summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-11 11:37:14 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-11 11:37:14 +0000
commit52b0935efe803609153bf0c040efbe7578695aff (patch)
tree1ddeb39ead6304d5ffe7629f62b75f71d0285e48 /target
parent0aa242fe20960cd313fcea8408679adbcf6bdcfd (diff)
downloadmaster-31e0f0ae-52b0935efe803609153bf0c040efbe7578695aff.tar.gz
master-31e0f0ae-52b0935efe803609153bf0c040efbe7578695aff.tar.bz2
master-31e0f0ae-52b0935efe803609153bf0c040efbe7578695aff.zip
brcm63xx: use dtb board detection for HW556
This requires individual images for each board version for now. Linux partition was shrunk to ensure writing thewrong image won't erase wifi calibration data. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42126
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/dts/hg556a-a.dts36
-rw-r--r--target/linux/brcm63xx/dts/hg556a-b.dts36
-rw-r--r--target/linux/brcm63xx/dts/hg556a-c.dts36
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile26
-rw-r--r--target/linux/brcm63xx/patches-3.14/534-board_hw556.patch52
-rw-r--r--target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/565-board_hw520.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch2
21 files changed, 151 insertions, 83 deletions
diff --git a/target/linux/brcm63xx/dts/hg556a-a.dts b/target/linux/brcm63xx/dts/hg556a-a.dts
new file mode 100644
index 0000000000..89e2698ed9
--- /dev/null
+++ b/target/linux/brcm63xx/dts/hg556a-a.dts
@@ -0,0 +1,36 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+ model = "Huawei EchoLife HG556a (version A)";
+ compatible = "huawei,hg556a-a", "brcm,bcm6358";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ linux@20000 {
+ label = "linux";
+ reg = <0x020000 0xec0000>;
+ };
+
+ caldata@ee0000 {
+ label = "caldata";
+ reg = <0xee0000 0x100000>;
+ read-only;
+ };
+
+ nvram@fe0000 {
+ label = "nvram";
+ reg = <0xfe0000 0x020000>;
+ };
+};
diff --git a/target/linux/brcm63xx/dts/hg556a-b.dts b/target/linux/brcm63xx/dts/hg556a-b.dts
new file mode 100644
index 0000000000..855dcd1f65
--- /dev/null
+++ b/target/linux/brcm63xx/dts/hg556a-b.dts
@@ -0,0 +1,36 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+ model = "Huawei EchoLife HG556a (version B)";
+ compatible = "huawei,hg556a-b", "brcm,bcm6358";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ linux@20000 {
+ label = "linux";
+ reg = <0x020000 0xec0000>;
+ };
+
+ caldata@ee0000 {
+ label = "caldata";
+ reg = <0xee0000 0x100000>;
+ read-only;
+ };
+
+ nvram@fe0000 {
+ label = "nvram";
+ reg = <0xfe0000 0x020000>;
+ };
+};
diff --git a/target/linux/brcm63xx/dts/hg556a-c.dts b/target/linux/brcm63xx/dts/hg556a-c.dts
new file mode 100644
index 0000000000..43e578d018
--- /dev/null
+++ b/target/linux/brcm63xx/dts/hg556a-c.dts
@@ -0,0 +1,36 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+ model = "Huawei EchoLife HG556a (version C)";
+ compatible = "huawei,hg556a-c", "brcm,bcm6358";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ linux@20000 {
+ label = "linux";
+ reg = <0x020000 0xec0000>;
+ };
+
+ caldata@ee0000 {
+ label = "caldata";
+ reg = <0xee0000 0x100000>;
+ read-only;
+ };
+
+ nvram@fe0000 {
+ label = "nvram";
+ reg = <0xfe0000 0x020000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 6ce7d957f9..9ee97d15a6 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -74,15 +74,6 @@ define Image/Build/CFEHW553
--block-size 0x20000 --image-offset $(4)
endef
-define Image/Build/CFEHW556
- # Generate the tagged image
- $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
- --output $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
- --boardid $(2) --chipid $(3) --entry $(LOADADDR) \
- --load-addr $(LOADADDR) --tag-version 8 --rsa-signature "$(5)" \
- --image-offset $(4) --info1 "$(6)" --block-size 0x20000
-endef
-
define Image/Build/CFEAGPF
# Generate the tagged image
$(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
@@ -229,6 +220,16 @@ define CfeImageDTB
TARGET_IMAGES += $(4)
endef
+define HW556ImageDTB
+ define Image/Build/$(2)
+ $$(call Image/Build/CFEDTB,$$(1),$(1),HW556,6358,$(2),EchoLife_HG556a,--image-offset 0x20000 --block-size 0x20000 --tag-version 8)
+ endef
+
+ TARGET_DTBS += $(1)
+ TARGET_IMAGES += $(2)
+endef
+
+
define Image/Build
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
# Various routers
@@ -351,9 +352,6 @@ define Image/Build
#HW553
$(call Image/Build/CFEHW553,$(1),HW553,6358,0x20000,HW553)
- #HW556
- $(call Image/Build/CFEHW556,$(1),HW556,6358,0x20000,EchoLife_HG556a,OpenWRT-$(REVISION))
-
# T-Com Speedport W 303V Typ B
$(call Image/Build/SPW303V,$(1),96358-502V,6358,SPW303V)
@@ -388,5 +386,9 @@ $(eval $(call CfeImageDTB,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
$(eval $(call CfeImageDTB,dsl-274xb-c,AW4139,6358,DSL274XB-C3))
# D-Link DVA-G3810BN/TL
$(eval $(call CfeImageDTB,dva-g3810bn_tl,96358VW,6358,DVAG3810BN))
+# Huawei HW556
+$(eval $(call HW556ImageDTB,hg556a-a,HW556-A))
+$(eval $(call HW556ImageDTB,hg556a-b,HW556-B))
+$(eval $(call HW556ImageDTB,hg556a-c,HW556-C))
$(eval $(call BuildImage))
diff --git a/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch b/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
index 0f303cae04..4f1e90cec6 100644
--- a/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
+++ b/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
@@ -8,7 +8,7 @@
#include <linux/platform_device.h>
#include <linux/spi/spi.h>
#include <linux/spi/spi_gpio.h>
-@@ -3006,6 +3007,492 @@ static struct board_info __initdata boar
+@@ -3006,6 +3007,495 @@ static struct board_info __initdata boar
},
};
@@ -104,6 +104,7 @@
+};
+static struct board_info __initdata board_HW556_A = {
+ .name = "HW556_A",
++ .of_board_id = "huawei,hg556a-a",
+ .expected_cpu_id = 0x6358,
+
+ .has_uart0 = 1,
@@ -231,6 +232,7 @@
+};
+static struct board_info __initdata board_HW556_B = {
+ .name = "HW556_B",
++ .of_board_id = "huawei,hg556a-b",
+ .expected_cpu_id = 0x6358,
+
+ .has_uart0 = 1,
@@ -365,6 +367,7 @@
+};
+static struct board_info __initdata board_HW556_C = {
+ .name = "HW556_C",
++ .of_board_id = "huawei,hg556a-c",
+ .expected_cpu_id = 0x6358,
+
+ .has_uart0 = 1,
@@ -501,7 +504,7 @@
/* T-Home Speedport W 303V Typ B */
static struct board_info __initdata board_spw303v = {
.name = "96358-502V",
-@@ -3446,6 +3933,10 @@ static const struct board_info __initcon
+@@ -3446,6 +3936,10 @@ static const struct board_info __initcon
&board_nb4_fxc_r2,
&board_ct6373_1,
&board_HW553,
@@ -512,51 +515,6 @@
&board_spw303v,
&board_DVAG3810BN,
#endif
-@@ -3465,13 +3956,37 @@ static void __init boardid_fixup(u8 *boo
- struct bcm_tag *tag = (struct bcm_tag *)(boot_addr + CFE_OFFSET_64K);
- char *board_name = (char *)bcm63xx_nvram_get_name();
-
-- if (BCMCPU_IS_6358() && (!strcmp(board_name, "96358VW"))) {
-- u8 *p = boot_addr + NB4_PID_OFFSET;
--
-- /* Extract nb4 PID */
-- if (!memcmp(p, "NB4-", 4)) {
-- memcpy(board_name, p, sizeof("NB4-XXX-rX"));
-- return;
-+ if (BCMCPU_IS_6358()) {
-+ if (!strcmp(board_name, "96358VW")) {
-+ u8 *p = boot_addr + NB4_PID_OFFSET;
-+
-+ /* Extract nb4 PID */
-+ if (!memcmp(p, "NB4-", 4)) {
-+ memcpy(board_name, p, sizeof("NB4-XXX-rX"));
-+ return;
-+ }
-+ } else if (!strcmp(board_name, "HW556")) {
-+ /*
-+ * HW556 has different wlan caldatas depending on
-+ * hardware version.
-+ * Detect hardware version and change board id
-+ */
-+ u8 cal_data_ath9k[4] = { 0xa5, 0x5a, 0, 0 };
-+ u8 cal_data_rt3062[4] = { 0x62, 0x30, 1, 0 };
-+
-+ if (!memcmp(boot_addr + 0xeffe00,
-+ &cal_data_rt3062, 4)) {
-+ /* Ralink 0xeffe00 */
-+ memcpy(board_name, "HW556_A", 7);
-+ } else if (!memcmp(boot_addr + 0xf7e000,
-+ &cal_data_ath9k, 4)) {
-+ /* Atheros 0xf7e000 */
-+ memcpy(board_name, "HW556_B", 7);
-+ } else if (!memcmp(boot_addr + 0xefe000,
-+ &cal_data_ath9k, 4)) {
-+ /* Atheros 0xefe000 */
-+ memcpy(board_name, "HW556_C", 7);
-+ }
- }
- }
-
--- a/drivers/mtd/bcm63xxpart.c
+++ b/drivers/mtd/bcm63xxpart.c
@@ -224,6 +224,11 @@ static int bcm63xx_parse_cfe_partitions(
diff --git a/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch b/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
index 77350e20e1..5a60a6ab58 100644
--- a/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
+++ b/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
@@ -61,7 +61,7 @@
#endif /* CONFIG_BCM63XX_CPU_6345 */
/*
-@@ -3895,6 +3949,7 @@ static const struct board_info __initcon
+@@ -3898,6 +3952,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6345
&board_96345gw2,
&board_rta770bw,
diff --git a/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch b/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
index cd23a2faea..98de734d8f 100644
--- a/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
+++ b/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
#endif /* CONFIG_BCM63XX_CPU_6328 */
/*
-@@ -3939,6 +4055,7 @@ static const struct board_info __initcon
+@@ -3942,6 +4058,7 @@ static const struct board_info __initcon
&board_963281TAN,
&board_A4001N1,
&board_dsl_274xb_f1,
diff --git a/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch b/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
index 70def81927..172cc6faae 100644
--- a/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
+++ b/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
---
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3894,6 +3894,96 @@ static struct board_info __initdata boar
+@@ -3897,6 +3897,96 @@ static struct board_info __initdata boar
.devs = nb6_devices,
.num_devs = ARRAY_SIZE(nb6_devices),
};
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
#endif /* CONFIG_BCM63XX_CPU_6362 */
/*
-@@ -4115,6 +4205,7 @@ static const struct board_info __initcon
+@@ -4118,6 +4208,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6362
&board_nb6,
diff --git a/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch b/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
index de927de0d6..2fe1ceb96b 100644
--- a/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
+++ b/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
@@ -94,7 +94,7 @@
* known 6328 boards
*/
#ifdef CONFIG_BCM63XX_CPU_6328
-@@ -4369,6 +4456,9 @@ static const struct board_info __initcon
+@@ -4372,6 +4459,9 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_3368
&board_cvg834g,
#endif
diff --git a/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch b/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
index 0bd0742682..94823f28fe 100644
--- a/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
+++ b/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
@@ -95,7 +95,7 @@
#endif /* CONFIG_BCM63XX_CPU_6318 */
/*
-@@ -4458,6 +4546,7 @@ static const struct board_info __initcon
+@@ -4461,6 +4549,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_6318
&board_96318ref,
diff --git a/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch b/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
index 278c4dc7f9..e7a2f82bb1 100644
--- a/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
+++ b/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4538,6 +4538,75 @@ static struct board_info __initdata boar
+@@ -4541,6 +4541,75 @@ static struct board_info __initdata boar
#endif /* CONFIG_BCM63XX_CPU_6368 */
/*
@@ -76,7 +76,7 @@
* all boards
*/
static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4622,6 +4691,9 @@ static const struct board_info __initcon
+@@ -4625,6 +4694,9 @@ static const struct board_info __initcon
&board_96368mvwg,
&board_96368mvngr,
#endif
diff --git a/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch b/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
index 9e6f320a7e..c52212a2f1 100644
--- a/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
+++ b/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
/* BT Voyager 2110 */
static struct board_info __initdata board_V2110 = {
-@@ -4658,6 +4704,7 @@ static const struct board_info __initcon
+@@ -4661,6 +4707,7 @@ static const struct board_info __initcon
&board_96348A_122,
&board_CPVA502plus,
&board_96348W3,
diff --git a/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch b/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
index 66f6eb6085..272ee5acd5 100644
--- a/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
+++ b/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4650,6 +4650,108 @@ static struct board_info __initdata boar
+@@ -4653,6 +4653,108 @@ static struct board_info __initdata boar
},
},
};
@@ -109,7 +109,7 @@
#endif /* CONFIG_BCM63XX_CPU_63268 */
/*
-@@ -4740,6 +4842,7 @@ static const struct board_info __initcon
+@@ -4743,6 +4845,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
&board_963269bhr,
diff --git a/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch b/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
index e1ca64630c..65c8add37f 100644
--- a/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
+++ b/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4587,6 +4587,131 @@ static struct board_info __initdata boar
+@@ -4590,6 +4590,131 @@ static struct board_info __initdata boar
* known 63268/63269 boards
*/
#ifdef CONFIG_BCM63XX_CPU_63268
@@ -132,7 +132,7 @@
static struct board_info __initdata board_963269bhr = {
.name = "963269BHR",
.expected_cpu_id = 0x63268,
-@@ -4841,6 +4966,7 @@ static const struct board_info __initcon
+@@ -4844,6 +4969,7 @@ static const struct board_info __initcon
&board_96368mvngr,
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
diff --git a/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch b/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
index f5cc1ad817..87c00698ee 100644
--- a/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
+++ b/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
@@ -8,7 +8,7 @@
#include <linux/platform_device.h>
#include <linux/spi/spi.h>
#include <linux/spi/spi_gpio.h>
-@@ -4581,6 +4582,117 @@ static struct board_info __initdata boar
+@@ -4584,6 +4585,117 @@ static struct board_info __initdata boar
.has_ohci0 = 1,
.has_ehci0 = 1,
};
@@ -126,7 +126,7 @@
#endif /* CONFIG_BCM63XX_CPU_6368 */
/*
-@@ -4964,6 +5076,7 @@ static const struct board_info __initcon
+@@ -4967,6 +5079,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
diff --git a/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch b/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
index c072d0b83b..2799f2277d 100644
--- a/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
+++ b/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4583,6 +4583,116 @@ static struct board_info __initdata boar
+@@ -4586,6 +4586,116 @@ static struct board_info __initdata boar
.has_ehci0 = 1,
};
@@ -117,7 +117,7 @@
static struct b53_platform_data WAP5813n_b53_pdata = {
.alias = "eth0",
};
-@@ -5076,6 +5186,7 @@ static const struct board_info __initcon
+@@ -5079,6 +5189,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
diff --git a/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch b/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
index 5cdcc12a06..286ae62f36 100644
--- a/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
+++ b/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4693,6 +4693,116 @@ static struct board_info __initdata boar
+@@ -4696,6 +4696,116 @@ static struct board_info __initdata boar
},
};
@@ -117,7 +117,7 @@
static struct b53_platform_data WAP5813n_b53_pdata = {
.alias = "eth0",
};
-@@ -5187,6 +5297,7 @@ static const struct board_info __initcon
+@@ -5190,6 +5300,7 @@ static const struct board_info __initcon
&board_96368mvwg,
&board_96368mvngr,
&board_VR3025u,
diff --git a/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch b/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
index 652c2b28dd..9b770cf1fe 100644
--- a/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
+++ b/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4592,6 +4592,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4595,6 +4595,96 @@ static struct sprom_fixup __initdata vr3
{ .offset = 115, .value = 0xfad9 },
};
@@ -97,7 +97,7 @@
static struct board_info __initdata board_VR3025u = {
.name = "96368M-1541N",
.expected_cpu_id = 0x6368,
-@@ -5296,6 +5386,7 @@ static const struct board_info __initcon
+@@ -5299,6 +5389,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
diff --git a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
index 1e026638da..e035f39d53 100644
--- a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
+++ b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
@@ -57,7 +57,7 @@
static struct board_info __initdata board_HW553 = {
.name = "HW553",
.expected_cpu_id = 0x6358,
-@@ -5369,6 +5419,7 @@ static const struct board_info __initcon
+@@ -5372,6 +5422,7 @@ static const struct board_info __initcon
&board_nb4_fxc_r1,
&board_nb4_fxc_r2,
&board_ct6373_1,
diff --git a/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch b/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
index d7eb88be6f..3369b5256f 100644
--- a/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
+++ b/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
@@ -96,7 +96,7 @@
static struct board_info __initdata board_A4001N1 = {
.name = "963281T_TEF",
.expected_cpu_id = 0x6328,
-@@ -5367,6 +5456,7 @@ static const struct board_info __initcon
+@@ -5370,6 +5459,7 @@ static const struct board_info __initcon
&board_AR5381u,
&board_AR5387un,
&board_963281TAN,
diff --git a/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch b/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
index a72edbc013..13fa11df08 100644
--- a/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
+++ b/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
@@ -142,7 +142,7 @@
#endif /* CONFIG_BCM63XX_CPU_6318 */
/*
-@@ -5450,6 +5585,7 @@ static const struct board_info __initcon
+@@ -5453,6 +5588,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6318
&board_96318ref,
&board_96318ref_p300,