summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-14 17:55:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-14 17:55:00 +0000
commit4919d469825f158dfbc903e7cdfa3372e8409ba3 (patch)
tree3dde6826df6ee62836fded0e77bbaa62fc3a4b1b /target
parent6d0dc3722118a0a91e5bfb8d3fbfd523dff53016 (diff)
downloadmaster-31e0f0ae-4919d469825f158dfbc903e7cdfa3372e8409ba3.tar.gz
master-31e0f0ae-4919d469825f158dfbc903e7cdfa3372e8409ba3.tar.bz2
master-31e0f0ae-4919d469825f158dfbc903e7cdfa3372e8409ba3.zip
Add the #1680 fix for GNU make versions
SVN-Revision: 7231
Diffstat (limited to 'target')
-rw-r--r--target/linux/at91-2.6/image/u-boot/patches/012-make_3.81.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/image/u-boot/patches/012-make_3.81.patch b/target/linux/at91-2.6/image/u-boot/patches/012-make_3.81.patch
new file mode 100644
index 0000000000..767493f901
--- /dev/null
+++ b/target/linux/at91-2.6/image/u-boot/patches/012-make_3.81.patch
@@ -0,0 +1,16 @@
+diff -urN u-boot-1.1.4.orig/examples/Makefile u-boot-1.1.4/examples/Makefile
+--- u-boot-1.1.4.orig/examples/Makefile 2007-05-13 13:45:44.000000000 +0200
++++ u-boot-1.1.4/examples/Makefile 2007-05-13 13:48:43.000000000 +0200
+@@ -123,10 +123,10 @@
+ $(LD) -g $(EX_LDFLAGS) -Ttext $(LOAD_ADDR) \
+ -o $@ -e $(<:.o=) $< $(LIB) \
+ -L$(gcclibdir) -lgcc
+-%.srec: %
++%.srec: %.o
+ $(OBJCOPY) -O srec $< $@ 2>/dev/null
+
+-%.bin: %
++%.bin: %.o
+ $(OBJCOPY) -O binary $< $@ 2>/dev/null
+
+ #########################################################################