summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-05-30 17:41:28 +0000
committerJohn Crispin <john@openwrt.org>2012-05-30 17:41:28 +0000
commit47ef62d1b82ea79dd807287264d22ec8e1826530 (patch)
treea645d4ea719e88d4ebe697474b72f180ee60d6f4 /target
parent5aefe3b277662416ea1a6e97292d4b360ef74c41 (diff)
downloadmaster-31e0f0ae-47ef62d1b82ea79dd807287264d22ec8e1826530.tar.gz
master-31e0f0ae-47ef62d1b82ea79dd807287264d22ec8e1826530.tar.bz2
master-31e0f0ae-47ef62d1b82ea79dd807287264d22ec8e1826530.zip
adds patch to make Tantos (psb6970) switch buildable again
SVN-Revision: 32006
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/config-3.31
-rw-r--r--target/linux/generic/patches-3.3/729-phy-tantos.patch24
-rw-r--r--target/linux/lantiq/config-3.31
3 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic/config-3.3 b/target/linux/generic/config-3.3
index c8886ff0ee..a4db291ccf 100644
--- a/target/linux/generic/config-3.3
+++ b/target/linux/generic/config-3.3
@@ -2162,6 +2162,7 @@ CONFIG_PRINTK=y
# CONFIG_PRINTK_TIME is not set
# CONFIG_PRISM2_USB is not set
# CONFIG_PRISM54 is not set
+# CONFIG_PSB6970_PHY is not set
# CONFIG_PROBE_INITRD_HEADER is not set
CONFIG_PROC_FS=y
# CONFIG_PROC_KCORE is not set
diff --git a/target/linux/generic/patches-3.3/729-phy-tantos.patch b/target/linux/generic/patches-3.3/729-phy-tantos.patch
new file mode 100644
index 0000000000..203b3e6ab8
--- /dev/null
+++ b/target/linux/generic/patches-3.3/729-phy-tantos.patch
@@ -0,0 +1,24 @@
+Index: linux-3.3.7/drivers/net/phy/Kconfig
+===================================================================
+--- linux-3.3.7.orig/drivers/net/phy/Kconfig 2012-05-27 18:09:00.129697447 +0200
++++ linux-3.3.7/drivers/net/phy/Kconfig 2012-05-29 18:31:44.462611635 +0200
+@@ -207,3 +207,7 @@
+ config MICREL_KS8995MA
+ tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
+ depends on SPI
++
++config PSB6970_PHY
++ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
++ select SWCONFIG
+Index: linux-3.3.7/drivers/net/phy/Makefile
+===================================================================
+--- linux-3.3.7.orig/drivers/net/phy/Makefile 2012-05-27 18:09:00.129697447 +0200
++++ linux-3.3.7/drivers/net/phy/Makefile 2012-05-29 18:30:59.286610634 +0200
+@@ -28,6 +28,7 @@
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
++obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
diff --git a/target/linux/lantiq/config-3.3 b/target/linux/lantiq/config-3.3
index d6ad3e701b..ce0b9ba905 100644
--- a/target/linux/lantiq/config-3.3
+++ b/target/linux/lantiq/config-3.3
@@ -107,3 +107,4 @@ CONFIG_SYS_SUPPORTS_BIG_ENDIAN=y
CONFIG_SYS_SUPPORTS_MULTITHREADING=y
CONFIG_XZ_DEC=y
CONFIG_ZONE_DMA_FLAG=0
+CONFIG_PSB6970_PHY=y