summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-13 07:29:10 +0000
committerJohn Crispin <john@openwrt.org>2015-02-13 07:29:10 +0000
commit45c912ba1318de470f164c1a1c9c176a5527e643 (patch)
treee014cfb21f6b469d61dfabd5b21d369127848262 /target
parentbd5635770c9042420c85f06bca1efb0ed3234889 (diff)
downloadmaster-31e0f0ae-45c912ba1318de470f164c1a1c9c176a5527e643.tar.gz
master-31e0f0ae-45c912ba1318de470f164c1a1c9c176a5527e643.tar.bz2
master-31e0f0ae-45c912ba1318de470f164c1a1c9c176a5527e643.zip
ar71xx: Add profile and build image for TP-Link MR12U v1
This patch adds corrected profile and build image for the TL-MR12U board. Unfortunately i cannot test the factory image since i can't find anywhere the original chinese firmware but the generated openwrt-ar71xx-generic-tl-mr12u-v1-squashfs-sysupgrade.bin worked just fine over a modified mr3040 factory image i managed to modify to initially flash the mr12u from the original firmware. Proper kernel support probably should be added since cat /proc/cpuinfo shows MR13U. Signed-off-by: Daniel Petre <daniel.petre@gmail.com> SVN-Revision: 44427
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk10
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index c7a65e4af2..5922f67399 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -48,6 +48,16 @@ define Profile/TLMR11U/Description
endef
$(eval $(call Profile,TLMR11U))
+define Profile/TLMR12U
+ NAME:=TP-LINK TL-MR12U
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR12U/Description
+ Package set optimized for the TP-LINK TL-MR12U.
+endef
+
+$(eval $(call Profile,TLMR12U))
define Profile/TLMR13U
NAME:=TP-LINK TL-MR13U
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 24e025e66a..c9af0d4981 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1386,6 +1386,7 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,MAC1200R,mc-mac1200r,MC-MAC1200R,
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR10U,tl-mr10u-v1,TL-MR10U,ttyATH0,115200,0x00100101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR11UV1,tl-mr11u-v1,TL-MR11U,ttyATH0,115200,0x00110101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR11UV2,tl-mr11u-v2,TL-MR11U,ttyATH0,115200,0x00110102,1,4Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR12U,tl-mr12u-v1,TL-MR13U,ttyATH0,115200,0x00120101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR13U,tl-mr13u-v1,TL-MR13U,ttyATH0,115200,0x00130101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR3020,tl-mr3020-v1,TL-MR3020,ttyATH0,115200,0x30200001,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR3040V1,tl-mr3040-v1,TL-MR3040,ttyATH0,115200,0x30400001,1,4Mlzma))