summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-03-13 17:13:11 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-03-13 17:13:11 +0000
commit425bf41b231233c8b4e8cf7b7ad90bba1f6b2653 (patch)
treeb89bc86eb1f6be17960d7ca4c1fe57f1c7afb13c /target
parentb78210955c6b2c6f54b0d71fea2c6d0ed7f00e76 (diff)
downloadmaster-31e0f0ae-425bf41b231233c8b4e8cf7b7ad90bba1f6b2653.tar.gz
master-31e0f0ae-425bf41b231233c8b4e8cf7b7ad90bba1f6b2653.tar.bz2
master-31e0f0ae-425bf41b231233c8b4e8cf7b7ad90bba1f6b2653.zip
kernel: update to kernel version 2.6.34.8
SVN-Revision: 26125
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm47xx/patches-2.6.34/977-ssb_export_fallback_sprom.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/014-cfi_fix_amd_extended_table_check.patch6
-rw-r--r--target/linux/generic/patches-2.6.34/020-mips_multi_machine_support.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/030-pci_disable_common_quirks.patch4
-rw-r--r--target/linux/generic/patches-2.6.34/040-arm-update-mach-types.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/100-netfilter_layer7_2.21.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/110-netfilter_match_speedup.patch8
-rw-r--r--target/linux/generic/patches-2.6.34/202-mips_mem_functions_performance.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/203-slab_maxsize.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/210-mini_fo_2.6.25_fixes.patch4
-rw-r--r--target/linux/generic/patches-2.6.34/212-mini_fo_2.6.26_fixes.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/223-kobject-add-broadcast_uevent.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/400-ledtrig_morse.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/402-ledtrig_netdev.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch76
-rw-r--r--target/linux/generic/patches-2.6.34/903-hostap_txpower.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/971-ocf_20100325.patch2
-rw-r--r--target/linux/generic/patches-2.6.34/975-ssb_update.patch4
-rw-r--r--target/linux/generic/patches-2.6.34/980-vm_exports.patch8
-rw-r--r--target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch2
-rw-r--r--target/linux/imx21/Makefile2
21 files changed, 69 insertions, 69 deletions
diff --git a/target/linux/brcm47xx/patches-2.6.34/977-ssb_export_fallback_sprom.patch b/target/linux/brcm47xx/patches-2.6.34/977-ssb_export_fallback_sprom.patch
index 2a22a3a38f..b13563d69d 100644
--- a/target/linux/brcm47xx/patches-2.6.34/977-ssb_export_fallback_sprom.patch
+++ b/target/linux/brcm47xx/patches-2.6.34/977-ssb_export_fallback_sprom.patch
@@ -10,7 +10,7 @@
bool ssb_is_sprom_available(struct ssb_bus *bus)
--- a/include/linux/ssb/ssb.h
+++ b/include/linux/ssb/ssb.h
-@@ -401,6 +401,7 @@ extern bool ssb_is_sprom_available(struc
+@@ -408,6 +408,7 @@ extern bool ssb_is_sprom_available(struc
/* Set a fallback SPROM.
* See kdoc at the function definition for complete documentation. */
extern int ssb_arch_set_fallback_sprom(const struct ssb_sprom *sprom);
diff --git a/target/linux/generic/patches-2.6.34/014-cfi_fix_amd_extended_table_check.patch b/target/linux/generic/patches-2.6.34/014-cfi_fix_amd_extended_table_check.patch
index 7010d367b8..2618fafeb9 100644
--- a/target/linux/generic/patches-2.6.34/014-cfi_fix_amd_extended_table_check.patch
+++ b/target/linux/generic/patches-2.6.34/014-cfi_fix_amd_extended_table_check.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -325,6 +325,8 @@ static struct cfi_fixup fixup_table[] =
+@@ -325,6 +325,8 @@ static struct cfi_fixup fixup_table[] =
static void cfi_fixup_major_minor(struct cfi_private *cfi,
struct cfi_pri_amdstd *extp)
{
@@ -9,7 +9,7 @@
if (cfi->mfr == CFI_MFR_SAMSUNG && cfi->id == 0x257e &&
extp->MajorVersion == '0')
extp->MajorVersion = '1';
-@@ -355,6 +357,9 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -355,6 +357,9 @@ struct mtd_info *cfi_cmdset_0002(struct
mtd->name = map->name;
mtd->writesize = 1;
@@ -19,7 +19,7 @@
if (cfi->cfi_mode==CFI_MODE_CFI){
unsigned char bootloc;
/*
-@@ -373,16 +378,24 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -373,16 +378,24 @@ struct mtd_info *cfi_cmdset_0002(struct
cfi_fixup_major_minor(cfi, extp);
diff --git a/target/linux/generic/patches-2.6.34/020-mips_multi_machine_support.patch b/target/linux/generic/patches-2.6.34/020-mips_multi_machine_support.patch
index ca0c10b20d..83e24451c1 100644
--- a/target/linux/generic/patches-2.6.34/020-mips_multi_machine_support.patch
+++ b/target/linux/generic/patches-2.6.34/020-mips_multi_machine_support.patch
@@ -176,7 +176,7 @@
unsigned int vced_count, vcei_count;
-@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
+@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
/*
* For the first processor also print the system type
*/
diff --git a/target/linux/generic/patches-2.6.34/030-pci_disable_common_quirks.patch b/target/linux/generic/patches-2.6.34/030-pci_disable_common_quirks.patch
index 945255b7f1..2f2b16c83e 100644
--- a/target/linux/generic/patches-2.6.34/030-pci_disable_common_quirks.patch
+++ b/target/linux/generic/patches-2.6.34/030-pci_disable_common_quirks.patch
@@ -23,7 +23,7 @@
/* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device.
-@@ -1904,7 +1905,9 @@ static void __devinit fixup_rev1_53c810(
+@@ -1924,7 +1925,9 @@ static void __devinit fixup_rev1_53c810(
}
}
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@@ -33,7 +33,7 @@
/* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{
-@@ -2560,6 +2563,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -2580,6 +2583,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
#endif /* CONFIG_PCI_IOV */
diff --git a/target/linux/generic/patches-2.6.34/040-arm-update-mach-types.patch b/target/linux/generic/patches-2.6.34/040-arm-update-mach-types.patch
index 1bae8c3fd6..0ebd307981 100644
--- a/target/linux/generic/patches-2.6.34/040-arm-update-mach-types.patch
+++ b/target/linux/generic/patches-2.6.34/040-arm-update-mach-types.patch
@@ -90,7 +90,7 @@
htc_excalibur_s620 MACH_HTC_EXCALIBUR_S620 HTC_EXCALIBUR_S620 2391
htc_opal MACH_HTC_OPAL HTC_OPAL 2392
touchbook MACH_TOUCHBOOK TOUCHBOOK 2393
-@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
+@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
siogentoo2 MACH_SIOGENTOO2 SIOGENTOO2 2459
sm3k MACH_SM3K SM3K 2460
acer_tempo_f900 MACH_ACER_TEMPO_F900 ACER_TEMPO_F900 2461
diff --git a/target/linux/generic/patches-2.6.34/100-netfilter_layer7_2.21.patch b/target/linux/generic/patches-2.6.34/100-netfilter_layer7_2.21.patch
index ce8853396a..a19ff620cb 100644
--- a/target/linux/generic/patches-2.6.34/100-netfilter_layer7_2.21.patch
+++ b/target/linux/generic/patches-2.6.34/100-netfilter_layer7_2.21.patch
@@ -71,7 +71,7 @@
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -90,6 +90,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
+@@ -90,6 +90,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
diff --git a/target/linux/generic/patches-2.6.34/110-netfilter_match_speedup.patch b/target/linux/generic/patches-2.6.34/110-netfilter_match_speedup.patch
index 8178a225ee..41c487b689 100644
--- a/target/linux/generic/patches-2.6.34/110-netfilter_match_speedup.patch
+++ b/target/linux/generic/patches-2.6.34/110-netfilter_match_speedup.patch
@@ -127,10 +127,11 @@
e = (struct ipt_entry *)(loc_cpu_entry + off);
if (copy_to_user(userptr + off
-@@ -1001,6 +1041,14 @@ copy_entries_to_user(unsigned int total_
+@@ -1000,6 +1040,14 @@ copy_entries_to_user(unsigned int total_
+ ret = -EFAULT;
goto free_counters;
}
-
++
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
+ if (copy_to_user(userptr + off
+ + offsetof(struct ipt_entry, ip.flags),
@@ -138,7 +139,6 @@
+ ret = -EFAULT;
+ goto free_counters;
+ }
-+
+
for (i = sizeof(struct ipt_entry);
i < e->target_offset;
- i += m->u.match_size) {
diff --git a/target/linux/generic/patches-2.6.34/202-mips_mem_functions_performance.patch b/target/linux/generic/patches-2.6.34/202-mips_mem_functions_performance.patch
index 6ea9ba51ee..e4324717b4 100644
--- a/target/linux/generic/patches-2.6.34/202-mips_mem_functions_performance.patch
+++ b/target/linux/generic/patches-2.6.34/202-mips_mem_functions_performance.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/include/asm/string.h
+++ b/arch/mips/include/asm/string.h
-@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
+@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
#define __HAVE_ARCH_MEMSET
extern void *memset(void *__s, int __c, size_t __count);
diff --git a/target/linux/generic/patches-2.6.34/203-slab_maxsize.patch b/target/linux/generic/patches-2.6.34/203-slab_maxsize.patch
index 83fd6c3099..fe8cecfc77 100644
--- a/target/linux/generic/patches-2.6.34/203-slab_maxsize.patch
+++ b/target/linux/generic/patches-2.6.34/203-slab_maxsize.patch
@@ -1,6 +1,6 @@
--- a/include/linux/slab.h
+++ b/include/linux/slab.h
-@@ -130,8 +130,8 @@ int kmem_ptr_validate(struct kmem_cache
+@@ -130,8 +130,8 @@ int kmem_ptr_validate(struct kmem_cache
* to do various tricks to work around compiler limitations in order to
* ensure proper constant folding.
*/
diff --git a/target/linux/generic/patches-2.6.34/210-mini_fo_2.6.25_fixes.patch b/target/linux/generic/patches-2.6.34/210-mini_fo_2.6.25_fixes.patch
index d71e3b6faa..b64630d500 100644
--- a/target/linux/generic/patches-2.6.34/210-mini_fo_2.6.25_fixes.patch
+++ b/target/linux/generic/patches-2.6.34/210-mini_fo_2.6.25_fixes.patch
@@ -61,7 +61,7 @@
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd);
-@@ -501,6 +505,29 @@ static inline void double_unlock(struct
+@@ -501,6 +505,29 @@ static inline void double_unlock(struct
#endif /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */
#endif /* __KERNEL__ */
@@ -127,7 +127,7 @@
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
--- a/fs/mini_fo/aux.c
+++ b/fs/mini_fo/aux.c
-@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
+@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd);
/* validate */
diff --git a/target/linux/generic/patches-2.6.34/212-mini_fo_2.6.26_fixes.patch b/target/linux/generic/patches-2.6.34/212-mini_fo_2.6.26_fixes.patch
index 8bd9ba3244..b5fa64e6a1 100644
--- a/target/linux/generic/patches-2.6.34/212-mini_fo_2.6.26_fixes.patch
+++ b/target/linux/generic/patches-2.6.34/212-mini_fo_2.6.26_fixes.patch
@@ -1,6 +1,6 @@
--- a/fs/mini_fo/super.c
+++ b/fs/mini_fo/super.c
-@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
+@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
diff --git a/target/linux/generic/patches-2.6.34/223-kobject-add-broadcast_uevent.patch b/target/linux/generic/patches-2.6.34/223-kobject-add-broadcast_uevent.patch
index d851d313ee..1dc655007e 100644
--- a/target/linux/generic/patches-2.6.34/223-kobject-add-broadcast_uevent.patch
+++ b/target/linux/generic/patches-2.6.34/223-kobject-add-broadcast_uevent.patch
@@ -20,7 +20,7 @@
#else
static inline int kobject_uevent(struct kobject *kobj,
enum kobject_action action)
-@@ -224,6 +230,16 @@ static inline int add_uevent_var(struct
+@@ -224,6 +230,16 @@ static inline int add_uevent_var(struct
static inline int kobject_action_type(const char *buf, size_t count,
enum kobject_action *type)
{ return -EINVAL; }
diff --git a/target/linux/generic/patches-2.6.34/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.34/400-ledtrig_morse.patch
index 4060e65d8c..3f43c90aca 100644
--- a/target/linux/generic/patches-2.6.34/400-ledtrig_morse.patch
+++ b/target/linux/generic/patches-2.6.34/400-ledtrig_morse.patch
@@ -11,7 +11,7 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -46,3 +46,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+@@ -46,3 +46,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
diff --git a/target/linux/generic/patches-2.6.34/402-ledtrig_netdev.patch b/target/linux/generic/patches-2.6.34/402-ledtrig_netdev.patch
index d2ceb087d7..001524681e 100644
--- a/target/linux/generic/patches-2.6.34/402-ledtrig_netdev.patch
+++ b/target/linux/generic/patches-2.6.34/402-ledtrig_netdev.patch
@@ -14,7 +14,7 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -47,3 +47,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
+@@ -47,3 +47,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
diff --git a/target/linux/generic/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch b/target/linux/generic/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch
index 5c70e79a05..c334b17d08 100644
--- a/target/linux/generic/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch
+++ b/target/linux/generic/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch
@@ -601,7 +601,7 @@
dev->checkpointBlockList[i] = -1;
}
-@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
+@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev)
{
@@ -926,7 +926,7 @@
{
unsigned char cDelta; /* column parity delta */
unsigned lDelta; /* line parity delta */
-@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
return 0; /* no error */
if (lDelta == ~lDeltaPrime &&
@@ -936,7 +936,7 @@
/* Single bit (recoverable) error in data */
bit = 0;
-@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
if (cDelta & 0x02)
bit |= 0x01;
@@ -945,7 +945,7 @@
return -1;
data[lDelta] ^= (1 << bit);
-@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
}
if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) +
@@ -954,7 +954,7 @@
/* Reccoverable error in ecc */
*read_ecc = *test_ecc;
-@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
/* Unrecoverable error */
return -1;
@@ -1398,7 +1398,7 @@
{
unsigned char *alias;
int ret;
-@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
+@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
return ret;
}
@@ -1560,7 +1560,7 @@
static int yaffs_file_flush(struct file *file, fl_owner_t id)
#else
static int yaffs_file_flush(struct file *file)
-@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
+@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
yaffs_Device *dev = obj->myDev;
T(YAFFS_TRACE_OS,
@@ -1571,7 +1571,7 @@
yaffs_GrossLock(dev);
-@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
+@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
yaffs_Device *dev;
@@ -1591,7 +1591,7 @@
BUG_ON(!PageLocked(pg));
#else
if (!PageLocked(pg))
-@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
+@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
yaffs_GrossLock(dev);
@@ -1604,7 +1604,7 @@
yaffs_GrossUnlock(dev);
-@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
+@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
flush_dcache_page(pg);
kunmap(pg);
@@ -3193,7 +3193,7 @@
if (n < step) {
n++;
continue;
-@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
+@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
char *end;
char *mask_name;
const char *x;
@@ -3202,7 +3202,7 @@
int i;
int done = 0;
int add, len = 0;
-@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
+@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
while (!done && (pos < count)) {
done = 1;
@@ -3213,7 +3213,7 @@
switch (buf[pos]) {
case '+':
-@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
+@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
mask_name = NULL;
mask_bitfield = simple_strtoul(buf + pos, &end, 0);
@@ -3240,7 +3240,7 @@
mask_name = mask_flags[i].mask_name;
mask_bitfield = mask_flags[i].mask_bitfield;
done = 0;
-@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
+@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
if (mask_name != NULL) {
done = 0;
@@ -3249,7 +3249,7 @@
case '-':
rg &= ~mask_bitfield;
break;
-@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
+@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS;
@@ -5691,7 +5691,7 @@
{
/* Get the real object in case we were fed a hard link as an equivalent object */
equivalentObject = yaffs_GetEquivalentObject(equivalentObject);
-@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
+@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
}
@@ -7622,7 +7622,7 @@
int nToCopy;
int n = nBytes;
int nDone = 0;
-@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
dev = in->myDev;
while (n > 0) {
@@ -7657,7 +7657,7 @@
if (dev->nShortOpCaches > 0) {
/* If we can't find the data in the cache, then load it up. */
-@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
cache->locked = 1;
@@ -7673,7 +7673,7 @@
cache->locked = 0;
} else {
/* Read into the local buffer then copy..*/
-@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
yaffs_GetTempBuffer(dev, __LINE__);
yaffs_ReadChunkDataFromObject(in, chunk,
localBuffer);
@@ -7718,7 +7718,7 @@
}
n -= nToCopy;
-@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
return nDone;
}
@@ -7923,7 +7923,7 @@
int newFullChunks;
yaffs_Device *dev = in->myDev;
-@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
+@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
yaffs_CheckGarbageCollection(dev);
@@ -7941,7 +7941,7 @@
if (newSize < oldFileSize) {
-@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
+@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
}
@@ -7968,7 +7968,7 @@
{
obj = yaffs_GetEquivalentObject(obj);
-@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
+@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
@@ -9789,7 +9789,7 @@
{
int init_failed = 0;
unsigned x;
-@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->chunkOffset = 0;
dev->nFreeChunks = 0;
@@ -9798,7 +9798,7 @@
if (dev->startBlock == 0) {
dev->internalStartBlock = dev->startBlock + 1;
dev->internalEndBlock = dev->endBlock + 1;
-@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
/* Check geometry parameters. */
@@ -9823,7 +9823,7 @@
return YAFFS_FAIL;
}
-@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
return YAFFS_FAIL;
}
@@ -9836,7 +9836,7 @@
/* Got the right mix of functions? */
if (!yaffs_CheckDevFunctions(dev)) {
/* Function missing */
-@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->isMounted = 1;
@@ -9875,7 +9875,7 @@
/*
* Calculate chunkGroupBits.
-@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
bits = ShiftsGE(x);
/* Set up tnode width if wide tnodes are enabled. */
@@ -9896,7 +9896,7 @@
dev->tnodeWidth = 16;
dev->tnodeMask = (1<<dev->tnodeWidth)-1;
-@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */
/* Initialise temporary buffers and caches. */
@@ -9905,7 +9905,7 @@
init_failed = 1;
dev->srCache = NULL;
-@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
if (!init_failed &&
dev->nShortOpCaches > 0) {
int i;
@@ -9940,7 +9940,7 @@
init_failed = 1;
dev->srLastUse = 0;
-@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->cacheHits = 0;
@@ -9979,7 +9979,7 @@
T(YAFFS_TRACE_ALWAYS,
(TSTR("yaffs: restored from checkpoint" TENDSTR)));
} else {
-@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->nBackgroundDeletions = 0;
dev->oldestDirtySequence = 0;
@@ -10011,7 +10011,7 @@
/* Clean up the mess */
T(YAFFS_TRACE_TRACING,
(TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR)));
-@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
}
@@ -10710,7 +10710,7 @@
{
if (etags) {
memset(etags, 0, sizeof(*etags));
-@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
+@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
* Returns YAFFS_OK or YAFFS_FAIL.
*/
int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev,
@@ -11038,14 +11038,14 @@
+ yaffs_UnpackTags2(tags, &pt);
+ }
+ }
-
-- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
++
+ if (localData)
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
+- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+-
if (retval == 0)
return YAFFS_OK;
else
diff --git a/target/linux/generic/patches-2.6.34/903-hostap_txpower.patch b/target/linux/generic/patches-2.6.34/903-hostap_txpower.patch
index b7e28d2cdb..8aa43c5242 100644
--- a/target/linux/generic/patches-2.6.34/903-hostap_txpower.patch
+++ b/target/linux/generic/patches-2.6.34/903-hostap_txpower.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/hostap/hostap_ap.c
+++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2336,13 +2336,13 @@ int prism2_ap_get_sta_qual(local_info_t
+@@ -2336,13 +2336,13 @@ int prism2_ap_get_sta_qual(local_info_t
addr[count].sa_family = ARPHRD_ETHER;
memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
if (sta->last_rx_silence == 0)
diff --git a/target/linux/generic/patches-2.6.34/971-ocf_20100325.patch b/target/linux/generic/patches-2.6.34/971-ocf_20100325.patch
index ccf01bd42a..bda63729c7 100644
--- a/target/linux/generic/patches-2.6.34/971-ocf_20100325.patch
+++ b/target/linux/generic/patches-2.6.34/971-ocf_20100325.patch
@@ -24,7 +24,7 @@
* All of these routines try to estimate how many bits of randomness a
* particular randomness source. They do this by keeping track of the
* first and second order deltas of the event timings.
-@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk
+@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk
}
#endif
diff --git a/target/linux/generic/patches-2.6.34/975-ssb_update.patch b/target/linux/generic/patches-2.6.34/975-ssb_update.patch
index e9b06d06bf..33ea39ce52 100644
--- a/target/linux/generic/patches-2.6.34/975-ssb_update.patch
+++ b/target/linux/generic/patches-2.6.34/975-ssb_update.patch
@@ -299,7 +299,7 @@
tx_ring_dma + size > DMA_BIT_MASK(30)) {
kfree(tx_ring);
goto out_err;
-@@ -2178,12 +2169,14 @@ static int __devinit b44_init_one(struct
+@@ -2176,12 +2167,14 @@ static int __devinit b44_init_one(struct
"Failed to powerup the bus\n");
goto err_out_free_dev;
}
@@ -385,7 +385,7 @@
u32 pmucap;
if (!(cc->capabilities & SSB_CHIPCO_CAP_PMU))
-@@ -516,15 +516,12 @@ void ssb_pmu_init(struct ssb_chipcommon
+@@ -516,15 +516,12 @@ void ssb_pmu_init(struct ssb_chipcommon
ssb_dprintk(KERN_DEBUG PFX "Found rev %u PMU (capabilities 0x%08X)\n",
cc->pmu.rev, pmucap);
diff --git a/target/linux/generic/patches-2.6.34/980-vm_exports.patch b/target/linux/generic/patches-2.6.34/980-vm_exports.patch
index 8f6376ecfb..3feb239e3f 100644
--- a/target/linux/generic/patches-2.6.34/980-vm_exports.patch
+++ b/target/linux/generic/patches-2.6.34/980-vm_exports.patch
@@ -76,7 +76,7 @@
* macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c
+++ b/kernel/sched.c
-@@ -4370,6 +4370,7 @@ int can_nice(const struct task_struct *p
+@@ -4339,6 +4339,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
capable(CAP_SYS_NICE));
}
@@ -104,7 +104,7 @@
* We enter with non-exclusive mmap_sem (to exclude vma changes,
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
-@@ -1173,6 +1173,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -1182,6 +1182,7 @@ void unmap_kernel_range(unsigned long ad
vunmap_page_range(addr, end);
flush_tlb_kernel_range(addr, end);
}
@@ -112,7 +112,7 @@
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
{
-@@ -1288,6 +1289,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1297,6 +1298,7 @@ struct vm_struct *get_vm_area(unsigned l
return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
-1, GFP_KERNEL, __builtin_return_address(0));
}
@@ -122,7 +122,7 @@
void *caller)
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
-@@ -728,6 +728,7 @@ extern void show_free_areas(void);
+@@ -732,6 +732,7 @@ extern void show_free_areas(void);
int shmem_lock(struct file *file, int lock, struct user_struct *user);
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
diff --git a/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch b/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch
index 0ac880caea..63834d65ea 100644
--- a/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch
+++ b/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch
@@ -1,6 +1,6 @@
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -238,7 +238,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -238,7 +238,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \
diff --git a/target/linux/imx21/Makefile b/target/linux/imx21/Makefile
index db508f8c9d..76b51ab8f6 100644
--- a/target/linux/imx21/Makefile
+++ b/target/linux/imx21/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX21
FEATURES:=jffs2
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
-LINUX_VERSION:=2.6.34.7
+LINUX_VERSION:=2.6.34.8
DEVICE_TYPE=phone