summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-03-17 15:07:36 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-03-17 15:07:36 +0000
commit4153768fd6dae493690203d15b60c3e4de9cdbf4 (patch)
tree002bb1148c42a8376cb2d74d8f3d54760e149ecf /target
parent8cb059a95863a50afea44a187cdda9a68bd0bdce (diff)
downloadmaster-31e0f0ae-4153768fd6dae493690203d15b60c3e4de9cdbf4.tar.gz
master-31e0f0ae-4153768fd6dae493690203d15b60c3e4de9cdbf4.tar.bz2
master-31e0f0ae-4153768fd6dae493690203d15b60c3e4de9cdbf4.zip
refresh patches
SVN-Revision: 20253
Diffstat (limited to 'target')
-rw-r--r--target/linux/xburst/patches-2.6.32/001-core.patch18
-rw-r--r--target/linux/xburst/patches-2.6.32/050-nand.patch1
-rw-r--r--target/linux/xburst/patches-2.6.32/103-serial.patch16
-rw-r--r--target/linux/xburst/patches-2.6.32/106-gpio-charger.patch12
4 files changed, 27 insertions, 20 deletions
diff --git a/target/linux/xburst/patches-2.6.32/001-core.patch b/target/linux/xburst/patches-2.6.32/001-core.patch
index 4ee44a5294..26863d87ed 100644
--- a/target/linux/xburst/patches-2.6.32/001-core.patch
+++ b/target/linux/xburst/patches-2.6.32/001-core.patch
@@ -30,9 +30,17 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/001-co
config LASAT
bool "LASAT Networks platforms"
select CEVT_R4K
+@@ -677,6 +680,7 @@ source "arch/mips/alchemy/Kconfig"
+ source "arch/mips/basler/excite/Kconfig"
+ source "arch/mips/bcm63xx/Kconfig"
+ source "arch/mips/jazz/Kconfig"
++source "arch/mips/jz4740/Kconfig"
+ source "arch/mips/lasat/Kconfig"
+ source "arch/mips/pmc-sierra/Kconfig"
+ source "arch/mips/sgi-ip27/Kconfig"
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -184,6 +184,14 @@ cflags-$(CONFIG_AR7) += -I$(srctree)/ar
+@@ -186,6 +186,14 @@ cflags-$(CONFIG_AR7) += -I$(srctree)/ar
load-$(CONFIG_AR7) += 0xffffffff94100000
#
@@ -47,7 +55,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/001-co
# Acer PICA 61, Mips Magnum 4000 and Olivetti M700.
#
core-$(CONFIG_MACH_JAZZ) += arch/mips/jazz/
-@@ -705,6 +713,12 @@ makeboot =$(Q)$(MAKE) $(build)=arch/mips
+@@ -704,6 +712,12 @@ makeboot =$(Q)$(MAKE) $(build)=arch/mips
all: $(all-y)
@@ -60,7 +68,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/001-co
vmlinux.bin: $(vmlinux-32)
+@$(call makeboot,$@)
-@@ -734,6 +748,7 @@ install:
+@@ -733,6 +747,7 @@ install:
archclean:
@$(MAKE) $(clean)=arch/mips/boot
@@ -68,7 +76,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/001-co
@$(MAKE) $(clean)=arch/mips/lasat
define archhelp
-@@ -741,6 +756,9 @@ define archhelp
+@@ -740,6 +755,9 @@ define archhelp
echo ' vmlinux.ecoff - ECOFF boot image'
echo ' vmlinux.bin - Raw binary boot image'
echo ' vmlinux.srec - SREC boot image'
@@ -533,7 +541,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/001-co
const char *__cpu_name[NR_CPUS];
__cpuinit void cpu_probe(void)
-@@ -939,6 +957,9 @@ __cpuinit void cpu_probe(void)
+@@ -939,6 +955,9 @@ __cpuinit void cpu_probe(void)
case PRID_COMP_CAVIUM:
cpu_probe_cavium(c, cpu);
break;
diff --git a/target/linux/xburst/patches-2.6.32/050-nand.patch b/target/linux/xburst/patches-2.6.32/050-nand.patch
index bdb1df8a3c..9a8662b0a0 100644
--- a/target/linux/xburst/patches-2.6.32/050-nand.patch
+++ b/target/linux/xburst/patches-2.6.32/050-nand.patch
@@ -31,4 +31,3 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/050-na
+obj-$(CONFIG_MTD_NAND_JZ4740) += jz4740_nand.o
nand-objs := nand_base.o nand_bbt.o
-
diff --git a/target/linux/xburst/patches-2.6.32/103-serial.patch b/target/linux/xburst/patches-2.6.32/103-serial.patch
index 2401248a12..2810631f64 100644
--- a/target/linux/xburst/patches-2.6.32/103-serial.patch
+++ b/target/linux/xburst/patches-2.6.32/103-serial.patch
@@ -9,7 +9,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
--- a/drivers/serial/8250.c
+++ b/drivers/serial/8250.c
-@@ -196,7 +196,7 @@ static const struct serial8250_config ua
+@@ -199,7 +199,7 @@ static const struct serial8250_config ua
[PORT_16550A] = {
.name = "16550A",
.fifo_size = 16,
@@ -18,7 +18,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
.flags = UART_CAP_FIFO,
},
-@@ -403,6 +403,10 @@ static unsigned int mem_serial_in(struct
+@@ -406,6 +406,10 @@ static unsigned int mem_serial_in(struct
static void mem_serial_out(struct uart_port *p, int offset, int value)
{
offset = map_8250_out_reg(p, offset) << p->regshift;
@@ -29,7 +29,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
writeb(value, p->membase + offset);
}
-@@ -2213,6 +2217,83 @@ static void serial8250_shutdown(struct u
+@@ -2214,6 +2218,83 @@ static void serial8250_shutdown(struct u
serial_unlink_irq_chain(up);
}
@@ -113,7 +113,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
static unsigned int serial8250_get_divisor(struct uart_port *port, unsigned int baud)
{
unsigned int quot;
-@@ -2232,6 +2313,7 @@ static unsigned int serial8250_get_divis
+@@ -2233,6 +2314,7 @@ static unsigned int serial8250_get_divis
return quot;
}
@@ -121,7 +121,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
static void
serial8250_set_termios(struct uart_port *port, struct ktermios *termios,
-@@ -2241,6 +2323,9 @@ serial8250_set_termios(struct uart_port
+@@ -2242,6 +2324,9 @@ serial8250_set_termios(struct uart_port
unsigned char cval, fcr = 0;
unsigned long flags;
unsigned int baud, quot;
@@ -131,7 +131,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
switch (termios->c_cflag & CSIZE) {
case CS5:
-@@ -2275,7 +2360,12 @@ serial8250_set_termios(struct uart_port
+@@ -2276,7 +2361,12 @@ serial8250_set_termios(struct uart_port
baud = uart_get_baud_rate(port, termios, old,
port->uartclk / 16 / 0xffff,
port->uartclk / 16);
@@ -144,7 +144,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
/*
* Oxford Semi 952 rev B workaround
-@@ -2353,6 +2443,10 @@ serial8250_set_termios(struct uart_port
+@@ -2354,6 +2444,10 @@ serial8250_set_termios(struct uart_port
if (up->capabilities & UART_CAP_UUE)
up->ier |= UART_IER_UUE | UART_IER_RTOIE;
@@ -155,7 +155,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-se
serial_out(up, UART_IER, up->ier);
if (up->capabilities & UART_CAP_EFR) {
-@@ -2387,7 +2481,15 @@ serial8250_set_termios(struct uart_port
+@@ -2388,7 +2482,15 @@ serial8250_set_termios(struct uart_port
serial_outp(up, UART_LCR, cval | UART_LCR_DLAB);/* set DLAB */
}
diff --git a/target/linux/xburst/patches-2.6.32/106-gpio-charger.patch b/target/linux/xburst/patches-2.6.32/106-gpio-charger.patch
index dd1713a4d6..641aba17c2 100644
--- a/target/linux/xburst/patches-2.6.32/106-gpio-charger.patch
+++ b/target/linux/xburst/patches-2.6.32/106-gpio-charger.patch
@@ -1,13 +1,13 @@
---- a/drivers/power/Makefile 2010-02-03 13:16:32.000000000 +0100
-+++ b/drivers/power/Makefile 2010-02-01 14:55:46.000000000 +0100
-@@ -30,3 +30,4 @@
+--- a/drivers/power/Makefile
++++ b/drivers/power/Makefile
+@@ -30,3 +30,4 @@ obj-$(CONFIG_BATTERY_DA9030) += da9030_b
obj-$(CONFIG_BATTERY_MAX17040) += max17040_battery.o
obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
obj-$(CONFIG_BATTERY_JZ4740) += jz4740-battery.o
+obj-$(CONFIG_CHARGER_GPIO) += gpio-charger.o
---- a/drivers/power/Kconfig 2010-02-03 13:16:32.000000000 +0100
-+++ b/drivers/power/Kconfig 2010-02-01 14:58:24.000000000 +0100
-@@ -121,4 +121,11 @@
+--- a/drivers/power/Kconfig
++++ b/drivers/power/Kconfig
+@@ -121,4 +121,11 @@ config BATTERY_JZ4740
This driver can be build as a module. If so, the module will be
called jz4740-battery.