summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-25 23:47:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-25 23:47:04 +0000
commit3be9b7712746486e377d87113cf40673d2317858 (patch)
tree930d9739c436240cb27ee51e5ff186bf53996c0b /target
parentdef45b136cf95d555d4e18bea7b5caa56155d0b7 (diff)
downloadmaster-31e0f0ae-3be9b7712746486e377d87113cf40673d2317858.tar.gz
master-31e0f0ae-3be9b7712746486e377d87113cf40673d2317858.tar.bz2
master-31e0f0ae-3be9b7712746486e377d87113cf40673d2317858.zip
kernel: remove all local symbols from kernel modules at link time to reduce their size
SVN-Revision: 26298
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch11
-rw-r--r--target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch2
-rw-r--r--target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch11
-rw-r--r--target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch2
4 files changed, 24 insertions, 2 deletions
diff --git a/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
new file mode 100644
index 0000000000..2e2508125d
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -360,7 +360,7 @@
+ KBUILD_AFLAGS := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE := -DMODULE
+ KBUILD_CFLAGS_MODULE := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
diff --git a/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch b/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
index 861a6b7538..47f796a909 100644
--- a/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
+++ b/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
@@ -3,7 +3,7 @@
@@ -361,6 +361,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+KBUILD_LDFLAGS_MODULE_PREREQ :=
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
diff --git a/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
new file mode 100644
index 0000000000..86a3e2f1f8
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -361,7 +361,7 @@
+ KBUILD_AFLAGS := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE := -DMODULE
+ KBUILD_CFLAGS_MODULE := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
diff --git a/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch b/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch
index 402cd0cacb..2d3a67d12b 100644
--- a/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch
+++ b/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch
@@ -3,7 +3,7 @@
@@ -362,6 +362,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+KBUILD_LDFLAGS_MODULE_PREREQ :=
# Read KERNELRELEASE from include/config/kernel.release (if it exists)