summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-10-28 16:53:13 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-10-28 16:53:13 +0000
commit3166a619460dd4a2e43b60c0c953df798d5549b1 (patch)
tree0295cadfc0285a65900400889dd3cab6a95d7fd9 /target
parent349e61e681e5850c8687745b51a0d2f8d86144c4 (diff)
downloadmaster-31e0f0ae-3166a619460dd4a2e43b60c0c953df798d5549b1.tar.gz
master-31e0f0ae-3166a619460dd4a2e43b60c0c953df798d5549b1.tar.bz2
master-31e0f0ae-3166a619460dd4a2e43b60c0c953df798d5549b1.zip
Prepare image Makefile to generate valid images for amit and g570s boards, thanks sn9
SVN-Revision: 13059
Diffstat (limited to 'target')
-rw-r--r--target/linux/rdc/image/Makefile26
1 files changed, 21 insertions, 5 deletions
diff --git a/target/linux/rdc/image/Makefile b/target/linux/rdc/image/Makefile
index f1fed220e7..ecfe7ffa77 100644
--- a/target/linux/rdc/image/Makefile
+++ b/target/linux/rdc/image/Makefile
@@ -30,9 +30,8 @@ endef
define Image/Build/ar525w
touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
- mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
- dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
- $(RM) $(KDIR)/root.tmp
+ dd if=$(KDIR)/root.$(1) of=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
+ mv $(KDIR)/root.tmp $(KDIR)/root.$(1)
$(STAGING_DIR_HOST)/bin/airlink -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
$(STAGING_DIR_HOST)/bin/airlink -e -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
endef
@@ -52,10 +51,27 @@ endef
define Image/Build/dir450
touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+ dd if=$(KDIR)/root.$(1) of=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
+ mv $(KDIR)/root.tmp $(KDIR)/root.$(1)
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/onlyrootfs-$(BOARD)-$(1)-$(2).img
+endef
+
+define Image/Build/g570s
mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
- $(RM) $(KDIR)/root.tmp
- cp $(KDIR)/root.$(1) $(BIN_DIR)/onlyrootfs-$(BOARD)-$(1)-$(2).img
+ $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-tftp-$(BOARD)-$(1)-$(2).img
+ dd of=$(BIN_DIR)/openwrt-tftp-$(BOARD)-$(1)-$(2).img if=/dev/null bs=1024 seek=1024
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-tftp-$(BOARD)-$(1)-$(2).img
+ if [ ! -x $(STAGING_DIR_HOST)/bin/zyxel_combine ]; then echo "#ERR Please copy the ZyXEL \"combine\" tool as $(STAGING_DIR_HOST)/bin/zyxel_combine to build."; fi
+ sh -c "mkdir $(KDIR)/zyxel.tmp && cd $(KDIR)/zyxel.tmp && mv ../root.tmp initrd.bin && cp ../bzImage kernel.bin && $(STAGING_DIR_HOST)/bin/zyxel_combine -mcf kernel.bin initrd.bin && mv image $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).rmt" || :
+ $(RM) -r $(KDIR)/zyxel.tmp
+endef
+
+define Image/Build/amit
+ if [ ! -x $(STAGING_DIR_HOST)/bin/amit_makebin ]; then echo "#ERR Please copy the AMIT \"makebin\" tool from http://mgb111.pradnik.net/ as $(STAGING_DIR_HOST)/bin/amit_makebin to build."; fi
+ sh -c "mkdir -p $(KDIR)/amit.tmp/linux_src/arch/i386/boot $(KDIR)/amit.tmp/rom_disk && cd $(KDIR)/amit.tmp && ln -s ../../root.$(1) rom_disk/fs.img && ln -s ../../../../../bzImage linux_src/arch/i386/boot && $(STAGING_DIR_HOST)/bin/amit_makebin && mv upgrade.img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-anas350.bin" || :
+ $(RM) -r $(KDIR)/amit.tmp
+ $(STAGING_DIR_HOST)/bin/makeamitbin -o $(BIN_DIR)/openwrt-$(BOARD)-$(1)-ar360w3g.bin -1 ALK_ATG001 -2 Atropos linux3g $(KDIR)/bzImage ramdisk3g $(KDIR)/root.$(1)
endef
define Image/Build