summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJimmy Zhong <mb300sd@mb300sd.net>2016-08-03 13:58:01 -0400
committerJohn Crispin <john@phrozen.org>2016-08-10 03:03:50 +0200
commit2b1f4945b155ffee7f9c7f44bb90e5498b880ff5 (patch)
treecbf0bc8cb880f782c52a478c497b674b8d41c1b7 /target
parent5947f7f85e191f8392847a199ad40a6de7be9408 (diff)
downloadmaster-31e0f0ae-2b1f4945b155ffee7f9c7f44bb90e5498b880ff5.tar.gz
master-31e0f0ae-2b1f4945b155ffee7f9c7f44bb90e5498b880ff5.tar.bz2
master-31e0f0ae-2b1f4945b155ffee7f9c7f44bb90e5498b880ff5.zip
ramips: Add support for TEW-714TRU
Signed-off-by: Jimmy Zhong <mb300sd@mb300sd.net>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/TEW-714TRU.dts122
-rw-r--r--target/linux/ramips/image/rt305x.mk6
6 files changed, 137 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 9624b1c64a..97c405d3fd 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -269,6 +269,10 @@ rt-n14u)
set_wifi_led "$board:blue:air"
set_usb_led "$board:blue:usb"
;;
+tew-714tru)
+ set_usb_led "$board:red:usb"
+ set_wifi_led "$board:green:wifi"
+ ;;
tiny-ac)
set_wifi_led "$board:orange:wifi"
set_usb_led "$board:green:usb"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index a404af9fbc..6aba1b0b1d 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -212,6 +212,7 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "0@eth0"
;;
+ tew-714tru|\
v11st-fe|\
wzr-agl300nh)
ucidef_add_switch "switch0" \
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 565d5138cb..1ea4fb2d71 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -403,6 +403,9 @@ ramips_board_detect() {
*"TEW-692GR")
name="tew-692gr"
;;
+ *"TEW-714TRU")
+ name="tew-714tru"
+ ;;
*"UBNT-ERX")
name="ubnt-erx"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 88547ca083..d9adf184d4 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -118,6 +118,7 @@ platform_check_image() {
sl-r7205|\
tew-691gr|\
tew-692gr|\
+ tew-714tru|\
tiny-ac|\
ur-326n4g|\
ur-336un|\
diff --git a/target/linux/ramips/dts/TEW-714TRU.dts b/target/linux/ramips/dts/TEW-714TRU.dts
new file mode 100644
index 0000000000..0e0f066518
--- /dev/null
+++ b/target/linux/ramips/dts/TEW-714TRU.dts
@@ -0,0 +1,122 @@
+/dts-v1/;
+
+#include "rt5350.dtsi"
+
+/ {
+ compatible = "TEW-714TRU", "ralink,rt5350-soc";
+ model = "TRENDnet TEW714TRU";
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ usb {
+ label = "tew-714tru:red:usb";
+ gpios = <&gpio0 9 1>;
+ };
+
+ wifi {
+ label = "tew-714tru:green:wifi";
+ gpios = <&gpio0 13 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 1>;
+ linux,code = <0x198>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x211>;
+ };
+ };
+
+ gpio_export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ repeater {
+ gpio-export,name = "repeater_switch";
+ gpios = <&gpio0 7 0>;
+ };
+
+ wisp {
+ gpio-export,name = "wisp_switch";
+ gpios = <&gpio0 12 0>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ linux,modalias = "m25p80", "s25fl064k";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "jtag", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x4>;
+};
+
+&esw {
+ mediatek,portmap = <0x1>;
+ mediatek,portdisable = <0x3e>;
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 8b08cc2981..82e77da682 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -418,6 +418,12 @@ define Device/sl-r7205
endef
TARGET_DEVICES += sl-r7205
+define Device/tew-714tru
+ DTS := TEW-714TRU
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := TRENDnet TEW-714TRU
+endef
+TARGET_DEVICES += tew-714tru
define Device/v22rw-2x2
DTS := V22RW-2X2