summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2010-03-18 11:20:35 +0000
committerJohn Crispin <john@openwrt.org>2010-03-18 11:20:35 +0000
commit2a89598ce5a91a1b718de438bcb106db3d71f66c (patch)
tree2dc826198a4e26d96403ef21b5e3e2e218c6681e /target
parentceffb972eb8e0b15755d5a474b889d7824397330 (diff)
downloadmaster-31e0f0ae-2a89598ce5a91a1b718de438bcb106db3d71f66c.tar.gz
master-31e0f0ae-2a89598ce5a91a1b718de438bcb106db3d71f66c.tar.bz2
master-31e0f0ae-2a89598ce5a91a1b718de438bcb106db3d71f66c.zip
Also build jffs2 images with 128k eraseblock size, signed off by Ithamar R. Adema
SVN-Revision: 20267
Diffstat (limited to 'target')
-rw-r--r--target/linux/ifxmips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ifxmips/image/Makefile b/target/linux/ifxmips/image/Makefile
index 15e0bc5dc3..ac887c4e49 100644
--- a/target/linux/ifxmips/image/Makefile
+++ b/target/linux/ifxmips/image/Makefile
@@ -27,6 +27,11 @@ define Image/Build/jffs2-64k
cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).image
endef
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/uImage of=$(KDIR)/uImage.$(1) bs=128k conv=sync
+ cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).image
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef