summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-10-18 08:48:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-10-18 08:48:07 +0000
commit279c5dad253eef51ce4f9673b4bb5f45db829c7d (patch)
tree3c81f53d9e4a7bd97eea1a0e62fc86d86635b63e /target
parent94cdcbde6d2fa931d27a239452ef794ab35f46ef (diff)
downloadmaster-31e0f0ae-279c5dad253eef51ce4f9673b4bb5f45db829c7d.tar.gz
master-31e0f0ae-279c5dad253eef51ce4f9673b4bb5f45db829c7d.tar.bz2
master-31e0f0ae-279c5dad253eef51ce4f9673b4bb5f45db829c7d.zip
ramips: add preliminary support for the DIR-300 revB board
SVN-Revision: 18058
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h3
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/common/prom.c3
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c98
-rw-r--r--target/linux/ramips/rt305x/config-2.6.301
6 files changed, 111 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index 60691818e5..4241f57b97 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -13,6 +13,9 @@ enum ramips_mach_type {
/* RT2880 based machines */
RAMIPS_MACH_RT_N15, /* Asus RT-N15 */
+ /* RT3050 based machines */
+ RAMIPS_MACH_DIR_300_REVB, /* D-Link DIR-300 rev B */
+
/* RT3052 based machines */
RAMIPS_MACH_V22RW_2X2, /* Ralink AP-RT3052-V22RW-2X2 */
RAMIPS_MACH_WHR_G300N, /* Buffalo WHR-G300N */
diff --git a/target/linux/ramips/files/arch/mips/ralink/common/prom.c b/target/linux/ramips/files/arch/mips/ralink/common/prom.c
index 923673b9ae..20b8d5fb64 100644
--- a/target/linux/ramips/files/arch/mips/ralink/common/prom.c
+++ b/target/linux/ramips/files/arch/mips/ralink/common/prom.c
@@ -33,6 +33,9 @@ static struct board_rec boards[] __initdata = {
.name = "RT-N15",
.mach_type = RAMIPS_MACH_RT_N15,
}, {
+ .name = "DIR-300-revB",
+ .mach_type = RAMIPS_MACH_DIR_300_REVB,
+ }, {
.name = "V22RW-2X2",
.mach_type = RAMIPS_MACH_V22RW_2X2,
}, {
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index 44f70567b7..383f79d2b6 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -7,6 +7,11 @@ config RT305X_MACH_WHR_G300N
default y
select RALINK_DEV_GPIO_LEDS
+config RT305X_MACH_DIR_300_REVB
+ bool "D-Link DIR-300 revB board support"
+ default y
+ select RALINK_DEV_GPIO_LEDS
+
config RT305X_MACH_V22RW_2X2
bool "Ralink AP-RT3052-V22RW-2X2 board support"
default y
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index 67bcbf6f6f..4eeaf21390 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -11,5 +11,6 @@ obj-y := irq.o setup.o devices.o rt305x.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
obj-$(CONFIG_RT305X_MACH_V22RW_2X2) += mach-v22rw-2x2.o
obj-$(CONFIG_RT305X_MACH_WHR_G300N) += mach-whr-g300n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c
new file mode 100644
index 0000000000..e807b94c7b
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c
@@ -0,0 +1,98 @@
+/*
+ * D-Link DIR-300 rev B board support
+ *
+ * Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+#include <linux/leds.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev_gpio_leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define DIR_300B_GPIO_LED_STATUS_AMBER 8
+#define DIR_300B_GPIO_LED_STATUS_GREEN 9
+#define DIR_300B_GPIO_LED_WPS 13
+
+#define DIR_300B_GPIO_BUTTON_WPS 0 /* active low */
+#define DIR_300B_GPIO_BUTTON_RESET 10 /* active low */
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition dir_300b_partitions[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = 0x030000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "devdata",
+ .offset = 0x030000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "devconf",
+ .offset = 0x040000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "kernel",
+ .offset = 0x050000,
+ .size = 0x090000,
+ }, {
+ .name = "rootfs",
+ .offset = 0x140000,
+ .size = 0x2B0000,
+ }, {
+ .name = "openwrt",
+ .offset = 0x050000,
+ .size = 0x3a0000,
+ }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data dir_300b_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+ .nr_parts = ARRAY_SIZE(dir_300b_partitions),
+ .parts = dir_300b_partitions,
+#endif
+};
+
+static struct gpio_led dir_300b_leds_gpio[] __initdata = {
+ {
+ .name = "dir-300b:amber:status",
+ .gpio = DIR_300B_GPIO_LED_STATUS_AMBER,
+ .active_low = 1,
+ }, {
+ .name = "dir-300b:green:status",
+ .gpio = DIR_300B_GPIO_LED_STATUS_GREEN,
+ .active_low = 1,
+ }, {
+ .name = "dir-300b:blue:wps",
+ .gpio = DIR_300B_GPIO_LED_WPS,
+ .active_low = 1,
+ }
+};
+
+static void __init dir_300b_init(void)
+{
+ rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+ rt305x_register_flash(0, &dir_300b_flash_data);
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(dir_300b_leds_gpio),
+ dir_300b_leds_gpio);
+}
+
+MIPS_MACHINE(RAMIPS_MACH_DIR_300_REVB, "D-Link DIR-300 revB", dir_300b_init);
diff --git a/target/linux/ramips/rt305x/config-2.6.30 b/target/linux/ramips/rt305x/config-2.6.30
index db867b7116..1ce0825cbb 100644
--- a/target/linux/ramips/rt305x/config-2.6.30
+++ b/target/linux/ramips/rt305x/config-2.6.30
@@ -115,6 +115,7 @@ CONFIG_PHYLIB=y
CONFIG_RALINK_DEV_GPIO_LEDS=y
# CONFIG_RALINK_RT288X is not set
CONFIG_RALINK_RT305X=y
+CONFIG_RT305X_MACH_DIR_300_REVB=y
CONFIG_RT305X_MACH_V22RW_2X2=y
CONFIG_RT305X_MACH_WHR_G300N=y
CONFIG_SCHED_OMIT_FRAME_POINTER=y