summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-08-06 19:07:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-08-06 19:07:47 +0000
commit21d2934f38a2e8526028a3f4ce69196062a79dc9 (patch)
treef3593cb1bc8ca1c2e61146a45a16a3a6ec42897e /target
parent49ad8232fba39107bf238a00dca58ddaa9c1428a (diff)
downloadmaster-31e0f0ae-21d2934f38a2e8526028a3f4ce69196062a79dc9.tar.gz
master-31e0f0ae-21d2934f38a2e8526028a3f4ce69196062a79dc9.tar.bz2
master-31e0f0ae-21d2934f38a2e8526028a3f4ce69196062a79dc9.zip
create firmware image for the WRT160NL board (thanks to Gerry Rozema)
SVN-Revision: 17151
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d1d4b47fd4..816f27e63a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -159,6 +159,26 @@ define Image/Build/TPLINK
-o $(call imgname,$(1),$(2)).uni
endef
+define Image/Build/CyberTAN
+ cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
+ gzip -9 -c $(KDIR)/vmlinux-$(2) > $(KDIR)/vmlinux-$(2).bin.gzip
+ mkimage -A mips -O linux -T kernel -a 0x80060000 -C gzip -e \
+ 0x80060000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux-$(2).bin.gzip $(KDIR)/vmlinux-$(2).uImage
+ ( \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=64k conv=sync; \
+ dd if=/dev/zero bs=1 count=65476; \
+ dd if=$(KDIR)/root.$(1) bs=64k; \
+ ) > $(KDIR)/vmlinux-$(2).image
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/vmlinux-$(2).trx \
+ -f $(KDIR)/vmlinux-$(2).image
+ -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) -g \
+ -i $(KDIR)/vmlinux-$(2).trx \
+ -o $(call imgname,$(1),$(2)).bin
+endef
+
define Image/Build/Template/Compex
$(call Image/Build/MyLoader,$(1),$(2))
endef
@@ -179,6 +199,18 @@ define Image/Build/Template/WRT400N/jffs2-64k
$(call Image/Build/Template/WRT400N,jffs2-64k,$(1),$(2),$(3))
endef
+define Image/Build/Template/CyberTAN
+ $(call Image/Build/CyberTAN,$(1),$(2),$(3),$(4))
+endef
+
+define Image/Build/Template/CyberTAN/squashfs
+ $(call Image/Build/Template/CyberTAN,squashfs,$(1),$(2),$(3))
+endef
+
+define Image/Build/Template/CyberTAN/jffs2-64k
+ $(call Image/Build/Template/CyberTAN,jffs2-64k,$(1),$(2),$(3))
+endef
+
define Image/Build/Template/AP81
$(call Image/Build/AP81,$(1),$(2),$(3),$(4))
endef
@@ -305,6 +337,10 @@ define Image/Build/Profile/WRT400N
$(call Image/Build/Template/WRT400N/$(1),wrt400n,board=WRT400N)
endef
+define Image/Build/Profile/WRT160NL
+ $(call Image/Build/Template/CyberTAN/$(1),wrt160nl,board=WRT160NL,1.00.01)
+endef
+
define Image/Build/Profile/Default
$(call Image/Build/Profile/AP83,$(1))
$(call Image/Build/Profile/A02RBW300N,$(1))
@@ -319,6 +355,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/UBNT,$(1))
$(call Image/Build/Profile/WP543,$(1))
$(call Image/Build/Profile/WRT400N,$(1))
+ $(call Image/Build/Profile/WRT160NL,$(1))
endef
define Image/Build/Profile/Madwifi