summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-08-22 15:37:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-08-22 15:37:19 +0000
commit184c6b06f2bb29b693084174908c7a0f1b46e3d2 (patch)
treeeb6e3d897cf739fd60e1728c475b35141a76b0a4 /target
parentbe1a9ff41dfeed9e00f165e6a661e26ccaa5549c (diff)
downloadmaster-31e0f0ae-184c6b06f2bb29b693084174908c7a0f1b46e3d2.tar.gz
master-31e0f0ae-184c6b06f2bb29b693084174908c7a0f1b46e3d2.tar.bz2
master-31e0f0ae-184c6b06f2bb29b693084174908c7a0f1b46e3d2.zip
update to 2.6.26.3 and 2.6.25.16
SVN-Revision: 12371
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120/Makefile4
-rw-r--r--target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch2
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-2.6.26/140-redboot_partition_scan.patch4
-rw-r--r--target/linux/at91/Makefile2
-rw-r--r--target/linux/at91/patches-2.6.25/017-usb_serial_endpoint_size.patch2
-rw-r--r--target/linux/atheros/Makefile2
-rw-r--r--target/linux/atheros/patches-2.6.26/120-watchdog.patch12
-rw-r--r--target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch4
-rw-r--r--target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch4
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/avr32/Makefile2
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/etrax/Makefile2
-rw-r--r--target/linux/generic-2.6/config-2.6.262
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/208-rtl8110sb_fix.patch8
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/801-usb_serial_endpoint_size.patch4
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/071-redboot_boardconfig.patch12
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/208-rtl8110sb_fix.patch8
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch4
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/910-cryptodev_backport.patch4
-rw-r--r--target/linux/ifxmips/Makefile2
-rw-r--r--target/linux/iop32x/Makefile2
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/116-sidewinder_fis_location.patch10
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/162-wg302v1_mem_fixup.patch4
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/192-cambria_gpio_device.patch2
-rw-r--r--target/linux/magicbox/Makefile2
-rw-r--r--target/linux/orion/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc44x/Makefile2
-rw-r--r--target/linux/ps3/Makefile2
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch6
-rw-r--r--target/linux/x86/Makefile2
37 files changed, 64 insertions, 70 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index f87f9eaf80..2947308f8e 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-#LINUX_VERSION:=2.6.25.15
-LINUX_VERSION:=2.6.26.2
+#LINUX_VERSION:=2.6.25.16
+LINUX_VERSION:=2.6.26.3
SUBTARGETS:=router_le router_be
INITRAMFS_EXTRA_FILES:=
diff --git a/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch b/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch
index 7f31c9bf94..40728a9707 100644
--- a/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch
+++ b/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch
@@ -39,7 +39,7 @@
/* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{
-@@ -1929,3 +1932,4 @@
+@@ -1934,3 +1937,4 @@
quirk_msi_intx_disable_bug);
#endif /* CONFIG_PCI_MSI */
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index f6da812123..8d48a2addb 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -11,7 +11,7 @@ BOARD:=ar7
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 66b1efc24d..1572c84319 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=ar71xx
BOARDNAME:=Atheros AR71xx
FEATURES:=squashfs tgz broken
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-2.6.26/140-redboot_partition_scan.patch b/target/linux/ar71xx/patches-2.6.26/140-redboot_partition_scan.patch
index baf8026a39..3e89407d0d 100644
--- a/target/linux/ar71xx/patches-2.6.26/140-redboot_partition_scan.patch
+++ b/target/linux/ar71xx/patches-2.6.26/140-redboot_partition_scan.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
-@@ -59,31 +59,32 @@
+@@ -62,31 +62,32 @@
static char nullstring[] = "unallocated";
#endif
@@ -40,7 +40,7 @@
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
master->name, offset);
-@@ -155,6 +156,11 @@
+@@ -158,6 +159,11 @@
}
if (i == numslots) {
/* Didn't find it */
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index 90d10088d5..4385a1763a 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -11,7 +11,7 @@ BOARD:=at91
BOARDNAME:=Atmel AT91
FEATURES:=squashfs usb
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/at91/patches-2.6.25/017-usb_serial_endpoint_size.patch b/target/linux/at91/patches-2.6.25/017-usb_serial_endpoint_size.patch
index 412490ffa1..d698763c68 100644
--- a/target/linux/at91/patches-2.6.25/017-usb_serial_endpoint_size.patch
+++ b/target/linux/at91/patches-2.6.25/017-usb_serial_endpoint_size.patch
@@ -1,6 +1,6 @@
--- a/drivers/usb/serial/usb-serial.c
+++ b/drivers/usb/serial/usb-serial.c
-@@ -905,7 +905,7 @@
+@@ -904,7 +904,7 @@
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index 1544f82164..e4e2a423ce 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -11,7 +11,7 @@ BOARD:=atheros
BOARDNAME:=Atheros 231x/5312
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/atheros/patches-2.6.26/120-watchdog.patch b/target/linux/atheros/patches-2.6.26/120-watchdog.patch
index 64ac6871ce..d99b8c7813 100644
--- a/target/linux/atheros/patches-2.6.26/120-watchdog.patch
+++ b/target/linux/atheros/patches-2.6.26/120-watchdog.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.26.2/drivers/watchdog/Kconfig
-===================================================================
---- linux-2.6.26.2.orig/drivers/watchdog/Kconfig 2008-08-14 16:54:30.000000000 +0200
-+++ linux-2.6.26.2/drivers/watchdog/Kconfig 2008-08-14 16:55:40.000000000 +0200
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
@@ -683,6 +683,12 @@
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
@@ -15,10 +13,8 @@ Index: linux-2.6.26.2/drivers/watchdog/Kconfig
# PARISC Architecture
# POWERPC Architecture
-Index: linux-2.6.26.2/drivers/watchdog/Makefile
-===================================================================
---- linux-2.6.26.2.orig/drivers/watchdog/Makefile 2008-08-14 16:55:44.000000000 +0200
-+++ linux-2.6.26.2/drivers/watchdog/Makefile 2008-08-14 16:58:16.000000000 +0200
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
@@ -97,6 +97,7 @@
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
diff --git a/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch b/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch
index e3a30d8872..97d3f1c387 100644
--- a/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch
+++ b/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch
@@ -1,5 +1,5 @@
---- a/drivers/net/ar2313/ar2313.c (revisione 11911)
-+++ a/drivers/net/ar2313/ar2313.c (copia locale)
+--- a/drivers/net/ar2313/ar2313.c
++++ b/drivers/net/ar2313/ar2313.c
@@ -291,7 +291,7 @@
sp->mii_bus.write = mdiobus_write;
sp->mii_bus.reset = mdiobus_reset;
diff --git a/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch b/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch
index baf8026a39..3e89407d0d 100644
--- a/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch
+++ b/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
-@@ -59,31 +59,32 @@
+@@ -62,31 +62,32 @@
static char nullstring[] = "unallocated";
#endif
@@ -40,7 +40,7 @@
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
master->name, offset);
-@@ -155,6 +156,11 @@
+@@ -158,6 +159,11 @@
}
if (i == numslots) {
/* Didn't find it */
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index 25f94fca0d..7cc7a93300 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -11,7 +11,7 @@ BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += yamonenv
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index de38c6581a..49c7c46154 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 3ec9bbb83f..36205aed61 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-switch kmod-diag
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 79d21f6246..cc2da9b7a5 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM963xx
FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/etrax/Makefile b/target/linux/etrax/Makefile
index a08d6b8925..8404cc86c9 100644
--- a/target/linux/etrax/Makefile
+++ b/target/linux/etrax/Makefile
@@ -10,7 +10,7 @@ ARCH:=cris
BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic-2.6/config-2.6.26 b/target/linux/generic-2.6/config-2.6.26
index a5f3921822..dbf2b23b98 100644
--- a/target/linux/generic-2.6/config-2.6.26
+++ b/target/linux/generic-2.6/config-2.6.26
@@ -428,6 +428,7 @@ CONFIG_HZ_100=y
# CONFIG_HZ_256 is not set
# CONFIG_HZ_300 is not set
# CONFIG_HZ_48 is not set
+# CONFIG_I2C_ALGOBIT is not set
# CONFIG_I2C_ALGOPCA is not set
# CONFIG_I2C_ALGOPCF is not set
# CONFIG_I2C_ALI1535 is not set
@@ -442,6 +443,7 @@ CONFIG_HZ_100=y
# CONFIG_I2C_DEBUG_CORE is not set
# CONFIG_I2C_ELEKTOR is not set
# CONFIG_I2C_GPIO is not set
+# CONFIG_I2C_HELPER_AUTO is not set
# CONFIG_I2C_I801 is not set
# CONFIG_I2C_I810 is not set
# CONFIG_I2C_IBM_IIC is not set
diff --git a/target/linux/generic-2.6/patches-2.6.25/208-rtl8110sb_fix.patch b/target/linux/generic-2.6/patches-2.6.25/208-rtl8110sb_fix.patch
index 2339bd2625..e812f9b51e 100644
--- a/target/linux/generic-2.6/patches-2.6.25/208-rtl8110sb_fix.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/208-rtl8110sb_fix.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
-@@ -1537,7 +1537,7 @@
+@@ -1539,7 +1539,7 @@
.hw_start = rtl_hw_start_8169,
.region = 1,
.align = 0,
@@ -9,7 +9,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = 0
-@@ -1546,7 +1546,7 @@
+@@ -1548,7 +1548,7 @@
.hw_start = rtl_hw_start_8168,
.region = 2,
.align = 8,
@@ -18,7 +18,7 @@
TxErr | TxOK | RxOK | RxErr,
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
-@@ -1555,7 +1555,7 @@
+@@ -1557,7 +1557,7 @@
.hw_start = rtl_hw_start_8101,
.region = 2,
.align = 8,
@@ -27,7 +27,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
-@@ -2903,10 +2903,12 @@
+@@ -2905,10 +2905,12 @@
break;
}
diff --git a/target/linux/generic-2.6/patches-2.6.25/801-usb_serial_endpoint_size.patch b/target/linux/generic-2.6/patches-2.6.25/801-usb_serial_endpoint_size.patch
index 79ee43e16a..e91ff5eafa 100644
--- a/target/linux/generic-2.6/patches-2.6.25/801-usb_serial_endpoint_size.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/801-usb_serial_endpoint_size.patch
@@ -8,7 +8,7 @@
static int debug;
static struct usb_serial *serial_table[SERIAL_TTY_MINORS]; /* initially all NULL */
static DEFINE_MUTEX(table_lock);
-@@ -904,7 +905,7 @@
+@@ -903,7 +904,7 @@
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}
@@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1316,3 +1317,5 @@
+@@ -1315,3 +1316,5 @@
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");
diff --git a/target/linux/generic-2.6/patches-2.6.26/071-redboot_boardconfig.patch b/target/linux/generic-2.6/patches-2.6.26/071-redboot_boardconfig.patch
index 48c7d52cb7..07f569a731 100644
--- a/target/linux/generic-2.6/patches-2.6.26/071-redboot_boardconfig.patch
+++ b/target/linux/generic-2.6/patches-2.6.26/071-redboot_boardconfig.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.26.2/drivers/mtd/redboot.c
-===================================================================
---- linux-2.6.26.2.orig/drivers/mtd/redboot.c 2008-08-19 19:32:17.000000000 +0200
-+++ linux-2.6.26.2/drivers/mtd/redboot.c 2008-08-19 19:47:34.000000000 +0200
+--- a/drivers/mtd/redboot.c
++++ b/drivers/mtd/redboot.c
@@ -13,6 +13,8 @@
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
@@ -19,7 +17,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
int nrparts = 0;
struct fis_image_desc *buf;
struct mtd_partition *parts;
-@@ -217,14 +220,14 @@
+@@ -211,14 +214,14 @@
}
}
#endif
@@ -36,7 +34,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
if (nulllen > 0) {
strcpy(nullname, nullstring);
-@@ -243,6 +246,8 @@
+@@ -237,6 +240,8 @@
}
#endif
for ( ; i<nrparts; i++) {
@@ -45,7 +43,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
parts[i].size = fl->img->size;
parts[i].offset = fl->img->flash_base;
parts[i].name = names;
-@@ -276,6 +281,14 @@
+@@ -270,6 +275,14 @@
fl = fl->next;
kfree(tmp_fl);
}
diff --git a/target/linux/generic-2.6/patches-2.6.26/208-rtl8110sb_fix.patch b/target/linux/generic-2.6/patches-2.6.26/208-rtl8110sb_fix.patch
index 2339bd2625..e812f9b51e 100644
--- a/target/linux/generic-2.6/patches-2.6.26/208-rtl8110sb_fix.patch
+++ b/target/linux/generic-2.6/patches-2.6.26/208-rtl8110sb_fix.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
-@@ -1537,7 +1537,7 @@
+@@ -1539,7 +1539,7 @@
.hw_start = rtl_hw_start_8169,
.region = 1,
.align = 0,
@@ -9,7 +9,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = 0
-@@ -1546,7 +1546,7 @@
+@@ -1548,7 +1548,7 @@
.hw_start = rtl_hw_start_8168,
.region = 2,
.align = 8,
@@ -18,7 +18,7 @@
TxErr | TxOK | RxOK | RxErr,
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
-@@ -1555,7 +1555,7 @@
+@@ -1557,7 +1557,7 @@
.hw_start = rtl_hw_start_8101,
.region = 2,
.align = 8,
@@ -27,7 +27,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
-@@ -2903,10 +2903,12 @@
+@@ -2905,10 +2905,12 @@
break;
}
diff --git a/target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch b/target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch
index f1bd446bd5..e7bc6c52f4 100644
--- a/target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch
+++ b/target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch
@@ -8,7 +8,7 @@
static int debug;
static struct usb_serial *serial_table[SERIAL_TTY_MINORS]; /* initially all NULL */
static DEFINE_MUTEX(table_lock);
-@@ -815,7 +816,7 @@
+@@ -814,7 +815,7 @@
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}
@@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1229,3 +1230,5 @@
+@@ -1228,3 +1229,5 @@
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");
diff --git a/target/linux/generic-2.6/patches-2.6.26/910-cryptodev_backport.patch b/target/linux/generic-2.6/patches-2.6.26/910-cryptodev_backport.patch
index 682d2a13fd..a2d64367c4 100644
--- a/target/linux/generic-2.6/patches-2.6.26/910-cryptodev_backport.patch
+++ b/target/linux/generic-2.6/patches-2.6.26/910-cryptodev_backport.patch
@@ -6510,7 +6510,7 @@
+
--- a/drivers/crypto/padlock-aes.c
+++ b/drivers/crypto/padlock-aes.c
-@@ -385,12 +385,12 @@
+@@ -411,12 +411,12 @@
int ret;
if (!cpu_has_xcrypt) {
@@ -6527,7 +6527,7 @@
--- a/drivers/crypto/padlock-sha.c
+++ b/drivers/crypto/padlock-sha.c
-@@ -254,12 +254,12 @@
+@@ -263,12 +263,12 @@
int rc = -ENODEV;
if (!cpu_has_phe) {
diff --git a/target/linux/ifxmips/Makefile b/target/linux/ifxmips/Makefile
index 060782bbd3..79f578dd19 100644
--- a/target/linux/ifxmips/Makefile
+++ b/target/linux/ifxmips/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=ifxmips
BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES:=uboot-ifxmips
diff --git a/target/linux/iop32x/Makefile b/target/linux/iop32x/Makefile
index 12dc5990c2..e46e0c80c8 100644
--- a/target/linux/iop32x/Makefile
+++ b/target/linux/iop32x/Makefile
@@ -11,7 +11,7 @@ BOARD:=iop32x
BOARDNAME:=Intel IOP32x
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 897a2fac2a..51155663b8 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs
SUBTARGETS=generic harddisk
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ixp4xx/patches-2.6.26/116-sidewinder_fis_location.patch b/target/linux/ixp4xx/patches-2.6.26/116-sidewinder_fis_location.patch
index 718ef3ce5e..da685ef74e 100644
--- a/target/linux/ixp4xx/patches-2.6.26/116-sidewinder_fis_location.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/116-sidewinder_fis_location.patch
@@ -1,15 +1,15 @@
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
-@@ -13,6 +13,8 @@
- #include <linux/mtd/mtd.h>
- #include <linux/mtd/partitions.h>
+@@ -15,6 +15,8 @@
+
+ #define BOARD_CONFIG_PART "boardconfig"
+#include <asm/mach-types.h>
+
struct fis_image_desc {
unsigned char name[16]; // Null terminated name
uint32_t flash_base; // Address within FLASH of image
-@@ -30,7 +32,8 @@
+@@ -32,7 +34,8 @@
struct fis_list *next;
};
@@ -19,7 +19,7 @@
module_param(directory, int, 0);
static inline int redboot_checksum(struct fis_image_desc *img)
-@@ -58,6 +61,8 @@
+@@ -61,6 +64,8 @@
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
static char nullstring[] = "unallocated";
#endif
diff --git a/target/linux/ixp4xx/patches-2.6.26/162-wg302v1_mem_fixup.patch b/target/linux/ixp4xx/patches-2.6.26/162-wg302v1_mem_fixup.patch
index 4eb1b7595f..f2d8fde550 100644
--- a/target/linux/ixp4xx/patches-2.6.26/162-wg302v1_mem_fixup.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/162-wg302v1_mem_fixup.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/mach-ixp4xx/wg302v1-setup.c
+++ b/arch/arm/mach-ixp4xx/wg302v1-setup.c
-@@ -99,6 +99,36 @@
+@@ -115,6 +115,36 @@
&wg302v1_eth[0],
};
@@ -37,7 +37,7 @@
static void __init wg302v1_init(void)
{
ixp4xx_sys_init();
-@@ -117,6 +147,7 @@
+@@ -133,6 +163,7 @@
/* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
.phys_io = IXP4XX_PERIPHERAL_BASE_PHYS,
.io_pg_offst = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
diff --git a/target/linux/ixp4xx/patches-2.6.26/192-cambria_gpio_device.patch b/target/linux/ixp4xx/patches-2.6.26/192-cambria_gpio_device.patch
index c79a03fa4c..0fe2eb0526 100644
--- a/target/linux/ixp4xx/patches-2.6.26/192-cambria_gpio_device.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/192-cambria_gpio_device.patch
@@ -44,4 +44,4 @@
+ platform_device_register(&cambria_gpio);
platform_device_register(&cambria_optional_uart);
- cambria_npec_data.phy = 2;
+ platform_device_register(&cambria_npec_device);
diff --git a/target/linux/magicbox/Makefile b/target/linux/magicbox/Makefile
index fcdd285a3f..f170208d2b 100644
--- a/target/linux/magicbox/Makefile
+++ b/target/linux/magicbox/Makefile
@@ -11,7 +11,7 @@ BOARD:=magicbox
BOARDNAME:=Magicbox
FEATURES:=squashfs pci
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
LINUX_KARCH:=ppc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
index c9474379f8..7fc961cd96 100644
--- a/target/linux/orion/Makefile
+++ b/target/linux/orion/Makefile
@@ -11,7 +11,7 @@ BOARD:=orion
BOARDNAME:=Marvell Orion
FEATURES:=squashfs
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 5194f30f80..38c16c1e34 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -11,7 +11,7 @@ BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index fa8ec11ea4..1c13f4ce9a 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -11,7 +11,7 @@ BOARD:=ppc44x
BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ps3/Makefile b/target/linux/ps3/Makefile
index a9e69a806b..3e559eb421 100644
--- a/target/linux/ps3/Makefile
+++ b/target/linux/ps3/Makefile
@@ -10,7 +10,7 @@ ARCH:=powerpc
BOARD:=ps3
BOARDNAME:=Sony PS3 Game Console
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
KERNEL_CC:=
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 3dd9a986ab..e09751314b 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext2
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
index 17c08cd6c5..200c684577 100644
--- a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
+++ b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.26/arch/um/Makefile-i386
-===================================================================
---- linux-2.6.26.orig/arch/um/Makefile-i386 2008-07-28 13:43:40.412036547 +0200
-+++ linux-2.6.26/arch/um/Makefile-i386 2008-07-28 13:44:00.234033125 +0200
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
@@ -35,7 +35,7 @@
# Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
# a lot more stack due to the lack of sharing of stacklots. Also, gcc
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 2d29198984..3288de347a 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi
SUBTARGETS=generic
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci