summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-24 18:35:17 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-24 18:35:17 +0000
commit11e93be20d363630dcaca8d2bb7febe2c82ecb06 (patch)
tree2f57d0a02dc8c200e15d3feb6d61e659a07d7b4e /target
parentc407264643c9ec8187f8ca157b48c4c068cb81b6 (diff)
downloadmaster-31e0f0ae-11e93be20d363630dcaca8d2bb7febe2c82ecb06.tar.gz
master-31e0f0ae-11e93be20d363630dcaca8d2bb7febe2c82ecb06.tar.bz2
master-31e0f0ae-11e93be20d363630dcaca8d2bb7febe2c82ecb06.zip
generic/4.0: drop patches applied upstream
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44531
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/patches-4.0/550-ubifs-symlink-xattr-support.patch29
-rw-r--r--target/linux/generic/patches-4.0/621-sched_act_connmark.patch161
2 files changed, 0 insertions, 190 deletions
diff --git a/target/linux/generic/patches-4.0/550-ubifs-symlink-xattr-support.patch b/target/linux/generic/patches-4.0/550-ubifs-symlink-xattr-support.patch
deleted file mode 100644
index 0790003147..0000000000
--- a/target/linux/generic/patches-4.0/550-ubifs-symlink-xattr-support.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/fs/ubifs/file.c
-+++ b/fs/ubifs/file.c
-@@ -1574,6 +1574,10 @@ const struct inode_operations ubifs_syml
- .follow_link = ubifs_follow_link,
- .setattr = ubifs_setattr,
- .getattr = ubifs_getattr,
-+ .setxattr = ubifs_setxattr,
-+ .getxattr = ubifs_getxattr,
-+ .listxattr = ubifs_listxattr,
-+ .removexattr = ubifs_removexattr,
- };
-
- const struct file_operations ubifs_file_operations = {
---- a/fs/ubifs/xattr.c
-+++ b/fs/ubifs/xattr.c
-@@ -209,12 +209,12 @@ static int change_xattr(struct ubifs_inf
- goto out_free;
- }
- inode->i_size = ui->ui_size = size;
-- ui->data_len = size;
-
- mutex_lock(&host_ui->ui_mutex);
- host->i_ctime = ubifs_current_time(host);
- host_ui->xattr_size -= CALC_XATTR_BYTES(ui->data_len);
- host_ui->xattr_size += CALC_XATTR_BYTES(size);
-+ ui->data_len = size;
-
- /*
- * It is important to write the host inode after the xattr inode
diff --git a/target/linux/generic/patches-4.0/621-sched_act_connmark.patch b/target/linux/generic/patches-4.0/621-sched_act_connmark.patch
deleted file mode 100644
index bff2765289..0000000000
--- a/target/linux/generic/patches-4.0/621-sched_act_connmark.patch
+++ /dev/null
@@ -1,161 +0,0 @@
---- /dev/null
-+++ b/net/sched/act_connmark.c
-@@ -0,0 +1,126 @@
-+/*
-+ * Copyright (c) 2011 Felix Fietkau <nbd@openwrt.org>
-+ *
-+ * This program is free software; you can redistribute it and/or modify it
-+ * under the terms and conditions of the GNU General Public License,
-+ * version 2, as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope it will be useful, but WITHOUT
-+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-+ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
-+ * more details.
-+ *
-+ * You should have received a copy of the GNU General Public License along with
-+ * this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-+ * Place - Suite 330, Boston, MA 02111-1307 USA.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/init.h>
-+#include <linux/kernel.h>
-+#include <linux/skbuff.h>
-+#include <linux/rtnetlink.h>
-+#include <linux/pkt_cls.h>
-+#include <linux/ip.h>
-+#include <linux/ipv6.h>
-+#include <net/netlink.h>
-+#include <net/pkt_sched.h>
-+#include <net/act_api.h>
-+
-+#include <net/netfilter/nf_conntrack.h>
-+#include <net/netfilter/nf_conntrack_core.h>
-+
-+#define TCA_ACT_CONNMARK 20
-+
-+#define CONNMARK_TAB_MASK 3
-+
-+static int tcf_connmark(struct sk_buff *skb, const struct tc_action *a,
-+ struct tcf_result *res)
-+{
-+ struct nf_conn *c;
-+ enum ip_conntrack_info ctinfo;
-+ int proto;
-+ int r;
-+
-+ if (skb->protocol == htons(ETH_P_IP)) {
-+ if (skb->len < sizeof(struct iphdr))
-+ goto out;
-+ proto = PF_INET;
-+ } else if (skb->protocol == htons(ETH_P_IPV6)) {
-+ if (skb->len < sizeof(struct ipv6hdr))
-+ goto out;
-+ proto = PF_INET6;
-+ } else
-+ goto out;
-+
-+ r = nf_conntrack_in(dev_net(skb->dev), proto, NF_INET_PRE_ROUTING, skb);
-+ if (r != NF_ACCEPT)
-+ goto out;
-+
-+ c = nf_ct_get(skb, &ctinfo);
-+ if (!c)
-+ goto out;
-+
-+ skb->mark = c->mark;
-+ nf_conntrack_put(skb->nfct);
-+ skb->nfct = NULL;
-+
-+out:
-+ return TC_ACT_PIPE;
-+}
-+
-+static int tcf_connmark_init(struct net *net, struct nlattr *nla,
-+ struct nlattr *est, struct tc_action *a,
-+ int ovr, int bind)
-+{
-+ int ret = 0;
-+
-+ if (!tcf_hash_check(0, a, bind)) {
-+ ret = tcf_hash_create(0, est, a, sizeof(struct tcf_common), bind);
-+ if (ret)
-+ return ret;
-+
-+ tcf_hash_insert(a);
-+ ret = ACT_P_CREATED;
-+ } else {
-+ if (!ovr) {
-+ tcf_hash_release(a, bind);
-+ return -EEXIST;
-+ }
-+ }
-+
-+ return ret;
-+}
-+
-+static inline int tcf_connmark_dump(struct sk_buff *skb, struct tc_action *a,
-+ int bind, int ref)
-+{
-+ return skb->len;
-+}
-+
-+static struct tc_action_ops act_connmark_ops = {
-+ .kind = "connmark",
-+ .type = TCA_ACT_CONNMARK,
-+ .owner = THIS_MODULE,
-+ .act = tcf_connmark,
-+ .dump = tcf_connmark_dump,
-+ .init = tcf_connmark_init,
-+};
-+
-+MODULE_AUTHOR("Felix Fietkau <nbd@openwrt.org>");
-+MODULE_DESCRIPTION("Connection tracking mark restoring");
-+MODULE_LICENSE("GPL");
-+
-+static int __init connmark_init_module(void)
-+{
-+
-+ return tcf_register_action(&act_connmark_ops, CONNMARK_TAB_MASK);
-+}
-+
-+static void __exit connmark_cleanup_module(void)
-+{
-+ tcf_unregister_action(&act_connmark_ops);
-+}
-+
-+module_init(connmark_init_module);
-+module_exit(connmark_cleanup_module);
---- a/net/sched/Kconfig
-+++ b/net/sched/Kconfig
-@@ -729,6 +729,19 @@ config NET_ACT_VLAN
- To compile this code as a module, choose M here: the
- module will be called act_vlan.
-
-+config NET_ACT_CONNMARK
-+ tristate "Connection Tracking Marking"
-+ depends on NET_CLS_ACT
-+ depends on NF_CONNTRACK
-+ depends on NF_CONNTRACK_MARK
-+ ---help---
-+ Say Y here to restore the connmark from a scheduler action
-+
-+ If unsure, say N.
-+
-+ To compile this code as a module, choose M here: the
-+ module will be called act_connmark.
-+
- config NET_CLS_IND
- bool "Incoming device classification"
- depends on NET_CLS_U32 || NET_CLS_FW
---- a/net/sched/Makefile
-+++ b/net/sched/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_NET_ACT_PEDIT) += act_pedit
- obj-$(CONFIG_NET_ACT_SIMP) += act_simple.o
- obj-$(CONFIG_NET_ACT_SKBEDIT) += act_skbedit.o
- obj-$(CONFIG_NET_ACT_CSUM) += act_csum.o
-+obj-$(CONFIG_NET_ACT_CONNMARK) += act_connmark.o
- obj-$(CONFIG_NET_ACT_VLAN) += act_vlan.o
- obj-$(CONFIG_NET_SCH_FIFO) += sch_fifo.o
- obj-$(CONFIG_NET_SCH_CBQ) += sch_cbq.o