summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-03-31 08:05:30 +0000
committerAndy Boyett <agb@openwrt.org>2008-03-31 08:05:30 +0000
commit0ed1824fa1f9a417d59b00e563537f7cf8fadecd (patch)
tree593c392bde4f9f1e80947c4af078b62093476831 /target
parenta2ccc5b7903856c058cc0d075c366b42bbce9b1f (diff)
downloadmaster-31e0f0ae-0ed1824fa1f9a417d59b00e563537f7cf8fadecd.tar.gz
master-31e0f0ae-0ed1824fa1f9a417d59b00e563537f7cf8fadecd.tar.bz2
master-31e0f0ae-0ed1824fa1f9a417d59b00e563537f7cf8fadecd.zip
Add a generic Broadcom USB profile.
SVN-Revision: 10695
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm-2.4/profiles/USBGeneric.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/profiles/USBGeneric.mk b/target/linux/brcm-2.4/profiles/USBGeneric.mk
new file mode 100644
index 0000000000..85bad87205
--- /dev/null
+++ b/target/linux/brcm-2.4/profiles/USBGeneric.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/USBGeneric
+ NAME:=Generic USB
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
+endef
+
+define Profile/USBGeneric/Description
+ Package set with for Broadcom routers with USB/USB2 (OHCI/EHCI) support.
+ Includes the WRTSL54GS, WL-520gU, WL-500gP v2, any other BCM5354 routers
+ with USB.
+endef
+$(eval $(call Profile,USBGeneric))
+