summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-21 07:15:47 +0000
committerJohn Crispin <john@openwrt.org>2015-04-21 07:15:47 +0000
commit0ddebefc74e6e9e265f01c087b132d6b6a7a748b (patch)
treeb25a8abb2a6b33c9389264e8e11e96ba11092b9e /target
parent0fd202f3e563573519154f733e3fc411165d4761 (diff)
downloadmaster-31e0f0ae-0ddebefc74e6e9e265f01c087b132d6b6a7a748b.tar.gz
master-31e0f0ae-0ddebefc74e6e9e265f01c087b132d6b6a7a748b.tar.bz2
master-31e0f0ae-0ddebefc74e6e9e265f01c087b132d6b6a7a748b.zip
ipq806x: add db149 support to OpenWrt init scripts
DB149 is a IPQ8064 based platform. This patch adds the init scripts to detect it, configure the network accordingly, and generate a flashable image for it. Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> SVN-Revision: 45537
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ipq806x/base-files/etc/uci-defaults/network6
-rw-r--r--target/linux/ipq806x/base-files/lib/ipq806x.sh3
-rw-r--r--target/linux/ipq806x/image/Makefile1
3 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ipq806x/base-files/etc/uci-defaults/network b/target/linux/ipq806x/base-files/etc/uci-defaults/network
index 34e9fe482b..354cea9e3d 100755
--- a/target/linux/ipq806x/base-files/etc/uci-defaults/network
+++ b/target/linux/ipq806x/base-files/etc/uci-defaults/network
@@ -22,6 +22,12 @@ ap148)
ucidef_add_switch_vlan "switch0" "1" "6 1 2 3 4"
ucidef_add_switch_vlan "switch0" "2" "0 5"
;;
+db149)
+ ucidef_set_interfaces_lan_wan "eth1 eth2 eth3" "eth0"
+ ucidef_add_switch "switch0" "1" "1"
+ ucidef_add_switch_vlan "switch0" "1" "6 1 2 3 4"
+ ucidef_add_switch_vlan "switch0" "2" "0 5"
+ ;;
*)
echo "Unsupported hardware. Network interfaces not intialized"
;;
diff --git a/target/linux/ipq806x/base-files/lib/ipq806x.sh b/target/linux/ipq806x/base-files/lib/ipq806x.sh
index 7c47fa2a85..2790f3f386 100644
--- a/target/linux/ipq806x/base-files/lib/ipq806x.sh
+++ b/target/linux/ipq806x/base-files/lib/ipq806x.sh
@@ -17,6 +17,9 @@ ipq806x_board_detect() {
*"AP148")
name="ap148"
;;
+ *"DB149")
+ name="db149"
+ ;;
esac
[ -z "$name" ] && name="unknown"
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 77d191f9a9..e2346e6319 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -22,6 +22,7 @@ endef
define Image/BuildKernel
$(CP) $(LINUX_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
$(call Image/BuildKernel/FIT,qcom-ipq8064-ap148)
+ $(call Image/BuildKernel/FIT,qcom-ipq8064-db149)
endef
define Image/Build/squashfs