summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-15 11:30:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-15 11:30:22 +0000
commit0d4286b0b3a6ea201346bee09a2fe0cf35844333 (patch)
tree2fbeae9cefc6857e775d67e1b0e06e7e5d04d519 /target
parentcb126cd576724db0bf8e1abf6dce2ecb764169da (diff)
downloadmaster-31e0f0ae-0d4286b0b3a6ea201346bee09a2fe0cf35844333.tar.gz
master-31e0f0ae-0d4286b0b3a6ea201346bee09a2fe0cf35844333.tar.bz2
master-31e0f0ae-0d4286b0b3a6ea201346bee09a2fe0cf35844333.zip
This patch is for broadcom 96348GW-11 boards, to get USB and Ethernet working. Also it patches mtd map driver for bcm96xx boards to be sure that CFE1CFE1 code is detected when booting from CFE. (#4201)
SVN-Revision: 13213
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c5
-rw-r--r--target/linux/brcm63xx/image/Makefile2
-rw-r--r--target/linux/brcm63xx/patches-2.6.27/011-add_preliminary_board_support.patch27
3 files changed, 31 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c b/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
index 504dfac849..9543c172a4 100644
--- a/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
+++ b/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
@@ -177,13 +177,14 @@ static int bcm963xx_detect_cfe(struct mtd_info *master)
{
int idoffset = 0x4e0;
static char idstring[8] = "CFE1CFE1";
- char buf[8];
+ char buf[9];
int ret;
size_t retlen;
ret = master->read(master, idoffset, 8, &retlen, (void *)buf);
+ buf[retlen] = 0;
printk("bcm963xx: Read Signature value of %s\n", buf);
- return strcmp(idstring,buf);
+ return strncmp(idstring,buf,8);
}
static int __init bcm963xx_mtd_init(void)
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index e64d2c8c3f..203277679c 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -75,6 +75,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96345GW2,6345)
# Neufbox4
$(call Image/Build/CFE,$(1),96358VW,6358)
+ # Comtrend 536
+ $(call Image/Build/CFE,$(1),96348GW-11,6348)
endef
$(eval $(call BuildImage))
diff --git a/target/linux/brcm63xx/patches-2.6.27/011-add_preliminary_board_support.patch b/target/linux/brcm63xx/patches-2.6.27/011-add_preliminary_board_support.patch
index 3726cb5bbc..1d8789fd7a 100644
--- a/target/linux/brcm63xx/patches-2.6.27/011-add_preliminary_board_support.patch
+++ b/target/linux/brcm63xx/patches-2.6.27/011-add_preliminary_board_support.patch
@@ -56,7 +56,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
+obj-$(CONFIG_BOARD_BCM963XX) += board_bcm963xx.o
--- /dev/null
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -0,0 +1,328 @@
+@@ -0,0 +1,353 @@
+/*
+ * This file is subject to the terms and conditions of the GNU General Public
+ * License. See the file "COPYING" in the main directory of this archive
@@ -109,6 +109,30 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
+ },
+};
+
++static struct board_info __initdata board_96348gw_11 = {
++ .name = "96348GW-11",
++ .expected_cpu_id = 0x6348,
++
++ .has_enet0 = 1,
++ .has_enet1 = 1,
++ .has_pci = 1,
++
++ .enet0 = {
++ .has_phy = 1,
++ .use_internal_phy = 1,
++ },
++
++ .enet1 = {
++ .force_speed_100 = 1,
++ .force_duplex_full = 1,
++ },
++
++
++ .has_ohci0 = 1,
++ .has_pccard = 1,
++ .has_ehci0 = 1,
++};
++
+static struct board_info __initdata board_96348gw = {
+ .name = "96348GW",
+ .expected_cpu_id = 0x6348,
@@ -159,6 +183,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
+#ifdef CONFIG_BCM63XX_CPU_6348
+ &board_96348r,
+ &board_96348gw,
++ &board_96348gw_11,
+#endif
+
+#ifdef CONFIG_BCM63XX_CPU_6358