summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-15 11:03:31 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-15 11:03:31 +0000
commit0b6f786316b934752272252cc4c0a975c483a418 (patch)
tree37e103ed41eef319a62a714c7c2fad695a40c26d /target
parentec1c11c65da3af3978355826ef710530d73e94d1 (diff)
downloadmaster-31e0f0ae-0b6f786316b934752272252cc4c0a975c483a418.tar.gz
master-31e0f0ae-0b6f786316b934752272252cc4c0a975c483a418.tar.bz2
master-31e0f0ae-0b6f786316b934752272252cc4c0a975c483a418.zip
ar71xx: change DIR-600-A1 image generation template, will be usable for other boards
SVN-Revision: 20227
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile44
1 files changed, 22 insertions, 22 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 2f990da080..5ac4dc198f 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -90,26 +90,6 @@ define Image/Build/WRT400N
fi; fi
endef
-dir600a1_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,896k(kernel),2816k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
-define Image/Build/DIR600A1
- $(call PatchKernelLzma,$(2),$(3) $(dir600a1_mtdlayout))
- if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \
- echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
- else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 2818048 ]; then \
- echo "Warning: $(KDIR)/root.$(1) is too big"; \
- else \
- mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
- 0x80060000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
- ( \
- dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=2752k conv=sync; \
- echo -n "AP91-AR7240-RT-090223-00"; \
- ) > $(call imgname,$(1),$(2))-universal.bin; \
- fi; fi
-endef
-
dir825b1_mtdlayout=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,1024k(kernel),5184k(rootfs),64k(caldata)ro,1600k(unknown)ro,6208k@0x50000(firmware)
define Image/Build/DIR825B1
$(call PatchKernelLzma,$(2),$(3) $(dir825b1_mtdlayout))
@@ -169,6 +149,26 @@ define Image/Build/Cameo
fi; fi
endef
+cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,896k(kernel),2816k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
+define Image/Build/Cameo7240
+ $(call PatchKernelLzma,$(2),$(3) $(cameo7240_mtdlayout))
+ if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \
+ echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+ else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 2818048 ]; then \
+ echo "Warning: $(KDIR)/root.$(1) is too big"; \
+ else \
+ mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
+ 0x80060000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
+ ( \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=2752k conv=sync; \
+ echo -n $(4); \
+ ) > $(call imgname,$(1),$(2))-universal.bin; \
+ fi; fi
+endef
+
define Image/Build/AP83
$(call PatchKernelGzip,$(2),$(3))
if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.gz"` -gt 1310720 ]; then \
@@ -404,7 +404,7 @@ define Image/Build/Profile/WP543
endef
define Image/Build/Profile/DIR600A1
- $(call Image/Build/Template/$(fs_64k)/$(1),DIR600A1,dir-600-a1,board=DIR-600-A1)
+ $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-600-a1,board=DIR-600-A1,"AP91-AR7240-RT-090223-00")
endef
define Image/Build/Profile/DIR615C1