summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-03-18 13:02:12 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-03-18 13:02:12 +0000
commit091c6afb8051cd89ebc5d0885076f537cf686c62 (patch)
treee6f26fa887c22bfb4b889e4f3fc85b30eefebe91 /target
parent7df8322519226c15f4333dfa17d9c35ec898a163 (diff)
downloadmaster-31e0f0ae-091c6afb8051cd89ebc5d0885076f537cf686c62.tar.gz
master-31e0f0ae-091c6afb8051cd89ebc5d0885076f537cf686c62.tar.bz2
master-31e0f0ae-091c6afb8051cd89ebc5d0885076f537cf686c62.zip
upgrade to 2.6.37, mark it broken
SVN-Revision: 26222
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx21/Makefile6
-rw-r--r--target/linux/imx21/config-default (renamed from target/linux/imx21/config-2.6.34)1
-rw-r--r--target/linux/imx21/patches/010-mach-vp6500.patch (renamed from target/linux/imx21/patches-2.6.34/010-mach-vp6500.patch)18
-rw-r--r--target/linux/imx21/patches/011-mach-type.patch (renamed from target/linux/imx21/patches-2.6.34/011-mach-type.patch)0
-rw-r--r--target/linux/imx21/patches/040-pwm.patch (renamed from target/linux/imx21/patches-2.6.34/040-pwm.patch)0
5 files changed, 13 insertions, 12 deletions
diff --git a/target/linux/imx21/Makefile b/target/linux/imx21/Makefile
index 76b51ab8f6..982719edd9 100644
--- a/target/linux/imx21/Makefile
+++ b/target/linux/imx21/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=imx21
BOARDNAME:=Freescale i.MX21
-FEATURES:=jffs2
+FEATURES:=jffs2 broken
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
-LINUX_VERSION:=2.6.34.8
+LINUX_VERSION:=2.6.37.3
DEVICE_TYPE=phone
diff --git a/target/linux/imx21/config-2.6.34 b/target/linux/imx21/config-default
index 829c672d1e..67a656734c 100644
--- a/target/linux/imx21/config-2.6.34
+++ b/target/linux/imx21/config-default
@@ -100,6 +100,7 @@ CONFIG_MACH_VP6500=y
# CONFIG_MTD_CFI_INTELEXT is not set
CONFIG_MTD_CMDLINE_PARTS=y
CONFIG_MTD_PHYSMAP=y
+# CONFIG_MXC_DEBUG_BOARD is not set
# CONFIG_MXC_IRQ_PRIOR is not set
# CONFIG_MXC_PWM is not set
CONFIG_NEED_DMA_MAP_STATE=y
diff --git a/target/linux/imx21/patches-2.6.34/010-mach-vp6500.patch b/target/linux/imx21/patches/010-mach-vp6500.patch
index 8d1832b56d..37bfa676f9 100644
--- a/target/linux/imx21/patches-2.6.34/010-mach-vp6500.patch
+++ b/target/linux/imx21/patches/010-mach-vp6500.patch
@@ -1,8 +1,8 @@
---- a/arch/arm/mach-mx2/Kconfig
-+++ b/arch/arm/mach-mx2/Kconfig
-@@ -27,6 +27,12 @@ config MACH_MX21ADS
- Include support for MX21ADS platform. This includes specific
- configurations for the board and its peripherals.
+--- a/arch/arm/mach-imx/Kconfig
++++ b/arch/arm/mach-imx/Kconfig
+@@ -83,6 +83,12 @@ if MACH_MX27
+
+ comment "MX27 platforms:"
+config MACH_VP6500
+ bool "Phillips VP6500 VoIP phone"
@@ -12,10 +12,10 @@
+
config MACH_MX27ADS
bool "MX27ADS platform"
- depends on MACH_MX27
---- a/arch/arm/mach-mx2/Makefile
-+++ b/arch/arm/mach-mx2/Makefile
-@@ -21,3 +21,4 @@ obj-$(CONFIG_MACH_CPUIMX27) += mach-cpui
+ select IMX_HAVE_PLATFORM_IMX_I2C
+--- a/arch/arm/mach-imx/Makefile
++++ b/arch/arm/mach-imx/Makefile
+@@ -32,3 +32,4 @@ obj-$(CONFIG_MACH_CPUIMX27) += mach-cpui
obj-$(CONFIG_MACH_EUKREA_MBIMX27_BASEBOARD) += eukrea_mbimx27-baseboard.o
obj-$(CONFIG_MACH_PCA100) += mach-pca100.o
obj-$(CONFIG_MACH_MXT_TD60) += mach-mxt_td60.o
diff --git a/target/linux/imx21/patches-2.6.34/011-mach-type.patch b/target/linux/imx21/patches/011-mach-type.patch
index 873f03083a..873f03083a 100644
--- a/target/linux/imx21/patches-2.6.34/011-mach-type.patch
+++ b/target/linux/imx21/patches/011-mach-type.patch
diff --git a/target/linux/imx21/patches-2.6.34/040-pwm.patch b/target/linux/imx21/patches/040-pwm.patch
index af47ad1de0..af47ad1de0 100644
--- a/target/linux/imx21/patches-2.6.34/040-pwm.patch
+++ b/target/linux/imx21/patches/040-pwm.patch