summaryrefslogtreecommitdiffstats
path: root/target/toolchain
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2016-05-26 15:24:27 +0200
committerAlexander Couzens <lynxis@fe80.eu>2016-06-01 17:54:36 +0200
commit4a7c65340088ed28334854013370c17ce4c4b95f (patch)
tree9df53f170c9897cd241f70fb0745bc07ff72ca54 /target/toolchain
parenta7d13178f430027ae9073e0a7d3edc2f344bcea6 (diff)
downloadmaster-31e0f0ae-4a7c65340088ed28334854013370c17ce4c4b95f.tar.gz
master-31e0f0ae-4a7c65340088ed28334854013370c17ce4c4b95f.tar.bz2
master-31e0f0ae-4a7c65340088ed28334854013370c17ce4c4b95f.zip
IB/SDK/toolchain: use VERSION_DIST_SANITIZED instead of VERSION_DIST
VERSION_DIST can contains spaces which produces problems when used as file name Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/toolchain')
-rw-r--r--target/toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/toolchain/Makefile b/target/toolchain/Makefile
index 08e716660b..e8fe4fb514 100644
--- a/target/toolchain/Makefile
+++ b/target/toolchain/Makefile
@@ -14,7 +14,7 @@ include $(INCLUDE_DIR)/version.mk
override MAKEFLAGS=
-TOOLCHAIN_NAME:=$(VERSION_DIST)-Toolchain-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))_gcc-$(GCCV)$(DIR_SUFFIX).$(HOST_OS)-$(HOST_ARCH)
+TOOLCHAIN_NAME:=$(VERSION_DIST_SANITIZED)-Toolchain-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))_gcc-$(GCCV)$(DIR_SUFFIX).$(HOST_OS)-$(HOST_ARCH)
TOOLCHAIN_BUILD_DIR:=$(BUILD_DIR)/$(TOOLCHAIN_NAME)
EXCLUDE_DIRS:=*/ccache \
*/initial \