summaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:42 +0000
commitd69efa4e1538b3667a684c8520dfd8d11662b258 (patch)
treefeb748e2bcb2f9f4707c2e10283f40c8305a03c5 /target/sdk
parent2274fbc8dbb996887f26c61d58176b3ea645e310 (diff)
downloadmaster-31e0f0ae-d69efa4e1538b3667a684c8520dfd8d11662b258.tar.gz
master-31e0f0ae-d69efa4e1538b3667a684c8520dfd8d11662b258.tar.bz2
master-31e0f0ae-d69efa4e1538b3667a684c8520dfd8d11662b258.zip
targets: Use configured distribution name for SDK, IB, and Toolchain tarball names
We allow to configure the version distribution name; let's also use it for the tarballs (SDK, ImageBuilder, and SDK). Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> SVN-Revision: 48081
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d81c2375e0..28739bbca9 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
override MAKEFLAGS=
-SDK_NAME:=OpenWrt-SDK-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))_gcc-$(GCCV)$(DIR_SUFFIX).$(HOST_OS)-$(HOST_ARCH)
+SDK_NAME:=$(VERSION_DIST)-SDK-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))_gcc-$(GCCV)$(DIR_SUFFIX).$(HOST_OS)-$(HOST_ARCH)
SDK_BUILD_DIR:=$(BUILD_DIR)/$(SDK_NAME)
STAGING_SUBDIR_HOST := staging_dir/host