summaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-10 11:17:02 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-10 11:17:02 +0000
commit4685e4f27310d55c20c8062b2b4f782e4b709694 (patch)
treea4b102a9368dd9edc59218db80b9968991492b70 /target/sdk
parent64e7b41b2e95ac9a417b4fdf144134af20caa66a (diff)
downloadmaster-31e0f0ae-4685e4f27310d55c20c8062b2b4f782e4b709694.tar.gz
master-31e0f0ae-4685e4f27310d55c20c8062b2b4f782e4b709694.tar.bz2
master-31e0f0ae-4685e4f27310d55c20c8062b2b4f782e4b709694.zip
sdk: track files with git and use it to implement proper clean targets
Initialize a Git repository in the SDK and use git reset / git clean to rollback any SDK changes with "make clean" or "make dirclean". This approach is more robust than nuking entire directory trees because some parts of them might have been shipped with the original archive. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43904
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/files/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/target/sdk/files/Makefile b/target/sdk/files/Makefile
index 0c27f1a473..01c1e1c788 100644
--- a/target/sdk/files/Makefile
+++ b/target/sdk/files/Makefile
@@ -14,6 +14,16 @@ export TOPDIR LC_ALL LANG SDK
world:
+# Initialize SDK snapshot
+.git/config:
+ @( \
+ echo -n "Initializing SDK ... "; \
+ git init -q .; \
+ find . -mindepth 1 -maxdepth 1 -not -name feeds | xargs git add; \
+ git commit -q -m "Initial state"; \
+ echo "ok."; \
+ )
+
include $(TOPDIR)/include/host.mk
ifneq ($(OPENWRT_BUILD),1)
@@ -36,14 +46,17 @@ else
$(package/stamp-compile): $(BUILD_DIR)/.prepared
$(BUILD_DIR)/.prepared: Makefile
@mkdir -p $$(dirname $@)
- @mkdir -p bin/packages
@touch $@
clean: FORCE
- rm -rf $(BUILD_DIR) $(BIN_DIR)
+ git clean -f -d $(STAGING_DIR); true
+ git clean -f -d $(BUILD_DIR); true
+ git clean -f -d $(BIN_DIR); true
dirclean: clean
- rm -rf $(TMP_DIR)
+ git reset --hard HEAD
+ git clean -f -d
+ rm -rf feeds/
# check prerequisites before starting to build
prereq: $(package/stamp-prereq) ;