summaryrefslogtreecommitdiffstats
path: root/target/sdk/files/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:27 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:27 +0000
commit49fda5e4d9d5f0f195894d82b3554deb88dfe413 (patch)
treecc197363e0c88e1367d25821a89aa4c5f4b49ec9 /target/sdk/files/include
parent1a27d74827b6f1ca494aa8e476d311ba74e82747 (diff)
downloadmaster-31e0f0ae-49fda5e4d9d5f0f195894d82b3554deb88dfe413.tar.gz
master-31e0f0ae-49fda5e4d9d5f0f195894d82b3554deb88dfe413.tar.bz2
master-31e0f0ae-49fda5e4d9d5f0f195894d82b3554deb88dfe413.zip
sdk: use prepare target to initialize git snapshot
The new approach is less prone to race conditions and will properly snapshot the symlinks prepared by the prereq-build target. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44330
Diffstat (limited to 'target/sdk/files/include')
-rw-r--r--target/sdk/files/include/prepare.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/sdk/files/include/prepare.mk b/target/sdk/files/include/prepare.mk
new file mode 100644
index 0000000000..76bad05a02
--- /dev/null
+++ b/target/sdk/files/include/prepare.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+prepare: .git/config
+
+.git/config:
+ @( \
+ printf "Initializing SDK ... "; \
+ git init -q .; \
+ find . -mindepth 1 -maxdepth 1 -not -name feeds | xargs git add; \
+ git commit -q -m "Initial state"; \
+ echo "ok."; \
+ )