summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-04-22 08:08:31 +0000
committerJohn Crispin <john@openwrt.org>2014-04-22 08:08:31 +0000
commit2b2d274bfa2fc7138423acbf2dbb53d665b1bf18 (patch)
treefac18929ecf3177c385cea8ef027094df3c11bcc /target/linux
parenta5cae0521e9385e342bff5dbaf3c8fbe71e85925 (diff)
downloadmaster-31e0f0ae-2b2d274bfa2fc7138423acbf2dbb53d665b1bf18.tar.gz
master-31e0f0ae-2b2d274bfa2fc7138423acbf2dbb53d665b1bf18.tar.bz2
master-31e0f0ae-2b2d274bfa2fc7138423acbf2dbb53d665b1bf18.zip
ramips: Add Airlink101 AR725W board support
Signed-off-by: Claudio Leite <leitec@staticky.com> SVN-Revision: 40549
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/AR725W.dts113
-rw-r--r--target/linux/ramips/image/Makefile3
-rw-r--r--target/linux/ramips/rt288x/config-3.101
3 files changed, 117 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/AR725W.dts b/target/linux/ramips/dts/AR725W.dts
new file mode 100644
index 0000000000..87f2553423
--- /dev/null
+++ b/target/linux/ramips/dts/AR725W.dts
@@ -0,0 +1,113 @@
+/dts-v1/;
+
+/include/ "rt2880.dtsi"
+
+/ {
+ compatible = "AR725W", "ralink,rt2880-soc";
+ model = "Airlink101 AR725W";
+
+ palmbus@300000 {
+ gpio0: gpio@600 {
+ status = "okay";
+ };
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "spi", "uartlite";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ ethernet@400000 {
+ status = "okay";
+ mtd-mac-address = <&factory 0x4>;
+
+ port@0 {
+ phy-handle = <&phy0>;
+ phy-mode = "mii";
+ };
+
+ mdio-bus {
+ status = "okay";
+ phy0: ethernet-phy@0 {
+ phy-mode = "mii";
+ reg = <0>;
+ };
+ };
+ };
+
+ wmac@480000 {
+ status = "okay";
+ ralink,mtd-eeprom = <&factory 0>;
+ };
+
+ cfi@bdc00000 {
+ compatible = "cfi-flash";
+ reg = <0xbc400000 0x800000>;
+
+ bank-width = <2>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ u-boot@0 {
+ reg = <0x0 0x30000>;
+ label = "u-boot";
+ read-only;
+ };
+
+ u-boot-env@30000 {
+ reg = <0x30000 0x10000>;
+ label = "u-boot-env";
+ };
+
+ factory: factory@40000 {
+ reg = <0x40000 0x10000>;
+ label = "factory";
+ read-only;
+ };
+
+ firmware@50000 {
+ reg = <0x50000 0x3B0000>;
+ label = "firmware";
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ status {
+ label = "ar725w:green:power";
+ gpios = <&gpio0 7 0>;
+ };
+
+ wpsred {
+ label = "ar725w:red:wps";
+ gpios = <&gpio0 8 1>;
+ };
+
+ wpsblue {
+ label = "ar725w:blue:wps";
+ gpios = <&gpio0 13 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <100>;
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x211>;
+ };
+ reset {
+ label = "reset";
+ gpios = <&gpio0 9 1>;
+ linux,code = <0x198>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 63f7425a9e..bf9ccc198a 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -261,6 +261,8 @@ BuildFirmware/PorayDualSize/initramfs=$(call BuildFirmware/DefaultDualSize/initr
# RT288X Profiles
#
+Image/Build/Profile/AR725W=$(call BuildFirmware/Default4M/$(1),$(1),ar725w,AR725W)
+
# 0x790000
belkin_f5d8235v1_mtd_size=7929856
Image/Build/Profile/F5D8235V1=$(call BuildFirmware/CustomFlash/$(1),$(1),f5d8235v1,F5D8235_V1,$(belkin_f5d8235v1_mtd_size))
@@ -273,6 +275,7 @@ Image/Build/Profile/WLITX4AG300N=$(call BuildFirmware/Default4M/$(1),$(1),wli-tx
ifeq ($(SUBTARGET),rt288x)
define Image/Build/Profile/Default
+ $(call Image/Build/Profile/AR725W,$(1))
$(call Image/Build/Profile/F5D8235V1,$(1))
$(call Image/Build/Profile/RTN15,$(1))
$(call Image/Build/Profile/V11STFE,$(1))
diff --git a/target/linux/ramips/rt288x/config-3.10 b/target/linux/ramips/rt288x/config-3.10
index f1ae652ec6..6fd3971beb 100644
--- a/target/linux/ramips/rt288x/config-3.10
+++ b/target/linux/ramips/rt288x/config-3.10
@@ -79,6 +79,7 @@ CONFIG_HW_RANDOM=m
CONFIG_HZ_PERIODIC=y
CONFIG_IMAGE_CMDLINE_HACK=y
CONFIG_INITRAMFS_SOURCE=""
+CONFIG_IP17XX_PHY=y
CONFIG_IRQCHIP=y
CONFIG_IRQ_CPU=y
CONFIG_IRQ_DOMAIN=y