summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-03-24 15:09:20 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-03-24 15:09:20 +0000
commitf5dc2ce0aa12ad9a40bbb841faf1bcadf44273c8 (patch)
treeb12684ade5c570afc85a3f39d7d34739639f56f8 /target/linux
parent62595883fbed75bab32d6798c12450f802deb6ee (diff)
downloadmaster-31e0f0ae-f5dc2ce0aa12ad9a40bbb841faf1bcadf44273c8.tar.gz
master-31e0f0ae-f5dc2ce0aa12ad9a40bbb841faf1bcadf44273c8.tar.bz2
master-31e0f0ae-f5dc2ce0aa12ad9a40bbb841faf1bcadf44273c8.zip
refresh patches
SVN-Revision: 15018
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/atheros/patches-2.6.28/001-get_c0_compare_irq_function.patch1
-rw-r--r--target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch4
-rw-r--r--target/linux/brcm63xx/patches-2.6.27/050-spi.patch12
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/150-netfilter_imq.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/976-ssb_fallback_sprom.patch28
5 files changed, 19 insertions, 28 deletions
diff --git a/target/linux/atheros/patches-2.6.28/001-get_c0_compare_irq_function.patch b/target/linux/atheros/patches-2.6.28/001-get_c0_compare_irq_function.patch
index 934eb5fc4e..fe2dd2757f 100644
--- a/target/linux/atheros/patches-2.6.28/001-get_c0_compare_irq_function.patch
+++ b/target/linux/atheros/patches-2.6.28/001-get_c0_compare_irq_function.patch
@@ -31,4 +31,3 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
#else
static inline int mips_clockevent_init(void)
{
-
diff --git a/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch b/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
index 243b650b62..e5cfdb82a3 100644
--- a/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
+++ b/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
@@ -19,7 +19,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1039,6 +1039,11 @@ MODULE_LICENSE ("GPL");
+@@ -1041,6 +1041,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ixp4xx_ehci_driver
#endif
@@ -33,7 +33,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
#error "missing bus glue for ehci-hcd"
--- a/drivers/usb/host/ehci.h
+++ b/drivers/usb/host/ehci.h
-@@ -755,6 +755,11 @@ ehci_port_speed(struct ehci_hcd *ehci, u
+@@ -761,6 +761,11 @@ ehci_port_speed(struct ehci_hcd *ehci, u
#define writel_be(val, addr) __raw_writel(val, (__force unsigned *)addr)
#endif
diff --git a/target/linux/brcm63xx/patches-2.6.27/050-spi.patch b/target/linux/brcm63xx/patches-2.6.27/050-spi.patch
index 7dea3172c9..fe3c430f13 100644
--- a/target/linux/brcm63xx/patches-2.6.27/050-spi.patch
+++ b/target/linux/brcm63xx/patches-2.6.27/050-spi.patch
@@ -1,6 +1,6 @@
---- a/drivers/spi/Kconfig 2009-03-06 02:24:35.000000000 +0100
-+++ b/drivers/spi/Kconfig 2009-03-06 02:25:01.000000000 +0100
-@@ -217,6 +217,13 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -217,6 +217,13 @@ config SPI_XILINX
See the "OPB Serial Peripheral Interface (SPI) (v1.00e)"
Product Specification document (DS464) for hardware details.
@@ -14,9 +14,9 @@
#
# Add new SPI master controllers in alphabetical order above this line
#
---- a/drivers/spi/Makefile 2009-03-06 02:25:07.000000000 +0100
-+++ b/drivers/spi/Makefile 2009-03-06 02:24:13.000000000 +0100
-@@ -30,6 +30,7 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_SPI_S3C24XX) += spi_s3c24x
obj-$(CONFIG_SPI_TXX9) += spi_txx9.o
obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
diff --git a/target/linux/generic-2.6/patches-2.6.27/150-netfilter_imq.patch b/target/linux/generic-2.6/patches-2.6.27/150-netfilter_imq.patch
index d8c1e31d63..46adc66e45 100644
--- a/target/linux/generic-2.6/patches-2.6.27/150-netfilter_imq.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/150-netfilter_imq.patch
@@ -664,7 +664,7 @@
#ifdef CONFIG_BRIDGE_NETFILTER
struct nf_bridge_info *nf_bridge;
#endif
-@@ -1642,6 +1646,10 @@ static inline void __nf_copy(struct sk_b
+@@ -1633,6 +1637,10 @@ static inline void __nf_copy(struct sk_b
dst->nfct_reasm = src->nfct_reasm;
nf_conntrack_get_reasm(src->nfct_reasm);
#endif
diff --git a/target/linux/generic-2.6/patches-2.6.27/976-ssb_fallback_sprom.patch b/target/linux/generic-2.6/patches-2.6.27/976-ssb_fallback_sprom.patch
index 815c37d067..295d00ee6f 100644
--- a/target/linux/generic-2.6/patches-2.6.27/976-ssb_fallback_sprom.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/976-ssb_fallback_sprom.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.28.7/drivers/ssb/pci.c
-===================================================================
---- linux-2.6.28.7.orig/drivers/ssb/pci.c 2009-02-26 20:37:02.000000000 +0100
-+++ linux-2.6.28.7/drivers/ssb/pci.c 2009-02-26 20:41:44.000000000 +0100
-@@ -514,6 +514,7 @@ unsupported:
+--- a/drivers/ssb/pci.c
++++ b/drivers/ssb/pci.c
+@@ -500,6 +500,7 @@ unsupported:
static int ssb_pci_sprom_get(struct ssb_bus *bus,
struct ssb_sprom *sprom)
{
@@ -10,7 +8,7 @@ Index: linux-2.6.28.7/drivers/ssb/pci.c
int err = -ENOMEM;
u16 *buf;
-@@ -533,12 +534,23 @@ static int ssb_pci_sprom_get(struct ssb_
+@@ -519,12 +520,23 @@ static int ssb_pci_sprom_get(struct ssb_
bus->sprom_size = SSB_SPROMSIZE_WORDS_R4;
sprom_do_read(bus, buf);
err = sprom_check_crc(buf, bus->sprom_size);
@@ -35,10 +33,8 @@ Index: linux-2.6.28.7/drivers/ssb/pci.c
kfree(buf);
out:
return err;
-Index: linux-2.6.28.7/drivers/ssb/sprom.c
-===================================================================
---- linux-2.6.28.7.orig/drivers/ssb/sprom.c 2009-02-26 20:33:21.000000000 +0100
-+++ linux-2.6.28.7/drivers/ssb/sprom.c 2009-02-26 20:52:35.000000000 +0100
+--- a/drivers/ssb/sprom.c
++++ b/drivers/ssb/sprom.c
@@ -14,6 +14,9 @@
#include "ssb_private.h"
@@ -86,10 +82,8 @@ Index: linux-2.6.28.7/drivers/ssb/sprom.c
+{
+ return fallback_sprom;
+}
-Index: linux-2.6.28.7/drivers/ssb/ssb_private.h
-===================================================================
---- linux-2.6.28.7.orig/drivers/ssb/ssb_private.h 2009-02-26 20:36:33.000000000 +0100
-+++ linux-2.6.28.7/drivers/ssb/ssb_private.h 2009-02-26 20:36:56.000000000 +0100
+--- a/drivers/ssb/ssb_private.h
++++ b/drivers/ssb/ssb_private.h
@@ -131,6 +131,7 @@ ssize_t ssb_attr_sprom_store(struct ssb_
const char *buf, size_t count,
int (*sprom_check_crc)(const u16 *sprom, size_t size),
@@ -98,10 +92,8 @@ Index: linux-2.6.28.7/drivers/ssb/ssb_private.h
/* core.c */
-Index: linux-2.6.28.7/include/linux/ssb/ssb.h
-===================================================================
---- linux-2.6.28.7.orig/include/linux/ssb/ssb.h 2009-02-26 20:26:34.000000000 +0100
-+++ linux-2.6.28.7/include/linux/ssb/ssb.h 2009-02-26 20:32:30.000000000 +0100
+--- a/include/linux/ssb/ssb.h
++++ b/include/linux/ssb/ssb.h
@@ -339,6 +339,10 @@ extern int ssb_bus_pcmciabus_register(st
extern void ssb_bus_unregister(struct ssb_bus *bus);