summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-17 16:36:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-17 16:36:19 +0000
commite819113e2ee031f6bcdb4677cf26d497e8655d9c (patch)
tree23780e0d017eb3cf3651217bf606f7ff98099971 /target/linux
parent6be418e3e1a6e45af6b7575f2e41023c6f981ba7 (diff)
downloadmaster-31e0f0ae-e819113e2ee031f6bcdb4677cf26d497e8655d9c.tar.gz
master-31e0f0ae-e819113e2ee031f6bcdb4677cf26d497e8655d9c.tar.bz2
master-31e0f0ae-e819113e2ee031f6bcdb4677cf26d497e8655d9c.zip
atheros[ar231x-eth]: move driver to atheros subdirectory
Move driver code to respective vendor subdirectory and fix config symbol name. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 41690
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/atheros/config-3.102
-rw-r--r--target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch59
-rw-r--r--target/linux/atheros/patches-3.10/220-enet_micrel_workaround.patch4
3 files changed, 33 insertions, 32 deletions
diff --git a/target/linux/atheros/config-3.10 b/target/linux/atheros/config-3.10
index ccbb592175..08c40872ee 100644
--- a/target/linux/atheros/config-3.10
+++ b/target/linux/atheros/config-3.10
@@ -100,7 +100,7 @@ CONFIG_MTD_REDBOOT_PARTS=y
CONFIG_MVSWITCH_PHY=y
CONFIG_NEED_DMA_MAP_STATE=y
CONFIG_NEED_PER_CPU_KM=y
-CONFIG_NET_VENDOR_AR231X=y
+CONFIG_NET_AR231X=y
CONFIG_NO_GENERIC_PCI_IOPORT_MAP=y
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PCI=y
diff --git a/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch b/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch
index a0c411599d..5f743b433c 100644
--- a/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch
+++ b/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch
@@ -1,37 +1,38 @@
---- a/drivers/net/ethernet/Kconfig
-+++ b/drivers/net/ethernet/Kconfig
-@@ -22,6 +22,7 @@ source "drivers/net/ethernet/adaptec/Kco
- source "drivers/net/ethernet/aeroflex/Kconfig"
- source "drivers/net/ethernet/alteon/Kconfig"
- source "drivers/net/ethernet/amd/Kconfig"
-+source "drivers/net/ethernet/ar231x/Kconfig"
- source "drivers/net/ethernet/apple/Kconfig"
- source "drivers/net/ethernet/atheros/Kconfig"
- source "drivers/net/ethernet/cadence/Kconfig"
---- a/drivers/net/ethernet/Makefile
-+++ b/drivers/net/ethernet/Makefile
-@@ -9,6 +9,7 @@ obj-$(CONFIG_GRETH) += aeroflex/
- obj-$(CONFIG_NET_VENDOR_ALTEON) += alteon/
- obj-$(CONFIG_NET_VENDOR_AMD) += amd/
- obj-$(CONFIG_NET_VENDOR_APPLE) += apple/
-+obj-$(CONFIG_NET_VENDOR_AR231X) += ar231x/
- obj-$(CONFIG_NET_VENDOR_ATHEROS) += atheros/
- obj-$(CONFIG_NET_CADENCE) += cadence/
- obj-$(CONFIG_NET_BFIN) += adi/
---- /dev/null
-+++ b/drivers/net/ethernet/ar231x/Kconfig
-@@ -0,0 +1,5 @@
-+config NET_VENDOR_AR231X
-+ tristate "AR231X Ethernet support"
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -7,3 +7,4 @@ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/
+ obj-$(CONFIG_ATL1C) += atl1c/
+ obj-$(CONFIG_ALX) += alx/
++obj-$(CONFIG_NET_AR231X) += ar231x/
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -5,7 +5,7 @@
+ config NET_VENDOR_ATHEROS
+ bool "Atheros devices"
+ default y
+- depends on PCI
++ depends on (PCI || ATHEROS_AR231X)
+ ---help---
+ If you have a network (Ethernet) card belonging to this class, say Y
+ and read the Ethernet-HOWTO, available from
+@@ -85,4 +85,10 @@ config ALX
+ To compile this driver as a module, choose M here. The module
+ will be called alx.
+
++config NET_AR231X
++ tristate "Atheros AR231X built-in Ethernet support"
+ depends on ATHEROS_AR231X
+ help
+ Support for the AR231x/531x ethernet controller
++
+ endif # NET_VENDOR_ATHEROS
--- /dev/null
-+++ b/drivers/net/ethernet/ar231x/Makefile
++++ b/drivers/net/ethernet/atheros/ar231x/Makefile
@@ -0,0 +1 @@
-+obj-$(CONFIG_NET_VENDOR_AR231X) += ar231x.o
++obj-$(CONFIG_NET_AR231X) += ar231x.o
--- /dev/null
-+++ b/drivers/net/ethernet/ar231x/ar231x.c
++++ b/drivers/net/ethernet/atheros/ar231x/ar231x.c
@@ -0,0 +1,1249 @@
+/*
+ * ar231x.c: Linux driver for the Atheros AR231x Ethernet device.
@@ -1283,7 +1284,7 @@
+}
+
--- /dev/null
-+++ b/drivers/net/ethernet/ar231x/ar231x.h
++++ b/drivers/net/ethernet/atheros/ar231x/ar231x.h
@@ -0,0 +1,287 @@
+/*
+ * ar231x.h: Linux driver for the Atheros AR231x Ethernet device.
diff --git a/target/linux/atheros/patches-3.10/220-enet_micrel_workaround.patch b/target/linux/atheros/patches-3.10/220-enet_micrel_workaround.patch
index ada0a76b13..cc3a74ec51 100644
--- a/target/linux/atheros/patches-3.10/220-enet_micrel_workaround.patch
+++ b/target/linux/atheros/patches-3.10/220-enet_micrel_workaround.patch
@@ -1,5 +1,5 @@
---- a/drivers/net/ethernet/ar231x/ar231x.c
-+++ b/drivers/net/ethernet/ar231x/ar231x.c
+--- a/drivers/net/ethernet/atheros/ar231x/ar231x.c
++++ b/drivers/net/ethernet/atheros/ar231x/ar231x.c
@@ -148,6 +148,7 @@ static int ar231x_mdiobus_write(struct m
static int ar231x_mdiobus_reset(struct mii_bus *bus);
static int ar231x_mdiobus_probe(struct net_device *dev);