summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-10-02 12:25:27 +0000
committerJonas Gorski <jogo@openwrt.org>2014-10-02 12:25:27 +0000
commite7ade47fbad2248cc3a75e132880566cb9ba3d29 (patch)
tree8201af1defcd27566421c33111039a0dd1c54b0d /target/linux
parentd9194da8824b4a616d641e552e813a74faf542e1 (diff)
downloadmaster-31e0f0ae-e7ade47fbad2248cc3a75e132880566cb9ba3d29.tar.gz
master-31e0f0ae-e7ade47fbad2248cc3a75e132880566cb9ba3d29.tar.bz2
master-31e0f0ae-e7ade47fbad2248cc3a75e132880566cb9ba3d29.zip
brcm63xx: Add DT support for 96338W
Renamed of_board_id to convention. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42734
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm63xx/dts/bcm96338W.dts8
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile3
-rw-r--r--target/linux/brcm63xx/patches-3.14/370-bcm63xx-add-of_board_ids-for-all-supported-boards.patch2
-rw-r--r--target/linux/brcm63xx/profiles/01-generic.mk9
4 files changed, 20 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/dts/bcm96338W.dts b/target/linux/brcm63xx/dts/bcm96338W.dts
new file mode 100644
index 0000000000..1609541425
--- /dev/null
+++ b/target/linux/brcm63xx/dts/bcm96338W.dts
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6338.dtsi"
+
+/ {
+ model = "Broadcom BCM96338W reference board";
+ compatible = "brcm,bcm96338w", "brcm,bcm6338";
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index c7e7978b28..957ea9b326 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -234,7 +234,6 @@ endef
define Image/Build
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
# Various routers
- $(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
$(call Image/Build/CFE,$(1),96358VW,6358,96358VW-generic)
$(call Image/Build/CFE,$(1),96358VW2,6358,96358VW2-generic)
$(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
@@ -335,6 +334,8 @@ $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-8M-fla
$(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-flash-generic,,--pad 8))
# Generic 96338GW
$(eval $(call CfeImageDTB,96338GW,bcm96338GW,6338GW,6338,96338GW-generic))
+# Generic 96338W
+$(eval $(call CfeImageDTB,96338W,bcm96338W,6338W,6338,96338W-generic))
# Generic 96345GW2
$(eval $(call CfeImageDTB,96345GW2,bcm96345GW2,96345GW2,6345,96345GW2-generic))
$(eval $(call CfeImageDTB,96345GW2,bcm96345GW2,96345GW2,6345,96345GW2-bc221,,--layoutver 5))
diff --git a/target/linux/brcm63xx/patches-3.14/370-bcm63xx-add-of_board_ids-for-all-supported-boards.patch b/target/linux/brcm63xx/patches-3.14/370-bcm63xx-add-of_board_ids-for-all-supported-boards.patch
index 004f526f42..a997212aeb 100644
--- a/target/linux/brcm63xx/patches-3.14/370-bcm63xx-add-of_board_ids-for-all-supported-boards.patch
+++ b/target/linux/brcm63xx/patches-3.14/370-bcm63xx-add-of_board_ids-for-all-supported-boards.patch
@@ -37,7 +37,7 @@ Subject: [PATCH 48/48] MIPS: BCM63XX: add of_board_ids for all supported boards
static struct board_info __initdata board_96338w = {
.name = "96338W",
-+ .of_board_id = "brcm,96338w",
++ .of_board_id = "brcm,bcm96338w",
.expected_cpu_id = 0x6338,
.has_uart0 = 1,
diff --git a/target/linux/brcm63xx/profiles/01-generic.mk b/target/linux/brcm63xx/profiles/01-generic.mk
index 30a17ab2d3..eb17f95f83 100644
--- a/target/linux/brcm63xx/profiles/01-generic.mk
+++ b/target/linux/brcm63xx/profiles/01-generic.mk
@@ -32,6 +32,15 @@ define Profile/96338GW/Description
endef
$(eval $(call Profile,96338GW))
+define Profile/96338W
+ NAME:=Generic 96338W
+ PACKAGES:=
+endef
+define Profile/96338W/Description
+ Package set optimized for 96338W.
+endef
+$(eval $(call Profile,96338W))
+
define Profile/96345GW2
NAME:=Generic 96345GW2
PACKAGES:=