summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-25 22:18:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-25 22:18:17 +0000
commitdef45b136cf95d555d4e18bea7b5caa56155d0b7 (patch)
tree49db6769a9a14d4073e51c01311ea3549ce61372 /target/linux
parenta119ee0013102aa7b9312250b53acf438120d2e6 (diff)
downloadmaster-31e0f0ae-def45b136cf95d555d4e18bea7b5caa56155d0b7.tar.gz
master-31e0f0ae-def45b136cf95d555d4e18bea7b5caa56155d0b7.tar.bz2
master-31e0f0ae-def45b136cf95d555d4e18bea7b5caa56155d0b7.zip
kernel: remove wrong chunks from the 2.6.37 and 2.6.38 version of the mips oprofile fix
SVN-Revision: 26297
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch12
-rw-r--r--target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch12
2 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch b/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch
index 2841ed883e..f83c96bb81 100644
--- a/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch
+++ b/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch
@@ -1,15 +1,3 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
- endif
- endif
-
-+ifndef CONFIG_PROFILING
-+ cflags-y := -ffunction-sections
-+endif
- ifdef CONFIG_FUNCTION_GRAPH_TRACER
- ifndef KBUILD_MCOUNT_RA_ADDRESS
- ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
diff --git a/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch b/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch
index 2841ed883e..f83c96bb81 100644
--- a/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch
+++ b/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch
@@ -1,15 +1,3 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
- endif
- endif
-
-+ifndef CONFIG_PROFILING
-+ cflags-y := -ffunction-sections
-+endif
- ifdef CONFIG_FUNCTION_GRAPH_TRACER
- ifndef KBUILD_MCOUNT_RA_ADDRESS
- ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)