summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-04 18:37:09 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-04 18:37:09 +0000
commitd5555de5b0f65140791594ea485cd9528a58b560 (patch)
tree1ad78888754600b1a4655cdfde54d2b7e847fb0a /target/linux
parent3eb676240fb08796f16cbf5cf83dbf917f7814bc (diff)
downloadmaster-31e0f0ae-d5555de5b0f65140791594ea485cd9528a58b560.tar.gz
master-31e0f0ae-d5555de5b0f65140791594ea485cd9528a58b560.tar.bz2
master-31e0f0ae-d5555de5b0f65140791594ea485cd9528a58b560.zip
ar71xx: move WNDR4300 profile to the nand subtarget
Signed-off-by: Stefan Agner <stefan@agner.ch> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38647
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk14
-rw-r--r--target/linux/ar71xx/image/Makefile7
-rw-r--r--target/linux/ar71xx/nand/profiles/netgear.mk19
3 files changed, 25 insertions, 15 deletions
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
index c5adc0d264..597c7aa3df 100644
--- a/target/linux/ar71xx/generic/profiles/netgear.mk
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -28,18 +28,6 @@ endef
$(eval $(call Profile,WNDR3700))
-define Profile/WNDR4300
- NAME:=NETGEAR WNDR4300
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
-endef
-
-define Profile/WNDR4300/Description
- Package set optimized for the NETGEAR WNDR4300
-endef
-
-$(eval $(call Profile,WNDR4300))
-
-
define Profile/WNR2000V3
NAME:=NETGEAR WNR2000V3
endef
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a0f34c7275..b1909ddcc7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -874,8 +874,6 @@ $(eval $(call SingleProfile,Netgear,64kraw,WNDR3800,wndr3800,WNDR3700,ttyS0,1152
$(eval $(call SingleProfile,Netgear,64kraw,WNDRMAC,wndrmac,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMAC,"",-H 29763654+16+64))
$(eval $(call SingleProfile,Netgear,64kraw,WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMACv2,"",-H 29763654+16+128))
-$(eval $(call SingleProfile,NetgearNAND,64k,WNDR4300,wndr4300,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),3703,WNDR4300,"",-H 29763948+0+128+128+2x2+3x3))
-
$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
@@ -1006,6 +1004,11 @@ $(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
$(eval $(call MultiProfile,Madwifi,EAP7660D UBNTRS UBNTRSPRO UBNTLSSR71 WP543))
endif # ifeq ($(SUBTARGET),generic)
+ifeq ($(SUBTARGET),nand)
+$(eval $(call SingleProfile,NetgearNAND,64k,WNDR4300,wndr4300,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),3703,WNDR4300,"",-H 29763948+0+128+128+2x2+3x3))
+endif # ifeq ($(SUBTARGET),nand)
+
+
$(eval $(call MultiProfile,Default,$(SINGLE_PROFILES)))
define Image/Build/squashfs
diff --git a/target/linux/ar71xx/nand/profiles/netgear.mk b/target/linux/ar71xx/nand/profiles/netgear.mk
new file mode 100644
index 0000000000..471ef376a9
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/netgear.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WNDR4300
+ NAME:=NETGEAR WNDR4300
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+ Package set optimized for the NETGEAR WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
+
+