summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-25 19:03:01 +0000
committerJohn Crispin <john@openwrt.org>2013-04-25 19:03:01 +0000
commitcf3885eb0f276f3d0a12aeeff3445799b59fbb23 (patch)
tree257257f55ccc93c29cd6d68abb1cc3a225c52579 /target/linux
parent978567a89e3a1460f0fc1e9d39c7b70548de6629 (diff)
downloadmaster-31e0f0ae-cf3885eb0f276f3d0a12aeeff3445799b59fbb23.tar.gz
master-31e0f0ae-cf3885eb0f276f3d0a12aeeff3445799b59fbb23.tar.bz2
master-31e0f0ae-cf3885eb0f276f3d0a12aeeff3445799b59fbb23.zip
ramips: introduce DTS for ALL5003
Prior to the switch to 3.8, ALL5002 and ALL5003 boards shared mach-all5002.c. With the change to DTS, this is no longer accurate, as ALL5002 is based on Rt3352 SoC while ALL5003 is based on Rt5350 SoC, therefore the corresponding rt5350.dtsi need to be included for ALL5003. Signed-off-by: Daniel Golle <dgolle@allnet.de> Patchwork: http://patchwork.openwrt.org/patch/3557/ Acked-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36435
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom1
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/02_network1
-rw-r--r--target/linux/ramips/base-files/lib/preinit/06_set_iface_mac1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh9
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/ALL5002.dts2
-rw-r--r--target/linux/ramips/dts/ALL5003.dts108
-rw-r--r--target/linux/ramips/image/Makefile2
-rw-r--r--target/linux/ramips/rt305x/profiles/allnet.mk12
9 files changed, 133 insertions, 4 deletions
diff --git a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index 538047b42d..320e01d904 100644
--- a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -59,6 +59,7 @@ case "$FIRMWARE" in
all0239-3g | \
all0256n | \
all5002 | \
+ all5003 | \
argus-atp52b | \
bc2 | \
br6425 | \
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/02_network b/target/linux/ramips/base-files/etc/uci-defaults/02_network
index b3d87d2889..41907bf1d1 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/02_network
@@ -41,6 +41,7 @@ ramips_setup_interfaces()
w150m | \
all0256n | \
all5002 | \
+ all5003 | \
broadway | \
wnce2001)
ucidef_add_switch "switch0" "1" "0"
diff --git a/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac b/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
index 7becaf7ad9..022f72e240 100644
--- a/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
+++ b/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
@@ -53,6 +53,7 @@ preinit_set_mac_address() {
all0239-3g |\
all0256n |\
all5002 |\
+ all5003 |\
carambola |\
dir-615-h1 |\
fonera20n |\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index c1355bcadc..99bdbdd80e 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -48,9 +48,12 @@ ramips_board_detect() {
*"Allnet ALL0256N")
name="all0256n"
;;
- *"Allnet ALL5002/ALL5003")
+ *"Allnet ALL5002")
name="all5002"
;;
+ *"Allnet ALL5003")
+ name="all5003"
+ ;;
*"ARC FreeStation5")
name="freestation5"
;;
@@ -212,7 +215,7 @@ ramips_board_detect() {
;;
*"UR-326N4G Wireless N router")
name="ur-326n4g"
- ;;
+ ;;
*"UR-336UN Wireless N router")
name="ur-336un"
;;
@@ -228,7 +231,7 @@ ramips_board_detect() {
esac
case "$machine" in
- *"Allnet ALL5002/ALL5003")
+ *"Allnet ALL500"[23]*)
all500x_board_detect
;;
esac
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 15c0007a04..b2fa0bd957 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -22,6 +22,7 @@ platform_check_image() {
all0239-3g | \
all0256n | \
all5002 | \
+ all5003 | \
asl26555 | \
bc2 | \
broadway | \
diff --git a/target/linux/ramips/dts/ALL5002.dts b/target/linux/ramips/dts/ALL5002.dts
index fb704f3aba..0ede2e3215 100644
--- a/target/linux/ramips/dts/ALL5002.dts
+++ b/target/linux/ramips/dts/ALL5002.dts
@@ -4,7 +4,7 @@
/ {
compatible = "ALL5002", "ralink,rt3352-soc";
- model = "Allnet ALL5002/ALL5003";
+ model = "Allnet ALL5002";
palmbus@10000000 {
sysc@0 {
diff --git a/target/linux/ramips/dts/ALL5003.dts b/target/linux/ramips/dts/ALL5003.dts
new file mode 100644
index 0000000000..581304e3a7
--- /dev/null
+++ b/target/linux/ramips/dts/ALL5003.dts
@@ -0,0 +1,108 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+ compatible = "ALL5003", "ralink,rt5350-soc";
+ model = "Allnet ALL5003";
+
+ palmbus@10000000 {
+ sysc@0 {
+ ralink,pinmux = "spi", "uartlite", "jtag", "mdio", "sdram", "rgmii";
+ ralink,gpiomux = "i2c";
+ ralink,uartmux = "gpio";
+ ralink,wdtmux = <1>;
+ };
+
+ gpio0: gpio@600 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l25635e";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "mx25l25635e";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x1fb0000>;
+ };
+ };
+ };
+ };
+
+ ethernet@10100000 {
+ status = "okay";
+ };
+
+ esw@10110000 {
+ status = "okay";
+ ralink,portmap = <0x3f>;
+ };
+
+ wmac@10180000 {
+ status = "okay";
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+
+ i2c-gpio {
+ compatible = "i2c-gpio";
+
+ gpios = <&gpio0 1 0 &gpio0 2 0>;
+ i2c-gpio,delay-us = <10>;
+
+ pcf0: iexp@38 {
+ #gpio-cells = <2>;
+ compatible = "inxp,pcf8574a";
+ reg = <0x38>;
+ gpio-controller;
+ };
+
+ hwmon@4b {
+ compatible = "national,lm92";
+ reg = <0x4b>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ ld1 {
+ label = "allnet:green:ld1";
+ gpios = <&pcf0 0 1>;
+ };
+ ld2 {
+ label = "allnet:green:ld2";
+ gpios = <&pcf0 1 1>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 99d4702403..621f23edb9 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -265,6 +265,7 @@ Image/Build/Profile/ALL0256N=$(call BuildFirmware/DefaultDualSize/$(1),$(1),all0
allnet_all5002_mtd_size=33226752
Image/Build/Profile/ALL5002=$(call BuildFirmware/CustomFlash/$(1),$(1),all5002,ALL5002,$(allnet_all5002_mtd_size))
+Image/Build/Profile/ALL5003=$(call BuildFirmware/CustomFlash/$(1),$(1),all5003,ALL5003,$(allnet_all5002_mtd_size))
argus_atp52b_mtd_size=7995392
Image/Build/Profile/ARGUS_ATP52B=$(call BuildFirmware/CustomFlash/$(1),$(1),argus_atp52b,ARGUS_ATP52B,$(argus_atp52b_mtd_size))
@@ -436,6 +437,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/ALL02393G,$(1))
$(call Image/Build/Profile/ALL0256N,$(1))
$(call Image/Build/Profile/ALL5002,$(1))
+ $(call Image/Build/Profile/ALL5003,$(1))
$(call Image/Build/Profile/ARGUS_ATP52B,$(1))
$(call Image/Build/Profile/ASL26555,$(1))
$(call Image/Build/Profile/BC2,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/allnet.mk b/target/linux/ramips/rt305x/profiles/allnet.mk
index 4ec2ffdd5c..858891f4d4 100644
--- a/target/linux/ramips/rt305x/profiles/allnet.mk
+++ b/target/linux/ramips/rt305x/profiles/allnet.mk
@@ -40,3 +40,15 @@ define Profile/ALL5002/Description
endef
$(eval $(call Profile,ALL5002))
+
+define Profile/ALL5003
+ NAME:=Allnet ALL5003
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-i2c-core kmod-i2c-gpio kmod-hwmon-lm92 kmod-gpio-pcf857x
+endef
+
+define Profile/ALL5003/Description
+ Package set for Allnet ALL5003
+endef
+
+$(eval $(call Profile,ALL5003))