summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:38:28 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:38:28 +0000
commitc560444a584adf9efc36ba78eead9fc3e4afdd66 (patch)
tree6db0004fa55454faf536bfeb3bce26a066edeae4 /target/linux
parente49d3e1d5bdbaabe80dd0e3d0b4da93b2914461e (diff)
downloadmaster-31e0f0ae-c560444a584adf9efc36ba78eead9fc3e4afdd66.tar.gz
master-31e0f0ae-c560444a584adf9efc36ba78eead9fc3e4afdd66.tar.bz2
master-31e0f0ae-c560444a584adf9efc36ba78eead9fc3e4afdd66.zip
kernel: update linux 3.1 to 3.1.9
SVN-Revision: 29726
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm63xx/patches-3.1/010-add_bcm63xx_ohci_controller.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.1/448-board-MAGIC.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.1/449-board_hw553.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.1/450-board_rta1320_16m.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.1/451-board_spw303v.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.1/452-board_V2500V.patch8
-rw-r--r--target/linux/brcm63xx/patches-3.1/453-board_BTV2110.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.1/455-board_ct536_ct5621.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.1/456-board_DWV-S0_fixes.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.1/977-ssb_export_fallback_sprom.patch4
-rw-r--r--target/linux/generic/patches-3.1/020-ssb_update.patch19
-rw-r--r--target/linux/generic/patches-3.1/100-overlayfs_v11.patch4
-rw-r--r--target/linux/generic/patches-3.1/720-phy_adm6996.patch2
-rw-r--r--target/linux/generic/patches-3.1/722-phy_mvswitch.patch2
-rw-r--r--target/linux/generic/patches-3.1/723-phy_ip175c.patch2
-rw-r--r--target/linux/generic/patches-3.1/724-phy_ar8216.patch2
-rw-r--r--target/linux/generic/patches-3.1/725-phy_rtl8306.patch2
-rw-r--r--target/linux/generic/patches-3.1/726-phy_rtl8366.patch2
-rw-r--r--target/linux/generic/patches-3.1/811-pci_disable_usb_common_quirks.patch4
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/omap24xx/Makefile2
-rw-r--r--target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch14
-rw-r--r--target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch6
23 files changed, 41 insertions, 60 deletions
diff --git a/target/linux/brcm63xx/patches-3.1/010-add_bcm63xx_ohci_controller.patch b/target/linux/brcm63xx/patches-3.1/010-add_bcm63xx_ohci_controller.patch
index add74a5467..2666e60ba0 100644
--- a/target/linux/brcm63xx/patches-3.1/010-add_bcm63xx_ohci_controller.patch
+++ b/target/linux/brcm63xx/patches-3.1/010-add_bcm63xx_ohci_controller.patch
@@ -177,7 +177,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
+MODULE_ALIAS("platform:bcm63xx_ohci");
--- a/drivers/usb/host/ohci-hcd.c
+++ b/drivers/usb/host/ohci-hcd.c
-@@ -1058,6 +1058,11 @@ MODULE_LICENSE ("GPL");
+@@ -1055,6 +1055,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ohci_hcd_da8xx_driver
#endif
@@ -191,7 +191,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
#define PLATFORM_DRIVER ohci_hcd_sh_driver
--- a/drivers/usb/host/ohci.h
+++ b/drivers/usb/host/ohci.h
-@@ -646,7 +646,7 @@ static inline u32 hc32_to_cpup (const st
+@@ -645,7 +645,7 @@ static inline u32 hc32_to_cpup (const st
* some big-endian SOC implementations. Same thing happens with PSW access.
*/
diff --git a/target/linux/brcm63xx/patches-3.1/448-board-MAGIC.patch b/target/linux/brcm63xx/patches-3.1/448-board-MAGIC.patch
index 47e7db1417..1db6933dfb 100644
--- a/target/linux/brcm63xx/patches-3.1/448-board-MAGIC.patch
+++ b/target/linux/brcm63xx/patches-3.1/448-board-MAGIC.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -751,6 +751,76 @@ static struct board_info __initdata boar
+@@ -746,6 +746,76 @@ static struct board_info __initdata boar
},
};
@@ -77,7 +77,7 @@
#endif
/*
-@@ -1661,6 +1731,7 @@ static const struct board_info __initdat
+@@ -1656,6 +1726,7 @@ static const struct board_info __initdat
&board_rta1025w_16,
&board_96348_D4PW,
&board_spw500v,
diff --git a/target/linux/brcm63xx/patches-3.1/449-board_hw553.patch b/target/linux/brcm63xx/patches-3.1/449-board_hw553.patch
index 964f46c767..9fe0c29166 100644
--- a/target/linux/brcm63xx/patches-3.1/449-board_hw553.patch
+++ b/target/linux/brcm63xx/patches-3.1/449-board_hw553.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1704,6 +1704,81 @@ static struct board_info __initdata boar
+@@ -1699,6 +1699,81 @@ static struct board_info __initdata boar
.spis = nb4_spi_devices,
.num_spis = ARRAY_SIZE(nb4_spi_devices),
};
@@ -82,7 +82,7 @@
#endif
/*
-@@ -1746,6 +1821,7 @@ static const struct board_info __initdat
+@@ -1741,6 +1816,7 @@ static const struct board_info __initdat
&board_nb4_ser_r2,
&board_nb4_fxc_r1,
&board_nb4_fxc_r2,
diff --git a/target/linux/brcm63xx/patches-3.1/450-board_rta1320_16m.patch b/target/linux/brcm63xx/patches-3.1/450-board_rta1320_16m.patch
index ed5a33b628..39f2eab019 100644
--- a/target/linux/brcm63xx/patches-3.1/450-board_rta1320_16m.patch
+++ b/target/linux/brcm63xx/patches-3.1/450-board_rta1320_16m.patch
@@ -44,7 +44,7 @@
#endif
/*
-@@ -1789,6 +1826,7 @@ static const struct board_info __initdat
+@@ -1784,6 +1821,7 @@ static const struct board_info __initdat
&board_96338gw,
&board_96338w,
&board_96338w2_e7t,
diff --git a/target/linux/brcm63xx/patches-3.1/451-board_spw303v.patch b/target/linux/brcm63xx/patches-3.1/451-board_spw303v.patch
index db8d352960..deae36689e 100644
--- a/target/linux/brcm63xx/patches-3.1/451-board_spw303v.patch
+++ b/target/linux/brcm63xx/patches-3.1/451-board_spw303v.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1816,6 +1816,72 @@ static struct board_info __initdata boar
+@@ -1811,6 +1811,72 @@ static struct board_info __initdata boar
},
},
};
@@ -73,7 +73,7 @@
#endif
/*
-@@ -1860,6 +1926,7 @@ static const struct board_info __initdat
+@@ -1855,6 +1921,7 @@ static const struct board_info __initdat
&board_nb4_fxc_r1,
&board_nb4_fxc_r2,
&board_HW553,
diff --git a/target/linux/brcm63xx/patches-3.1/452-board_V2500V.patch b/target/linux/brcm63xx/patches-3.1/452-board_V2500V.patch
index f28a10d6cc..a7ab28981e 100644
--- a/target/linux/brcm63xx/patches-3.1/452-board_V2500V.patch
+++ b/target/linux/brcm63xx/patches-3.1/452-board_V2500V.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -858,6 +858,63 @@ static struct board_info __initdata boar
+@@ -853,6 +853,63 @@ static struct board_info __initdata boar
},
};
@@ -64,7 +64,7 @@
#endif
/*
-@@ -1911,6 +1968,7 @@ static const struct board_info __initdat
+@@ -1906,6 +1963,7 @@ static const struct board_info __initdat
&board_96348_D4PW,
&board_spw500v,
&board_96348sv,
@@ -72,7 +72,7 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_6358
-@@ -2064,6 +2122,22 @@ void __init board_prom_init(void)
+@@ -2059,6 +2117,22 @@ void __init board_prom_init(void)
val = bcm_mpi_readl(MPI_CSBASE_REG(0));
val &= MPI_CSBASE_BASE_MASK;
boot_addr = (u8 *)KSEG1ADDR(val);
@@ -95,7 +95,7 @@
/* dump cfe version */
cfe = boot_addr + BCM963XX_CFE_VERSION_OFFSET;
-@@ -2265,6 +2339,13 @@ int __init board_register_devices(void)
+@@ -2260,6 +2334,13 @@ int __init board_register_devices(void)
val = bcm_mpi_readl(MPI_CSBASE_REG(0));
val &= MPI_CSBASE_BASE_MASK;
diff --git a/target/linux/brcm63xx/patches-3.1/453-board_BTV2110.patch b/target/linux/brcm63xx/patches-3.1/453-board_BTV2110.patch
index a9e49eb969..5164ee6473 100644
--- a/target/linux/brcm63xx/patches-3.1/453-board_BTV2110.patch
+++ b/target/linux/brcm63xx/patches-3.1/453-board_BTV2110.patch
@@ -63,7 +63,7 @@
static struct board_info __initdata board_96348gw = {
.name = "96348GW",
.expected_cpu_id = 0x6348,
-@@ -1969,6 +2025,7 @@ static const struct board_info __initdat
+@@ -1964,6 +2020,7 @@ static const struct board_info __initdat
&board_spw500v,
&board_96348sv,
&board_V2500V_BB,
diff --git a/target/linux/brcm63xx/patches-3.1/455-board_ct536_ct5621.patch b/target/linux/brcm63xx/patches-3.1/455-board_ct536_ct5621.patch
index cdb931ff6e..dc00e43bda 100644
--- a/target/linux/brcm63xx/patches-3.1/455-board_ct536_ct5621.patch
+++ b/target/linux/brcm63xx/patches-3.1/455-board_ct536_ct5621.patch
@@ -50,7 +50,7 @@
static struct board_info __initdata board_96348gw = {
.name = "96348GW",
.expected_cpu_id = 0x6348,
-@@ -2026,6 +2069,7 @@ static const struct board_info __initdat
+@@ -2021,6 +2064,7 @@ static const struct board_info __initdat
&board_96348sv,
&board_V2500V_BB,
&board_V2110,
diff --git a/target/linux/brcm63xx/patches-3.1/456-board_DWV-S0_fixes.patch b/target/linux/brcm63xx/patches-3.1/456-board_DWV-S0_fixes.patch
index 9937d6739c..4c21d5d196 100644
--- a/target/linux/brcm63xx/patches-3.1/456-board_DWV-S0_fixes.patch
+++ b/target/linux/brcm63xx/patches-3.1/456-board_DWV-S0_fixes.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1332,6 +1332,8 @@ static struct board_info __initdata boar
+@@ -1327,6 +1327,8 @@ static struct board_info __initdata boar
.name = "DWV-S0",
.expected_cpu_id = 0x6358,
@@ -9,7 +9,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -1347,6 +1349,7 @@ static struct board_info __initdata boar
+@@ -1342,6 +1344,7 @@ static struct board_info __initdata boar
},
.has_ohci0 = 1,
diff --git a/target/linux/brcm63xx/patches-3.1/977-ssb_export_fallback_sprom.patch b/target/linux/brcm63xx/patches-3.1/977-ssb_export_fallback_sprom.patch
index 8f26d8bc0a..478019d99e 100644
--- a/target/linux/brcm63xx/patches-3.1/977-ssb_export_fallback_sprom.patch
+++ b/target/linux/brcm63xx/patches-3.1/977-ssb_export_fallback_sprom.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2113,7 +2113,7 @@ static void __init nb4_nvram_fixup(void)
+@@ -2108,7 +2108,7 @@ static void __init nb4_nvram_fixup(void)
* bcm4318 WLAN work
*/
#ifdef CONFIG_SSB_PCIHOST
@@ -9,7 +9,7 @@
.revision = 0x02,
.board_rev = 0x17,
.country_code = 0x0,
-@@ -2133,6 +2133,7 @@ static struct ssb_sprom bcm63xx_sprom =
+@@ -2128,6 +2128,7 @@ static struct ssb_sprom bcm63xx_sprom =
.boardflags_lo = 0x2848,
.boardflags_hi = 0x0000,
};
diff --git a/target/linux/generic/patches-3.1/020-ssb_update.patch b/target/linux/generic/patches-3.1/020-ssb_update.patch
index 9dc63adfa2..c67097b3e6 100644
--- a/target/linux/generic/patches-3.1/020-ssb_update.patch
+++ b/target/linux/generic/patches-3.1/020-ssb_update.patch
@@ -8,25 +8,6 @@
#include <linux/ssb/ssb.h>
#include "ssb_private.h"
---- a/drivers/ssb/driver_pcicore.c
-+++ b/drivers/ssb/driver_pcicore.c
-@@ -516,10 +516,14 @@ static void ssb_pcicore_pcie_setup_worka
-
- static void __devinit ssb_pcicore_init_clientmode(struct ssb_pcicore *pc)
- {
-- ssb_pcicore_fix_sprom_core_index(pc);
-+ struct ssb_device *pdev = pc->dev;
-+ struct ssb_bus *bus = pdev->bus;
-+
-+ if (bus->bustype == SSB_BUSTYPE_PCI)
-+ ssb_pcicore_fix_sprom_core_index(pc);
-
- /* Disable PCI interrupts. */
-- ssb_write32(pc->dev, SSB_INTVEC, 0);
-+ ssb_write32(pdev, SSB_INTVEC, 0);
-
- /* Additional PCIe always once-executed workarounds */
- if (pc->dev->id.coreid == SSB_DEV_PCIE) {
--- a/drivers/ssb/main.c
+++ b/drivers/ssb/main.c
@@ -12,6 +12,7 @@
diff --git a/target/linux/generic/patches-3.1/100-overlayfs_v11.patch b/target/linux/generic/patches-3.1/100-overlayfs_v11.patch
index 9870000d3b..f995a56030 100644
--- a/target/linux/generic/patches-3.1/100-overlayfs_v11.patch
+++ b/target/linux/generic/patches-3.1/100-overlayfs_v11.patch
@@ -254,7 +254,7 @@
rc = PTR_ERR(inode);
--- a/fs/namespace.c
+++ b/fs/namespace.c
-@@ -1495,6 +1495,23 @@ void drop_collected_mounts(struct vfsmou
+@@ -1492,6 +1492,23 @@ void drop_collected_mounts(struct vfsmou
release_mounts(&umount_list);
}
@@ -3154,7 +3154,7 @@
} ____cacheline_aligned;
struct seq_file;
-@@ -2022,6 +2034,7 @@ extern long do_sys_open(int dfd, const c
+@@ -2023,6 +2035,7 @@ extern long do_sys_open(int dfd, const c
extern struct file *filp_open(const char *, int, int);
extern struct file *file_open_root(struct dentry *, struct vfsmount *,
const char *, int);
diff --git a/target/linux/generic/patches-3.1/720-phy_adm6996.patch b/target/linux/generic/patches-3.1/720-phy_adm6996.patch
index 9e8e56678b..d4dbbb5c88 100644
--- a/target/linux/generic/patches-3.1/720-phy_adm6996.patch
+++ b/target/linux/generic/patches-3.1/720-phy_adm6996.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -98,6 +98,13 @@ config MICREL_PHY
+@@ -102,6 +102,13 @@ config MICREL_PHY
---help---
Supports the KSZ9021, VSC8201, KS8001 PHYs.
diff --git a/target/linux/generic/patches-3.1/722-phy_mvswitch.patch b/target/linux/generic/patches-3.1/722-phy_mvswitch.patch
index 2025b229a4..925cc4561f 100644
--- a/target/linux/generic/patches-3.1/722-phy_mvswitch.patch
+++ b/target/linux/generic/patches-3.1/722-phy_mvswitch.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -105,6 +105,9 @@ config ADM6996_PHY
+@@ -109,6 +109,9 @@ config ADM6996_PHY
Currently supports the ADM6996FC and ADM6996M switches.
Support for FC is very limited.
diff --git a/target/linux/generic/patches-3.1/723-phy_ip175c.patch b/target/linux/generic/patches-3.1/723-phy_ip175c.patch
index 9e13e579dd..0ac339e9a2 100644
--- a/target/linux/generic/patches-3.1/723-phy_ip175c.patch
+++ b/target/linux/generic/patches-3.1/723-phy_ip175c.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -108,6 +108,10 @@ config ADM6996_PHY
+@@ -112,6 +112,10 @@ config ADM6996_PHY
config MVSWITCH_PHY
tristate "Driver for Marvell 88E6060 switches"
diff --git a/target/linux/generic/patches-3.1/724-phy_ar8216.patch b/target/linux/generic/patches-3.1/724-phy_ar8216.patch
index a718e370f1..7a51dccee8 100644
--- a/target/linux/generic/patches-3.1/724-phy_ar8216.patch
+++ b/target/linux/generic/patches-3.1/724-phy_ar8216.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -112,6 +112,10 @@ config IP17XX_PHY
+@@ -116,6 +116,10 @@ config IP17XX_PHY
tristate "Driver for IC+ IP17xx switches"
select SWCONFIG
diff --git a/target/linux/generic/patches-3.1/725-phy_rtl8306.patch b/target/linux/generic/patches-3.1/725-phy_rtl8306.patch
index a6d188f2ce..42cd274ca7 100644
--- a/target/linux/generic/patches-3.1/725-phy_rtl8306.patch
+++ b/target/linux/generic/patches-3.1/725-phy_rtl8306.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -116,6 +116,10 @@ config AR8216_PHY
+@@ -120,6 +120,10 @@ config AR8216_PHY
tristate "Driver for Atheros AR8216 switches"
select SWCONFIG
diff --git a/target/linux/generic/patches-3.1/726-phy_rtl8366.patch b/target/linux/generic/patches-3.1/726-phy_rtl8366.patch
index badc0a4e62..080793d707 100644
--- a/target/linux/generic/patches-3.1/726-phy_rtl8366.patch
+++ b/target/linux/generic/patches-3.1/726-phy_rtl8366.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -158,4 +158,29 @@ config MDIO_OCTEON
+@@ -162,4 +162,29 @@ config MDIO_OCTEON
If in doubt, say Y.
diff --git a/target/linux/generic/patches-3.1/811-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-3.1/811-pci_disable_usb_common_quirks.patch
index 49a88ec7e2..34e9c6398c 100644
--- a/target/linux/generic/patches-3.1/811-pci_disable_usb_common_quirks.patch
+++ b/target/linux/generic/patches-3.1/811-pci_disable_usb_common_quirks.patch
@@ -1,7 +1,7 @@
--- a/drivers/usb/host/pci-quirks.c
+++ b/drivers/usb/host/pci-quirks.c
-@@ -429,6 +429,8 @@ reset_needed:
+@@ -430,6 +430,8 @@ reset_needed:
}
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
@@ -10,7 +10,7 @@
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{
u16 cmd;
-@@ -882,3 +884,5 @@ static void __devinit quirk_usb_early_ha
+@@ -876,3 +878,5 @@ static void __devinit quirk_usb_early_ha
quirk_usb_handoff_xhci(pdev);
}
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 75fef7eff9..dced25ffdd 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
FEATURES:=squashfs jffs2
DEFAULT_SUBTARGET:=danube
-LINUX_VERSION:=3.1.4
+LINUX_VERSION:=3.1.9
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
index e891b89cb6..087c707754 100644
--- a/target/linux/omap24xx/Makefile
+++ b/target/linux/omap24xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
MAINTAINER:=Michael Buesch <m@bues.ch>
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
-LINUX_VERSION:=3.1.4
+LINUX_VERSION:=3.1.9
define Target/Description
TI OMAP-24xx
diff --git a/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch b/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch
index 6da3478dcb..0c26af2ab1 100644
--- a/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch
+++ b/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
-@@ -1876,7 +1876,7 @@ config XIP_PHYS_ADDR
+@@ -1888,7 +1888,7 @@ config XIP_PHYS_ADDR
config KEXEC
bool "Kexec system call (EXPERIMENTAL)"
@@ -201,7 +201,7 @@
EXPORT_SYMBOL_GPL(arm_pm_restart);
static void do_nothing(void *unused)
-@@ -250,7 +274,15 @@ void machine_power_off(void)
+@@ -253,7 +277,15 @@ void machine_power_off(void)
void machine_restart(char *cmd)
{
machine_shutdown();
@@ -219,10 +219,10 @@
void __show_regs(struct pt_regs *regs)
--- a/arch/arm/kernel/setup.c
+++ b/arch/arm/kernel/setup.c
-@@ -890,8 +890,8 @@ void __init setup_arch(char **cmdline_p)
- machine_desc = mdesc;
- machine_name = mdesc->name;
-
+@@ -896,8 +896,8 @@ void __init setup_arch(char **cmdline_p)
+ arm_dma_zone_size = mdesc->dma_zone_size;
+ }
+ #endif
- if (mdesc->soft_reboot)
- reboot_setup("s");
+ if (mdesc->restart_mode)
@@ -230,7 +230,7 @@
init_mm.start_code = (unsigned long) _text;
init_mm.end_code = (unsigned long) _etext;
-@@ -910,6 +910,9 @@ void __init setup_arch(char **cmdline_p)
+@@ -916,6 +916,9 @@ void __init setup_arch(char **cmdline_p)
paging_init(mdesc);
request_standard_resources(mdesc);
diff --git a/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch b/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch
index c958989bf7..afdea788ee 100644
--- a/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch
+++ b/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch
@@ -79,7 +79,7 @@
hw_ep->fifo_async = musb->async + 0x400 + MUSB_FIFO_OFFSET(i);
hw_ep->fifo_sync = musb->sync + 0x400 + MUSB_FIFO_OFFSET(i);
hw_ep->fifo_sync_va =
-@@ -2376,8 +2376,13 @@ static struct platform_driver musb_drive
+@@ -2368,8 +2368,13 @@ static struct platform_driver musb_drive
/*-------------------------------------------------------------------------*/
@@ -93,7 +93,7 @@
if (usb_disabled())
return 0;
-@@ -2386,7 +2391,17 @@ static int __init musb_init(void)
+@@ -2378,7 +2383,17 @@ static int __init musb_init(void)
", "
"otg (peripheral+host)",
musb_driver_name);
@@ -112,7 +112,7 @@
}
/* make us init after usbcore and i2c (transceivers, regulators, etc)
-@@ -2397,5 +2412,6 @@ fs_initcall(musb_init);
+@@ -2389,5 +2404,6 @@ fs_initcall(musb_init);
static void __exit musb_cleanup(void)
{
platform_driver_unregister(&musb_driver);