summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-04 19:46:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-04 19:46:41 +0000
commitbd38281dbaa633c3dc3db36b9f012ec82b06fdf4 (patch)
treebdaf1d0c3467d28034ffbca123c173ba985feda2 /target/linux
parent3fa9ee3bfaf1e9047c44ef3438bf69be403df0cc (diff)
downloadmaster-31e0f0ae-bd38281dbaa633c3dc3db36b9f012ec82b06fdf4.tar.gz
master-31e0f0ae-bd38281dbaa633c3dc3db36b9f012ec82b06fdf4.tar.bz2
master-31e0f0ae-bd38281dbaa633c3dc3db36b9f012ec82b06fdf4.zip
add preliminary support for the Planex MZK-W300NH board
SVN-Revision: 13863
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/config-2.6.261
-rw-r--r--target/linux/ar71xx/config-2.6.271
-rw-r--r--target/linux/ar71xx/config-2.6.281
-rw-r--r--target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h2
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig4
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c80
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/prom.c3
-rw-r--r--target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h1
9 files changed, 93 insertions, 1 deletions
diff --git a/target/linux/ar71xx/config-2.6.26 b/target/linux/ar71xx/config-2.6.26
index 518f2975f3..a006dd998e 100644
--- a/target/linux/ar71xx/config-2.6.26
+++ b/target/linux/ar71xx/config-2.6.26
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W300NH=y
CONFIG_AR71XX_MACH_PB42=y
CONFIG_AR71XX_MACH_RB_4XX=y
CONFIG_AR71XX_MACH_TEW_632BRP=y
diff --git a/target/linux/ar71xx/config-2.6.27 b/target/linux/ar71xx/config-2.6.27
index 502f458ed6..337efdd10b 100644
--- a/target/linux/ar71xx/config-2.6.27
+++ b/target/linux/ar71xx/config-2.6.27
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W300NH=y
CONFIG_AR71XX_MACH_PB42=y
CONFIG_AR71XX_MACH_RB_4XX=y
CONFIG_AR71XX_MACH_TEW_632BRP=y
diff --git a/target/linux/ar71xx/config-2.6.28 b/target/linux/ar71xx/config-2.6.28
index 522f1c7e15..7b69cad738 100644
--- a/target/linux/ar71xx/config-2.6.28
+++ b/target/linux/ar71xx/config-2.6.28
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W300NH=y
CONFIG_AR71XX_MACH_PB42=y
CONFIG_AR71XX_MACH_RB_4XX=y
CONFIG_AR71XX_MACH_TEW_632BRP=y
diff --git a/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h b/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
index 09ffdfe07f..64f19bf62c 100644
--- a/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
+++ b/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
@@ -121,7 +121,7 @@ extern unsigned long ar71xx_mach_type;
#define AR71XX_MACH_UBNT_LSX 10 /* Ubiquiti LSX */
#define AR71XX_MACH_WNR2000 11 /* NETGEAR WNR2000 */
#define AR71XX_MACH_PB42 12 /* Atheros PB42 */
-
+#define AR71XX_MACH_MZK_W300NH 13 /* Planex MZK-W300NH */
/*
* PLL block
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
index d8e22470f4..cd2624cc66 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
@@ -35,6 +35,10 @@ config AR71XX_MACH_WNR2000
bool "NETGEAR WNR2000 board support"
default y
+config AR71XX_MACH_MZK_W300NH
+ bool "Planex MZK-W300NH board support"
+ default y
+
config AR71XX_MACH_TEW_632BRP
bool "TRENDnet TEW-632BRP support"
default y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
index b634e36d68..33118d7741 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
@@ -13,6 +13,7 @@ obj-y := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
obj-$(CONFIG_AR71XX_MACH_AP83) += mach-ap83.o
obj-$(CONFIG_AR71XX_MACH_AW_NR580) += mach-aw-nr580.o
obj-$(CONFIG_AR71XX_MACH_GENERIC) += mach-generic.o
+obj-$(CONFIG_AR71XX_MACH_MZK_W300NH) += mach-mzk-w300nh.o
obj-$(CONFIG_AR71XX_MACH_PB42) += mach-pb42.o
obj-$(CONFIG_AR71XX_MACH_RB_4XX) += mach-rb-4xx.o
obj-$(CONFIG_AR71XX_MACH_TEW_632BRP) += mach-tew-632brp.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c
new file mode 100644
index 0000000000..2f429be67f
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c
@@ -0,0 +1,80 @@
+/*
+ * Planex MZK-W300NH board support
+ *
+ * Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/platform.h>
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition mzk_w300nh_partitions[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = 0x040000,
+ .mask_flags = MTD_WRITEABLE,
+ } , {
+ .name = "u-boot-env",
+ .offset = 0x040000,
+ .size = 0x010000,
+ } , {
+ .name = "uImage",
+ .offset = 0x050000,
+ .size = 0x160000,
+ } , {
+ .name = "rootfs",
+ .offset = 0x1b0000,
+ .size = 0x610000,
+ } , {
+ .name = "config",
+ .offset = 0x7c0000,
+ .size = 0x020000,
+ } , {
+ .name = "art",
+ .offset = 0x7e0000,
+ .size = 0x020000,
+ .mask_flags = MTD_WRITEABLE,
+ }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data mzk_w300nh_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+ .parts = mzk_w300nh_partitions,
+ .nr_parts = ARRAY_SIZE(mzk_w300nh_partitions),
+#endif
+};
+
+static struct spi_board_info mzk_w300nh_spi_info[] = {
+ {
+ .bus_num = 0,
+ .chip_select = 0,
+ .max_speed_hz = 25000000,
+ .modalias = "m25p80",
+ .platform_data = &mzk_w300nh_flash_data,
+ }
+};
+
+static void __init mzk_w300nh_setup(void)
+{
+ ar71xx_add_device_spi(NULL, mzk_w300nh_spi_info,
+ ARRAY_SIZE(mzk_w300nh_spi_info));
+
+ ar91xx_add_device_wmac();
+}
+
+MIPS_MACHINE(AR71XX_MACH_MZK_W300NH, "Planex MZK-W300NH", mzk_w300nh_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c b/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
index bb6a112a23..d05217c615 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
@@ -64,6 +64,9 @@ static struct board_rec boards[] __initdata = {
}, {
.name = "PB42",
.mach_type = AR71XX_MACH_PB42,
+ }, {
+ .name = "MZK-W300NH",
+ .mach_type = AR71XX_MACH_MZK_W300NH,
}
};
diff --git a/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h b/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
index 3895b21e4c..64f19bf62c 100644
--- a/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
+++ b/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
@@ -121,6 +121,7 @@ extern unsigned long ar71xx_mach_type;
#define AR71XX_MACH_UBNT_LSX 10 /* Ubiquiti LSX */
#define AR71XX_MACH_WNR2000 11 /* NETGEAR WNR2000 */
#define AR71XX_MACH_PB42 12 /* Atheros PB42 */
+#define AR71XX_MACH_MZK_W300NH 13 /* Planex MZK-W300NH */
/*
* PLL block