summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-02-18 13:33:25 +0000
committerJohn Crispin <john@openwrt.org>2014-02-18 13:33:25 +0000
commitb56bef28d79c2cb3ffdc86d9b84b5aa16c649547 (patch)
treefe22a6b188e862633b40e51ea439e53013347d70 /target/linux
parent55383946dc2b17b7bedb5f435b17d0d3e1c5323c (diff)
downloadmaster-31e0f0ae-b56bef28d79c2cb3ffdc86d9b84b5aa16c649547.tar.gz
master-31e0f0ae-b56bef28d79c2cb3ffdc86d9b84b5aa16c649547.tar.bz2
master-31e0f0ae-b56bef28d79c2cb3ffdc86d9b84b5aa16c649547.zip
ralink: add support for na930
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 39611
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh5
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/01_leds3
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rw-r--r--target/linux/ramips/dts/NA930.dts164
-rw-r--r--target/linux/ramips/image/Makefile3
-rw-r--r--target/linux/ramips/mt7620a/config-3.103
7 files changed, 181 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index d57cc7ac22..4168d0a2bd 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -160,7 +160,10 @@ get_status_led() {
;;
f7c027)
status_led="belkin:orange:status"
- ;;
+ ;;
+ na930)
+ status_led="na930:blue:power"
+ ;;
esac
}
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/01_leds b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
index ca4c131781..567835e6b1 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
@@ -115,6 +115,9 @@ case $board in
mzk-w300nh2)
set_wifi_led "mzkw300nh2:amber:wlan"
;;
+ na930)
+ set_usb_led "na930:blue:status"
+ ;;
nw718)
set_usb_led "nw718:amber:usb"
;;
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/02_network b/target/linux/ramips/base-files/etc/uci-defaults/02_network
index 65c05899c3..703471838d 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/02_network
@@ -146,6 +146,7 @@ ramips_setup_interfaces()
;;
d105 | \
+ na930 | \
omni-emb-hpm|\
wli-tx4-ag300n)
ucidef_set_interface_lan "eth0"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 7aa331334e..5a686e6719 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -280,6 +280,9 @@ ramips_board_detect() {
*"V22SG")
name="v22sg"
;;
+ *"Sercomm NA930")
+ name="na930"
+ ;;
*)
name="generic"
;;
diff --git a/target/linux/ramips/dts/NA930.dts b/target/linux/ramips/dts/NA930.dts
new file mode 100644
index 0000000000..6fe9964da9
--- /dev/null
+++ b/target/linux/ramips/dts/NA930.dts
@@ -0,0 +1,164 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+ compatible = "ralink,mt7620a-eval-board", "ralink,mt7620a-soc";
+ model = "Sercomm NA930";
+
+ chosen {
+ bootargs = "console=ttyS1,57600";
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "rgmii2", "spi", "ephy";
+ ralink,function = "gpio";
+ };
+ uartf_gpio {
+ ralink,group = "uartf";
+ ralink,function = "gpio uartf";
+ };
+ };
+ };
+
+ palmbus@10000000 {
+ uart@500 {
+ status = "okay";
+ };
+
+ gpio@638 {
+ status = "okay";
+ };
+
+ gpio@660 {
+ status = "okay";
+ };
+ };
+
+ nand {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mtk,mt7620-nand";
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+ partition@200000 {
+ label = "factory";
+ reg = <0x200000 0x40000>;
+ read-only;
+ };
+ partition@240000 {
+ label = "Config";
+ reg = <0x240000 0x400000>;
+ read-only;
+ };
+ partition@640000 {
+ label = "firmware";
+ reg = <0x640000 0x1400000>;
+ };
+ };
+
+ ethernet@10100000 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&rgmii1_pins &mdio_pins>;
+
+ ralink,port-map = "llllw";
+
+ port@4 {
+ status = "okay";
+ phy-handle = <&phy4>;
+ phy-mode = "rgmii";
+ };
+
+ port@5 {
+ status = "okay";
+ phy-handle = <&phy5>;
+ phy-mode = "rgmii";
+ };
+
+ mdio-bus {
+ status = "okay";
+
+ phy4: ethernet-phy@4 {
+ reg = <4>;
+ phy-mode = "rgmii";
+ };
+
+ phy5: ethernet-phy@5 {
+ reg = <5>;
+ phy-mode = "rgmii";
+ };
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset {
+ label = "reset";
+ gpios = <&gpio0 11 1>;
+ linux,code = <0x198>;
+ };
+ zwave {
+ label = "zwave";
+ gpios = <&gpio0 12 1>;
+ linux,code = <0x100>;
+ };
+ wps {
+ label = "wps";
+ gpios = <&gpio0 14 1>;
+ linux,code = <0x211>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ zwave {
+ label = "na930:blue:zwave";
+ gpios = <&gpio2 0 1>;
+ };
+ status {
+ label = "na930:blue:status";
+ gpios = <&gpio2 26 1>;
+ };
+ service {
+ label = "na930:blue:service";
+ gpios = <&gpio2 28 1>;
+ };
+ power {
+ label = "na930:blue:power";
+ gpios = <&gpio2 29 1>;
+ };
+ };
+
+ gpio_export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ telit {
+ gpio-export,name = "telit";
+ gpio-export,output = <1>;
+ gpios = <&gpio0 13 0>;
+ };
+ };
+
+ gsw@10110000 {
+ ralink,port4 = "gmac";
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 8fb0107ebd..ae95b68655 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -666,6 +666,8 @@ Image/Build/Profile/WHR300HP2=$(call BuildFirmware/CustomFlash/$(1),$(1),whr-300
Image/Build/Profile/WHR600D=$(call BuildFirmware/CustomFlash/$(1),$(1),whr-600d,WHR-600D,$(whr_300hp2_mtd_size))
dlink810l_mtd_size=6881280
Image/Build/Profile/DIR-810L=$(call BuildFirmware/CustomFlash/$(1),$(1),dir-810l,DIR-810L,$(dlink810l_mtd_size))
+na930_mtd_size=20971520
+Image/Build/Profile/NA930=$(call BuildFirmware/CustomFlash/$(1),$(1),na930,NA930,$(na930_mtd_size))
ifeq ($(SUBTARGET),mt7620a)
define Image/Build/Profile/Default
@@ -677,6 +679,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/DIR-810L,$(1))
$(call Image/Build/Profile/WHR300HP2,$(1))
$(call Image/Build/Profile/WHR600D,$(1))
+ $(call Image/Build/Profile/NA930,$(1))
endef
endif
diff --git a/target/linux/ramips/mt7620a/config-3.10 b/target/linux/ramips/mt7620a/config-3.10
index 1320574b97..6805dd9efa 100644
--- a/target/linux/ramips/mt7620a/config-3.10
+++ b/target/linux/ramips/mt7620a/config-3.10
@@ -6,6 +6,7 @@ CONFIG_ARCH_HIBERNATION_POSSIBLE=y
CONFIG_ARCH_REQUIRE_GPIOLIB=y
CONFIG_ARCH_SUSPEND_POSSIBLE=y
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
+CONFIG_AT803X_PHY=y
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_CEVT_R4K=y
CONFIG_CLKDEV_LOOKUP=y
@@ -78,11 +79,13 @@ CONFIG_HW_HAS_PCI=y
CONFIG_HW_RANDOM=m
CONFIG_HZ_PERIODIC=y
CONFIG_IMAGE_CMDLINE_HACK=y
+CONFIG_INET_LRO=y
CONFIG_INITRAMFS_SOURCE=""
CONFIG_IRQCHIP=y
CONFIG_IRQ_CPU=y
CONFIG_IRQ_DOMAIN=y
CONFIG_IRQ_FORCED_THREADING=y
+CONFIG_IRQ_INTC=y
CONFIG_IRQ_WORK=y
CONFIG_M25PXX_USE_FAST_READ=y
CONFIG_MDIO_BOARDINFO=y