summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-11-24 14:44:12 +0000
committerJonas Gorski <jogo@openwrt.org>2014-11-24 14:44:12 +0000
commitb3ce1c4ea67bdf3180075905b8cce6325448f0f6 (patch)
treef2244c4ec21e57b2d49b54097ab4287387124a6f /target/linux
parentc26c5eff0ea43f9645fdb50b8dfd5f1fe4fb6640 (diff)
downloadmaster-31e0f0ae-b3ce1c4ea67bdf3180075905b8cce6325448f0f6.tar.gz
master-31e0f0ae-b3ce1c4ea67bdf3180075905b8cce6325448f0f6.tar.bz2
master-31e0f0ae-b3ce1c4ea67bdf3180075905b8cce6325448f0f6.zip
brcm63xx: Add DT support for AGPF-S0
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43358
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm63xx/dts/agpf-s0.dts30
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile5
-rw-r--r--target/linux/brcm63xx/profiles/pirelli.mk16
3 files changed, 48 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/dts/agpf-s0.dts b/target/linux/brcm63xx/dts/agpf-s0.dts
new file mode 100644
index 0000000000..9d66b8901b
--- /dev/null
+++ b/target/linux/brcm63xx/dts/agpf-s0.dts
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+ model = "Pirelli Alice Gate AGPF-S0";
+ compatible = "pirelli,agpf-s0", "brcm,bcm6358";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ linux@20000 {
+ label = "linux";
+ reg = <0x020000 0xfc0000>;
+ };
+
+ nvram@fe0000 {
+ label = "nvram";
+ reg = <0xfe0000 0x020000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index b7789cf368..2b57fcd985 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -288,9 +288,6 @@ define Image/Build
$(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2,OpenWRT-$(REVISION))
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
- # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
- $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,AGV2+W-cfe)
- $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,AGV2+W)
# Pirelli A226G
$(call Image/Build/CFEAGPF,$(1),DWV-S0,6358,0x10000,A226G-cfe)
$(call Image/Build/CFEAGPF,$(1),DWV-S0,6358,0x10000,A226G)
@@ -388,6 +385,8 @@ $(eval $(call CfeImageDTB,HG553,hg553,HW553,6358,HG553,EchoLife_HG553,--image-of
$(eval $(call CfeImageDTB,HG556a_AB,hg556a-a,HW556,6358,HG556a_A,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x10000 --tag-version 8))
$(eval $(call CfeImageDTB,HG556a_AB,hg556a-b,HW556,6358,HG556a_B,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x20000 --tag-version 8))
$(eval $(call CfeImageDTB,HG556a_C,hg556a-c,HW556,6358,HG556a_C,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x20000 --tag-version 8))
+# Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
+$(eval $(call CfeImageDTB,AGPF_S0,agpf-s0,AGPF-S0,6358,AGV2+W,,--block-size 0x20000 --image-offset 0x20000 --signature2 IMAGE --tag-version 8))
# T-Com Speedport W 500V
$(eval $(call CfeImageDTB,SPW500V,spw500v,96348GW,6348,SPW500V))
# Tecom GW6000
diff --git a/target/linux/brcm63xx/profiles/pirelli.mk b/target/linux/brcm63xx/profiles/pirelli.mk
new file mode 100644
index 0000000000..c06852eaf2
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/pirelli.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/AGPF_S0
+ NAME:=Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
+ PACKAGES:=kmod-b43 wpad-mini\
+ kmod-usb2 kmod-usb-ohci
+endef
+define Profile/AGPF_S0/Description
+ Package set optimized for AGPF-S0.
+endef
+$(eval $(call Profile,AGPF_S0))