summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-07 11:40:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-07 11:40:45 +0000
commitabad211388a0b33c488ae93e7ef6b690d8ca4813 (patch)
treeec266c9782721d54d25ead2df72e941076b7cf02 /target/linux
parentf346e316b49d83e3583ccb2790629e1609a2c079 (diff)
downloadmaster-31e0f0ae-abad211388a0b33c488ae93e7ef6b690d8ca4813.tar.gz
master-31e0f0ae-abad211388a0b33c488ae93e7ef6b690d8ca4813.tar.bz2
master-31e0f0ae-abad211388a0b33c488ae93e7ef6b690d8ca4813.zip
ar71xx: use the lzma loader for the WRT160NL
Partition layout before: 0x000000040000-0x0000001a0000 : "kernel" 0x0000001a0000-0x0000007e0000 : "rootfs" mtd: partition "rootfs" set to be root filesystem mtd: partition "rootfs_data" created automatically, ofs=0x350000, len=0x490000 0x000000350000-0x0000007e0000 : "rootfs_data" after: 0x000000040000-0x000000140000 : "kernel" 0x000000140000-0x0000007e0000 : "rootfs" mtd: partition "rootfs" set to be root filesystem mtd: partition "rootfs_data" created automatically, ofs=0x2f0000, len=0x4f0000 0x0000002f0000-0x0000007e0000 : "rootfs_data" Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37915
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ac9c8b87e9..98f364dc0b 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -618,8 +618,8 @@ define Image/Build/TPLINK-LZMA/initramfs
-o $(call imgname,$(1),$(2))-uImage.bin
endef
-
-Image/Build/CyberTAN/buildkernel=$(call MkuImageGzip,$(2),$(3))
+Image/Build/CyberTAN/loader=$(call Image/BuildLoader,$(1),gz,$(2),0x80060000)
+Image/Build/CyberTAN/buildkernel=$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
define Image/Build/CyberTAN
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \