summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-05-12 01:41:22 +0200
committerJohn Crispin <john@phrozen.org>2016-05-12 03:29:36 +0200
commit825717d45082dbf7950f271a0889689e28bac54f (patch)
tree0c1d6e4638c069dc2c0397ca82ed66813f59ca21 /target/linux
parenta55f0c32fa84db8ccd34f81738297de9d51cdea3 (diff)
downloadmaster-31e0f0ae-825717d45082dbf7950f271a0889689e28bac54f.tar.gz
master-31e0f0ae-825717d45082dbf7950f271a0889689e28bac54f.tar.bz2
master-31e0f0ae-825717d45082dbf7950f271a0889689e28bac54f.zip
ramips: convert mt7621 to new image building code
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt7621.mk27
-rw-r--r--target/linux/ramips/mt7621/profiles/firefly.mk18
-rw-r--r--target/linux/ramips/mt7621/profiles/linksys.mk15
-rw-r--r--target/linux/ramips/mt7621/profiles/misc.mk20
-rw-r--r--target/linux/ramips/mt7621/profiles/mqmaker.mk20
-rw-r--r--target/linux/ramips/mt7621/profiles/netgear.mk17
-rw-r--r--target/linux/ramips/mt7621/profiles/netis.mk23
-rw-r--r--target/linux/ramips/mt7621/profiles/samknows.mk18
-rw-r--r--target/linux/ramips/mt7621/profiles/storylink.mk18
-rw-r--r--target/linux/ramips/mt7621/profiles/ubnt.mk18
-rw-r--r--target/linux/ramips/mt7621/profiles/zbt.mk31
-rw-r--r--target/linux/ramips/mt7621/target.mk2
12 files changed, 28 insertions, 199 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a09f4abfbf..31752446ac 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -36,17 +36,20 @@ endef
define Device/mt7621
DTS := MT7621
IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_TITLE := MediaTek MT7621 EVB
endef
TARGET_DEVICES += mt7621
define Device/wsr-600
DTS := WSR-600
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := Buffalo WSR-600
endef
TARGET_DEVICES += wsr-600
define Device/re6500
DTS := RE6500
+ DEVICE_TITLE := Linksys RE6500
endef
TARGET_DEVICES += re6500
@@ -54,6 +57,7 @@ define Device/wsr-1166
DTS := WSR-1166
IMAGE/sysupgrade.bin := trx | pad-rootfs
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := Buffalo WSR-1166
endef
TARGET_DEVICES += wsr-1166
@@ -71,47 +75,64 @@ define Device/dir-860l-b1
seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
seama-seal -m "signature=wrgac13_dlink.2013gui_dir860lb" | \
check-size $$$$(IMAGE_SIZE)
+ DEVICE_TITLE := D-Link DIR-860L B1
endef
TARGET_DEVICES += dir-860l-b1
define Device/firewrt
DTS := FIREWRT
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := Firefly FireWRT
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev
endef
TARGET_DEVICES += firewrt
define Device/pbr-m1
DTS := PBR-M1
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := PBR-M1
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+ kmod-rtc-pcf8563 kmod-i2c-mt7621
endef
TARGET_DEVICES += pbr-m1
define Device/sap-g3200u3
DTS := SAP-G3200U3
+ DEVICE_TITLE := STORYLiNK SAP-G3200U3
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev
endef
TARGET_DEVICES += sap-g3200u3
define Device/witi
DTS := WITI
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := MQmaker WiTi
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+ kmod-rtc-pcf8563 kmod-i2c-mt7621
endef
TARGET_DEVICES += witi
define Device/wndr3700v5
DTS := WNDR3700V5
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := Netgear WNDR3700v5
+ DEVICE_PACKAGES := kmod-usb3
endef
TARGET_DEVICES += wndr3700v5
define Device/zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := ZBT WG2626
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci
endef
TARGET_DEVICES += zbt-wg2626
define Device/zbt-wg3526
DTS := ZBT-WG3526
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := ZBT WG3526
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci
endef
TARGET_DEVICES += zbt-wg3526
@@ -123,6 +144,8 @@ define Device/wf-2881
IMAGE_SIZE := 132382720
KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
+ DEVICE_TITLE := NETIS WF-2881
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev
endef
TARGET_DEVICES += wf-2881
@@ -135,12 +158,16 @@ define Device/ubnt-erx
KERNEL_INITRAMFS := $$(KERNEL) | check-size $$(KERNEL_SIZE) | \
ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
IMAGE/sysupgrade.tar := sysupgrade-nand
+ DEVICE_TITLE := Ubiquiti EdgeRouter X
+ DEVICE_PACKAGES := -kmod-mt76 -kmod-rt2800-pci -kmod-cfg80211 -wpad-mini -iwinfo
endef
TARGET_DEVICES += ubnt-erx
define Device/sk-wb8
DTS := SK-WB8
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := SamKnows Whitebox 8
+ DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev uboot-envtools
endef
TARGET_DEVICES += sk-wb8
diff --git a/target/linux/ramips/mt7621/profiles/firefly.mk b/target/linux/ramips/mt7621/profiles/firefly.mk
deleted file mode 100644
index 979752780b..0000000000
--- a/target/linux/ramips/mt7621/profiles/firefly.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/FIREWRT
- NAME:=Firefly FireWRT
- PACKAGES:=\
- kmod-usb-core kmod-usb3 kmod-usb-hid \
- kmod-ledtrig-usbdev
-endef
-
-define Profile/FIREWRT/Description
- Package set compatible with the Firefly FireWRT board.
-endef
-$(eval $(call Profile,FIREWRT))
diff --git a/target/linux/ramips/mt7621/profiles/linksys.mk b/target/linux/ramips/mt7621/profiles/linksys.mk
deleted file mode 100644
index fb447c9e05..0000000000
--- a/target/linux/ramips/mt7621/profiles/linksys.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RE6500
- NAME:=Linksys RE6500
-endef
-
-define Profile/RE6500/Description
- Package set compatible with the Linksys RE6500 board.
-endef
-$(eval $(call Profile,RE6500))
diff --git a/target/linux/ramips/mt7621/profiles/misc.mk b/target/linux/ramips/mt7621/profiles/misc.mk
deleted file mode 100644
index 06a9d44c88..0000000000
--- a/target/linux/ramips/mt7621/profiles/misc.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/PBR-M1
- NAME:=PBR-M1 Device
- FEATURES+=rtc
- PACKAGES:=\
- kmod-usb-core kmod-usb3 kmod-usb-hid \
- kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
- kmod-rtc-pcf8563
-endef
-
-define Profile/PBR-M1/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,PBR-M1))
diff --git a/target/linux/ramips/mt7621/profiles/mqmaker.mk b/target/linux/ramips/mt7621/profiles/mqmaker.mk
deleted file mode 100644
index 0b01ab9122..0000000000
--- a/target/linux/ramips/mt7621/profiles/mqmaker.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WITI
- NAME:=MQmaker WiTi
- FEATURES+=rtc
- PACKAGES:=\
- kmod-usb-core kmod-usb3 kmod-usb-hid \
- kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
- kmod-rtc-pcf8563 kmod-i2c-mt7621
-endef
-
-define Profile/WITI/Description
- Package set compatible with MQmaker WiTi board.
-endef
-$(eval $(call Profile,WITI))
diff --git a/target/linux/ramips/mt7621/profiles/netgear.mk b/target/linux/ramips/mt7621/profiles/netgear.mk
deleted file mode 100644
index 05802a252f..0000000000
--- a/target/linux/ramips/mt7621/profiles/netgear.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WNDR3700V5
- NAME:=Netgear WNDR3700v5
- PACKAGES:=\
- kmod-usb-core kmod-usb3
-endef
-
-define Profile/WNDR3700V5/Description
- Package set compatible with the Netgear WNDR3700v5.
-endef
-$(eval $(call Profile,WNDR3700V5))
diff --git a/target/linux/ramips/mt7621/profiles/netis.mk b/target/linux/ramips/mt7621/profiles/netis.mk
deleted file mode 100644
index 39b524f534..0000000000
--- a/target/linux/ramips/mt7621/profiles/netis.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WF-2881
- NAME:=NETIS WF-2881
- PACKAGES:=\
- kmod-usb-core kmod-usb3 kmod-usb-hid \
- kmod-ledtrig-usbdev
-endef
-
-define Profile/WF-2881/Description
- Package set compatible with the NETIS WF-2881 board.
-endef
-
-#-m <min io size> -e <LEB size> -c <Eraseblocks count>
-WF-2881_UBIFS_OPTS:="-m 2048 -e 129024 -c 1024"
-WF-2881_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
-$(eval $(call Profile,WF-2881))
diff --git a/target/linux/ramips/mt7621/profiles/samknows.mk b/target/linux/ramips/mt7621/profiles/samknows.mk
deleted file mode 100644
index aa2e45e4d1..0000000000
--- a/target/linux/ramips/mt7621/profiles/samknows.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/SK-WB8
- NAME:=SamKnows Whitebox 8
- PACKAGES:=\
- kmod-usb-core kmod-usb3 \
- kmod-ledtrig-usbdev uboot-envtools
-endef
-
-define Profile/SK-WB8/Description
- Package set compatible with the SamKnows Whitebox 8.
-endef
-$(eval $(call Profile,SK-WB8))
diff --git a/target/linux/ramips/mt7621/profiles/storylink.mk b/target/linux/ramips/mt7621/profiles/storylink.mk
deleted file mode 100644
index 9ca4a2f743..0000000000
--- a/target/linux/ramips/mt7621/profiles/storylink.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/SAP-G3200U3
- NAME:=STORYLiNK SAP-G3200U3
- PACKAGES:=\
- kmod-usb-core kmod-usb3 kmod-usb-hid \
- kmod-ledtrig-usbdev
-endef
-
-define Profile/SAP-G3200U3/Description
- Package set compatible with the STORYLiNK SAP-G3200U3 board.
-endef
-$(eval $(call Profile,SAP-G3200U3))
diff --git a/target/linux/ramips/mt7621/profiles/ubnt.mk b/target/linux/ramips/mt7621/profiles/ubnt.mk
deleted file mode 100644
index 3f1af02c57..0000000000
--- a/target/linux/ramips/mt7621/profiles/ubnt.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/UBNT-ERX
- NAME:=Ubiquiti EdgeRouter X
- FEATURES+=nand -usb
- PACKAGES:=-kmod-mt76 -kmod-rt2800-pci -kmod-cfg80211 \
- -wpad-mini -iwinfo
-endef
-
-define Profile/UBNT-ERX/Description
- Package set compatible with the Ubiquiti EdgeRouter X
-endef
-$(eval $(call Profile,UBNT-ERX))
diff --git a/target/linux/ramips/mt7621/profiles/zbt.mk b/target/linux/ramips/mt7621/profiles/zbt.mk
deleted file mode 100644
index 453687d4c5..0000000000
--- a/target/linux/ramips/mt7621/profiles/zbt.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/ZBT-WG2626
- NAME:=ZBT-WG2626 Device
- PACKAGES:=\
- kmod-usb-core kmod-usb3 \
- kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci
-endef
-
-define Profile/ZBT-WG2626/Description
- Package set for ZBT-WG2626 device
-endef
-$(eval $(call Profile,ZBT-WG2626))
-
-
-define Profile/ZBT-WG3526
- NAME:=ZBT-WG3526 Device
- PACKAGES:=\
- kmod-usb-core kmod-usb3 \
- kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci
-endef
-
-define Profile/ZBT-WG3526/Description
- Package set for ZBT-WG3526 device
-endef
-$(eval $(call Profile,ZBT-WG3526))
diff --git a/target/linux/ramips/mt7621/target.mk b/target/linux/ramips/mt7621/target.mk
index e38fad4b25..c1c39a1018 100644
--- a/target/linux/ramips/mt7621/target.mk
+++ b/target/linux/ramips/mt7621/target.mk
@@ -4,7 +4,7 @@
SUBTARGET:=mt7621
BOARDNAME:=MT7621 based boards
-FEATURES+=usb
+FEATURES+=usb rtc
CPU_TYPE:=1004kc
CPU_SUBTYPE:=dsp
CFLAGS:=-Os -pipe -mmt -mips32r2 -mtune=1004kc