summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-13 14:48:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-13 14:48:03 +0000
commit62c8ff19ad57b42df2cdc160b9ca37fbf86dd53a (patch)
treefa7a0b1190d60a2b40db497e8de3d70eff7da5d4 /target/linux
parent588c81d1e0ff0d3ff1659c54addddf211152904a (diff)
downloadmaster-31e0f0ae-62c8ff19ad57b42df2cdc160b9ca37fbf86dd53a.tar.gz
master-31e0f0ae-62c8ff19ad57b42df2cdc160b9ca37fbf86dd53a.tar.bz2
master-31e0f0ae-62c8ff19ad57b42df2cdc160b9ca37fbf86dd53a.zip
ar71xx: add profile and build image for the TL-WA7510N board
[juhosg: separated from the http://patchwork.openwrt.org/patch/2820/ patch] Signed-off-by: Stefan Helmert <helst_listen@aol.de> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34190
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk10
-rw-r--r--target/linux/ar71xx/image/Makefile2
2 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 056a91703d..07d7059a8c 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -82,6 +82,16 @@ define Profile/TLWA701/Description
endef
$(eval $(call Profile,TLWA701))
+define Profile/TLWA7510
+ NAME:=TP-LINK TL-WA7510N
+ PACKAGES:=
+endef
+
+define Profile/TLWA7510/Description
+ Package set optimized for the TP-LINK TL-WA7510N.
+endef
+$(eval $(call Profile,TLWA7510))
+
define Profile/TLWA901
NAME:=TP-LINK TL-WA901N/ND
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 1d67317c7d..3992ae8ddc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -803,6 +803,7 @@ $(eval $(call SingleProfile,TPLINKOLD,$(fs_squash),TLWR841NV15,tl-wr841nd-v1.5,T
$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLMR3220,tl-mr3220-v1,TL-MR3220,ttyS0,115200,0x32200001,1,4M))
$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLMR3420,tl-mr3420-v1,TL-MR3420,ttyS0,115200,0x34200001,1,4M))
$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA701,tl-wa701n-v1,TL-WA901ND,ttyS0,115200,0x07010001,1,4M))
+$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA7510NV1,tl-wa7510n,TL-WA7510N,ttyS0,115200,0x75100001,1,4M))
$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA901NV1,tl-wa901nd-v1,TL-WA901ND,ttyS0,115200,0x09010001,1,4M))
$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA901NV2,tl-wa901nd-v2,TL-WA901ND-v2,ttyS0,115200,0x09010002,1,4M))
$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWR740NV1,tl-wr740n-v1,TL-WR741ND,ttyS0,115200,0x07400001,1,4M))
@@ -865,6 +866,7 @@ $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
$(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT))
$(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
$(eval $(call MultiProfile,TLWA901,TLWA901NV1 TLWA901NV2))
+$(eval $(call MultiProfile,TLWA7510,TLWA7510NV1))
$(eval $(call MultiProfile,TLWR740,TLWR740NV1 TLWR740NV3 TLWR740NV4))
$(eval $(call MultiProfile,TLWR741,TLWR741NV1 TLWR741NV2 TLWR741NV4))
$(eval $(call MultiProfile,TLWR841,TLWR841NV15 TLWR841NV3 TLWR841NV5 TLWR841NV7 TLWR841NV8))