summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-06 19:37:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-06 19:37:49 +0000
commit624505df567ada22374f8414df17f867cf8cd77f (patch)
tree4783470b90622d8262989b6fcd1454975f1247a4 /target/linux
parent8b46a72583c072a809149f05e8bdc3dd5c6e0d47 (diff)
downloadmaster-31e0f0ae-624505df567ada22374f8414df17f867cf8cd77f.tar.gz
master-31e0f0ae-624505df567ada22374f8414df17f867cf8cd77f.tar.bz2
master-31e0f0ae-624505df567ada22374f8414df17f867cf8cd77f.zip
ar71xx: fix LZMA loader build regression from r32090 (thx, juhosg)
SVN-Revision: 32095
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 6b45b551bf..8eed67dc06 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1146,7 +1146,7 @@ endef
define Image/Prepare
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
- $(if $(CONFIG_IB),$(call Image/Build/Profile/Default,loader))
+ $(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(PROFILE)),loader)
endef
define Image/Build