summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-28 10:56:30 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-28 10:56:30 +0000
commit437e1844849ab385f5ab4cbaa0dc819bc3fba201 (patch)
treefc59c868b1d8fd4233ba6e65839fe8a6cd0693a9 /target/linux
parent7193f29d96ab94cf804675b9e1d94e4e841dfddc (diff)
downloadmaster-31e0f0ae-437e1844849ab385f5ab4cbaa0dc819bc3fba201.tar.gz
master-31e0f0ae-437e1844849ab385f5ab4cbaa0dc819bc3fba201.tar.bz2
master-31e0f0ae-437e1844849ab385f5ab4cbaa0dc819bc3fba201.zip
ramips: rt305x: add support for the Asus RT-G32 B1 board
Based on a patch by: Sergiy <piratfm@gmail.com> SVN-Revision: 27812
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom4
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-g32-revb.c115
-rw-r--r--target/linux/ramips/image/Makefile12
-rw-r--r--target/linux/ramips/rt305x/config-2.6.391
9 files changed, 143 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index 03ff4f81d4..ee20b54ef2 100644
--- a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -37,6 +37,10 @@ case "$FIRMWARE" in
rt2x00_eeprom_extract "devdata" 16384 272
;;
+ rt-g32-b1)
+ rt2x00_eeprom_extract "devconf" 0 272
+ ;;
+
f5d8235v2 | \
fonera20n | \
hw550-3g | \
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index f34454b6d8..d081b8be67 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -34,6 +34,9 @@ ramips_board_name() {
*"PWH2004")
name="pwh2004"
;;
+ *"RT-G32 B1")
+ name="rt-g32-b1"
+ ;;
*"RT-N15")
name="rt-n15"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 0dd3b7bd23..e7511e849b 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -14,7 +14,7 @@ platform_check_image() {
[ "$ARGC" -gt 1 ] && return 1
case "$board" in
- dir-300-b1 | dir-600-b1 | dir-600-b2 | fonera20n | v22rw-2x2 | whr-g300n | hw550-3g | mofi3500-3gn)
+ dir-300-b1 | dir-600-b1 | dir-600-b2 | fonera20n | rt-g32-b1 | v22rw-2x2 | whr-g300n | hw550-3g | mofi3500-3gn)
[ "$magic" != "2705" ] && {
echo "Invalid image type."
return 1
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index b9f8a602ee..3f410716d5 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -21,6 +21,7 @@ enum ramips_mach_type {
RAMIPS_MACH_DIR_300_B1, /* D-Link DIR-300 B1 */
RAMIPS_MACH_DIR_600_B1, /* D-Link DIR-600 B1 */
RAMIPS_MACH_DIR_600_B2, /* D-Link DIR-600 B2 */
+ RAMIPS_MACH_RT_G32_B1, /* Asus RT-G32 B1 */
/* RT3052 based machines */
RAMIPS_MACH_F5D8235_V2, /* Belkin F5D8235 v2 */
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index 18ea3502ed..a12693ce11 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -2,6 +2,11 @@ if RALINK_RT305X
menu "Ralink RT350x machine selection"
+config RT305X_MACH_RT_G32_REVB
+ bool "Asus RT-G32 revB board support"
+ default y
+ select RALINK_DEV_GPIO_BUTTONS
+
config RT305X_MACH_HW550_3G
bool "Aztech HW550-3G support"
default y
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index f0aae4f3b3..5460a148ba 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -17,6 +17,7 @@ obj-$(CONFIG_RT305X_MACH_FONERA20N) += mach-fonera20n.o
obj-$(CONFIG_RT305X_MACH_HW550_3G) += mach-hw550-3g.o
obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
obj-$(CONFIG_RT305X_MACH_PWH2004) += mach-pwh2004.o
+obj-$(CONFIG_RT305X_MACH_RT_G32_REVB) += mach-rt-g32-revb.o
obj-$(CONFIG_RT305X_MACH_V22RW_2X2) += mach-v22rw-2x2.o
obj-$(CONFIG_RT305X_MACH_WCR150GN) += mach-wcr150gn.o
obj-$(CONFIG_RT305X_MACH_WHR_G300N) += mach-whr-g300n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-g32-revb.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-g32-revb.c
new file mode 100644
index 0000000000..8273c5ae3b
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-g32-revb.c
@@ -0,0 +1,115 @@
+/*
+ * Asus RT-G32 rev B board support
+ *
+ * Copyright (C) 2011 Sergiy <piratfm@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define RT_G32B_GPIO_BUTTON_WPS 0 /* active low */
+#define RT_G32B_GPIO_BUTTON_RESET 10 /* active low */
+
+#define RT_G32B_BUTTONS_POLL_INTERVAL 20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition rt_g32b_partitions[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = 0x030000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "devdata",
+ .offset = 0x030000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "devconf",
+ .offset = 0x040000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "kernel",
+ .offset = 0x050000,
+ .size = 0x0d0000,
+ }, {
+ .name = "rootfs",
+ .offset = 0x120000,
+ .size = 0x2e0000,
+ }, {
+ .name = "firmware",
+ .offset = 0x050000,
+ .size = 0x3b0000,
+ }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+const struct flash_platform_data rt_g32b_flash = {
+ .type = "mx25l3205d",
+#ifdef CONFIG_MTD_PARTITIONS
+ .parts = rt_g32b_partitions,
+ .nr_parts = ARRAY_SIZE(rt_g32b_partitions),
+#endif
+};
+
+struct spi_board_info __initdata rt_g32b_spi_slave_info[] = {
+ {
+ .modalias = "m25p80",
+ .platform_data = &rt_g32b_flash,
+ .irq = -1,
+ .max_speed_hz = 10000000,
+ .bus_num = 0,
+ .chip_select = 0,
+ },
+};
+
+static struct gpio_button rt_g32b_gpio_buttons[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .threshold = 3,
+ .gpio = RT_G32B_GPIO_BUTTON_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .threshold = 3,
+ .gpio = RT_G32B_GPIO_BUTTON_WPS,
+ .active_low = 1,
+ }
+};
+
+static void __init rt_g32b_init(void)
+{
+ rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+ rt305x_register_spi(rt_g32b_spi_slave_info,
+ ARRAY_SIZE(rt_g32b_spi_slave_info));
+
+ rt305x_register_ethernet();
+ ramips_register_gpio_buttons(-1, RT_G32B_BUTTONS_POLL_INTERVAL,
+ ARRAY_SIZE(rt_g32b_gpio_buttons),
+ rt_g32b_gpio_buttons);
+ rt305x_register_wifi();
+ rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_RT_G32_B1, "RT-G32-B1", "Asus RT-G32 B1",
+ rt_g32b_init);
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index dde5ca89ad..22eaaa0882 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -115,6 +115,17 @@ define Image/Build/Profile/DIR300B1
$(call Image/Build/Template/DIR300B1,$(1),dir-600-b2,DIR-600-B2,wrgn23_dlwbr_dir600b)
endef
+mtdlayout_rtg32b1=mtdparts=spi0.0:192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
+mtd_rtg32b1_kernel_part_size=851968
+mtd_rtg32b1_rootfs_part_size=3014656
+define Image/Build/Template/RTG32B1
+ $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_rtg32b1,$(mtd_rtg32b1_kernel_part_size),$(mtd_rtg32b1_rootfs_part_size))
+endef
+
+define Image/Build/Profile/RTG32B1
+ $(call Image/Build/Template/RTG32B1,$(1),rt-g32-b1,RT-G32-B1)
+endef
+
define Image/Build/Profile/FONERA20N
$(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
endef
@@ -175,6 +186,7 @@ endef
ifeq ($(CONFIG_RALINK_RT305X),y)
define Image/Build/Profile/Default
$(call Image/Build/Profile/DIR300B1,$(1))
+ $(call Image/Build/Profile/RTG32B1,$(1))
$(call Image/Build/Profile/FONERA20N,$(1))
$(call Image/Build/Profile/V22RW2X2,$(1))
$(call Image/Build/Profile/PWH2004,$(1))
diff --git a/target/linux/ramips/rt305x/config-2.6.39 b/target/linux/ramips/rt305x/config-2.6.39
index 97cdd7c173..562b8f1536 100644
--- a/target/linux/ramips/rt305x/config-2.6.39
+++ b/target/linux/ramips/rt305x/config-2.6.39
@@ -97,6 +97,7 @@ CONFIG_RT305X_MACH_FONERA20N=y
CONFIG_RT305X_MACH_HW550_3G=y
CONFIG_RT305X_MACH_MOFI3500_3GN=y
CONFIG_RT305X_MACH_PWH2004=y
+CONFIG_RT305X_MACH_RT_G32_REVB=y
CONFIG_RT305X_MACH_V22RW_2X2=y
CONFIG_RT305X_MACH_WCR150GN=y
CONFIG_RT305X_MACH_WHR_G300N=y