summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-11-06 07:38:24 +0000
committerJohn Crispin <john@openwrt.org>2012-11-06 07:38:24 +0000
commit3a1851964e9b98af4318dd950b1037e1379d7915 (patch)
tree59ba6144cf0156d6c66e968e2ca8e6eb7a41aef5 /target/linux
parentd84fa1d9fa6e9d608be8a786fc6de8097bccd78d (diff)
downloadmaster-31e0f0ae-3a1851964e9b98af4318dd950b1037e1379d7915.tar.gz
master-31e0f0ae-3a1851964e9b98af4318dd950b1037e1379d7915.tar.bz2
master-31e0f0ae-3a1851964e9b98af4318dd950b1037e1379d7915.zip
add support for arv7525
SVN-Revision: 34097
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/lantiq/image/Makefile3
-rw-r--r--target/linux/lantiq/xway/profiles/001-lantiq.mk10
2 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index de5365e676..11374ef945 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -207,6 +207,9 @@ Image/Build/Profile/EASY80920-NAND=$(call Image/Build/$(1),$(1),EASY80920-NAND)
Image/BuildKernel/Profile/EASY80920-NOR=$(call Image/BuildKernel/Template,EASY80920-NOR)
Image/Build/Profile/EASY80920-NOR=$(call Image/Build/$(1),$(1),EASY80920-NOR)
+Image/BuildKernel/Profile/ARV7525PW=$(call Image/BuildKernel/Template,ARV7525PW)
+Image/Build/Profile/ARV7525PW=$(call Image/Build/$(1),$(1),ARV7525PW)
+
endif
ifeq ($(CONFIG_TARGET_lantiq_vr9),y)
diff --git a/target/linux/lantiq/xway/profiles/001-lantiq.mk b/target/linux/lantiq/xway/profiles/001-lantiq.mk
index 2c24d3c95e..6243568d83 100644
--- a/target/linux/lantiq/xway/profiles/001-lantiq.mk
+++ b/target/linux/lantiq/xway/profiles/001-lantiq.mk
@@ -17,3 +17,13 @@ define Profile/EASY80920-NAND/Description
endef
$(eval $(call Profile,EASY80920-NAND))
+
+define Profile/ARV7525PW
+ NAME:=ARV7525PW
+endef
+
+define Profile/ARV7525PW/Description
+ Speedport W303V - ARV7525PW
+endef
+
+$(eval $(call Profile,ARV7525PW))