summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:17:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:17:40 +0000
commit27dee35f99ae1e4478d12461520e9aeab22f1169 (patch)
tree0b56ed03772d4dccf83f03e8215602b7ff1f1360 /target/linux
parent09de82989a23c0844422dba103d7534a81cfaeef (diff)
downloadmaster-31e0f0ae-27dee35f99ae1e4478d12461520e9aeab22f1169.tar.gz
master-31e0f0ae-27dee35f99ae1e4478d12461520e9aeab22f1169.tar.bz2
master-31e0f0ae-27dee35f99ae1e4478d12461520e9aeab22f1169.zip
refresh 2.6.24 patches
SVN-Revision: 14451
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch16
-rw-r--r--target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch14
-rw-r--r--target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch28
-rw-r--r--target/linux/rdc/patches-2.6.24/003-rootfstype.patch6
-rw-r--r--target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch28
-rw-r--r--target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch6
-rw-r--r--target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch6
-rw-r--r--target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch14
-rw-r--r--target/linux/rdc/patches-2.6.24/006-pci_ids.patch4
-rw-r--r--target/linux/rdc/patches-2.6.24/600-x86_lzma.patch21
10 files changed, 63 insertions, 80 deletions
diff --git a/target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch b/target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
index 0c407a114a..6da095df58 100644
--- a/target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
+++ b/target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/maps/Kconfig
---- linux-2.6.17/drivers/mtd/maps/Kconfig 2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/mtd/maps/Kconfig 2006-09-24 20:28:11.000000000 +0200
-@@ -76,6 +76,50 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -117,6 +117,50 @@ config MTD_PNC2000
PNC-2000 is the name of Network Camera product from PHOTRON
Ltd. in Japan. It uses CFI-compliant flash.
@@ -52,11 +51,10 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/map
config MTD_SC520CDP
tristate "CFI Flash device mapped on AMD SC520 CDP"
depends on X86 && MTD_CFI && MTD_CONCAT
-diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/maps/Makefile
---- linux-2.6.17/drivers/mtd/maps/Makefile 2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/mtd/maps/Makefile 2006-09-24 20:26:10.000000000 +0200
-@@ -28,6 +28,7 @@
- obj-$(CONFIG_MTD_PHYSMAP) += physmap.o
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
+ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
obj-$(CONFIG_MTD_PNC2000) += pnc2000.o
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+obj-$(CONFIG_MTD_RDC3210) += rdc3210.o
diff --git a/target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch b/target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
index ad2102f632..11c894bcf2 100644
--- a/target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
+++ b/target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
@@ -1,15 +1,13 @@
-diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
-index 97b64d7..f8c1d32 100644
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
-@@ -79,6 +79,10 @@ config GENERIC_BUG
- default y
- depends on BUG
-
+@@ -81,6 +81,10 @@ config GENERIC_BUG
+ default y
+ depends on BUG
+
+config GENERIC_GPIO
+ bool
+ default n
+
config GENERIC_HWEIGHT
- bool
- default y
+ bool
+ default y
diff --git a/target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch b/target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
index 1b93025247..97d6e7d41f 100644
--- a/target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
+++ b/target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
@@ -1,9 +1,8 @@
-diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
---- linux-2.6.17/drivers/net/Kconfig 2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/net/Kconfig 2006-09-25 13:14:27.000000000 +0200
-@@ -1358,6 +1358,24 @@
- <file:Documentation/networking/net-modules.txt>. The module will be
- called apricot.
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -1449,6 +1449,24 @@ config APRICOT
+ To compile this driver as a module, choose M here. The module
+ will be called apricot.
+config R6040
+ tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
@@ -24,16 +23,15 @@ diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
+ depends on R6040
+ default y
config B44
- tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)"
- depends on NET_PCI && PCI && EXPERIMENTAL
-diff -urN linux-2.6.17/drivers/net/Makefile linux-2.6.17.new/drivers/net/Makefile
---- linux-2.6.17/drivers/net/Makefile 2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/net/Makefile 2006-09-25 13:14:45.000000000 +0200
-@@ -106,6 +106,7 @@
+ tristate "Broadcom 440x/47xx ethernet support"
+ depends on SSB_POSSIBLE
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -116,6 +116,7 @@ obj-$(CONFIG_LNE390) += lne390.o 8390.o
obj-$(CONFIG_NE3210) += ne3210.o 8390.o
- obj-$(CONFIG_NET_SB1250_MAC) += sb1250-mac.o
+ obj-$(CONFIG_SB1250_MAC) += sb1250-mac.o
obj-$(CONFIG_B44) += b44.o
+obj-$(CONFIG_R6040) += r6040.o
obj-$(CONFIG_FORCEDETH) += forcedeth.o
- obj-$(CONFIG_NE_H8300) += ne-h8300.o 8390.o
-
+ obj-$(CONFIG_NE_H8300) += ne-h8300.o
+ obj-$(CONFIG_AX88796) += ax88796.o
diff --git a/target/linux/rdc/patches-2.6.24/003-rootfstype.patch b/target/linux/rdc/patches-2.6.24/003-rootfstype.patch
index 34ac3d0a71..3ad90472a8 100644
--- a/target/linux/rdc/patches-2.6.24/003-rootfstype.patch
+++ b/target/linux/rdc/patches-2.6.24/003-rootfstype.patch
@@ -1,6 +1,6 @@
---- linux-2.6.19.2/init/do_mounts.c 2007-01-10 11:10:37.000000000 -0800
-+++ foo/init/do_mounts.c 2007-04-05 13:15:37.000000000 -0700
-@@ -243,6 +243,8 @@
+--- a/init/do_mounts.c
++++ b/init/do_mounts.c
+@@ -256,6 +256,8 @@ static void __init get_fs_names(char *pa
{
char *s = page;
diff --git a/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch b/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
index 47f8c08c68..a42e5409c7 100644
--- a/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
+++ b/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
---- linux-2.6.24/arch/x86/Kconfig 2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/Kconfig 2008-02-11 18:24:27.000000000 +0100
-@@ -300,6 +300,17 @@
+--- a/arch/x86/Kconfig
++++ b/arch/x86/Kconfig
+@@ -304,6 +304,17 @@ config X86_VSMP
supposed to run on these EM64T-based machines. Only choose this option
if you have one of these machines.
@@ -19,10 +18,9 @@ diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
endchoice
config SCHED_NO_NO_OMIT_FRAME_POINTER
-diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c
---- linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c 2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c 2008-02-11 18:26:18.000000000 +0100
-@@ -30,6 +30,17 @@
+--- a/arch/x86/kernel/reboot_fixups_32.c
++++ b/arch/x86/kernel/reboot_fixups_32.c
+@@ -30,6 +30,17 @@ static void cs5536_warm_reset(struct pci
udelay(50); /* shouldn't get here but be safe and spin a while */
}
@@ -40,7 +38,7 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
struct device_fixup {
unsigned int vendor;
unsigned int device;
-@@ -40,6 +51,7 @@
+@@ -40,6 +51,7 @@ static struct device_fixup fixups_table[
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
{ PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
@@ -48,10 +46,9 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
};
/*
-diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_32
---- linux-2.6.24/arch/x86/Makefile_32 2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/Makefile_32 2008-02-11 18:25:12.000000000 +0100
-@@ -99,6 +99,11 @@
+--- a/arch/x86/Makefile_32
++++ b/arch/x86/Makefile_32
+@@ -99,6 +99,11 @@ mflags-$(CONFIG_X86_ES7000) := -Iinclude
mcore-$(CONFIG_X86_ES7000) := arch/x86/mach-default
core-$(CONFIG_X86_ES7000) := arch/x86/mach-es7000/
@@ -63,9 +60,8 @@ diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_3
# Xen paravirtualization support
core-$(CONFIG_XEN) += arch/x86/xen/
-diff -urN linux-2.6.24/include/asm-x86/timex.h linux-2.6.24.new/include/asm-x86/timex.h
---- linux-2.6.24/include/asm-x86/timex.h 2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/include/asm-x86/timex.h 2008-02-11 18:25:43.000000000 +0100
+--- a/include/asm-x86/timex.h
++++ b/include/asm-x86/timex.h
@@ -7,6 +7,8 @@
#ifdef CONFIG_X86_ELAN
diff --git a/target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch b/target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch
index 7faabdf7a3..7f202c6c77 100644
--- a/target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch
+++ b/target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch
@@ -1,6 +1,6 @@
---- linux-2.6.24.7.orig/drivers/pcmcia/yenta_socket.c 2008-10-26 08:30:07.000000000 -0700
-+++ linux-2.6.24.7/drivers/pcmcia/yenta_socket.c 2008-10-26 08:54:27.000000000 -0700
-@@ -1171,6 +1171,17 @@
+--- a/drivers/pcmcia/yenta_socket.c
++++ b/drivers/pcmcia/yenta_socket.c
+@@ -1171,6 +1171,17 @@ static int __devinit yenta_probe (struct
/* We must finish initialization here */
diff --git a/target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch b/target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch
index 007477e836..99b54b72a2 100644
--- a/target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch
+++ b/target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch
@@ -1,6 +1,6 @@
---- linux-2.6.24.7/arch/x86/kernel/setup_32.c 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/arch/x86/kernel/setup_32.c 2008-08-05 14:54:58.000000000 +0200
-@@ -609,6 +609,7 @@
+--- a/arch/x86/kernel/setup_32.c
++++ b/arch/x86/kernel/setup_32.c
+@@ -609,6 +609,7 @@ void __init setup_arch(char **cmdline_p)
print_memory_map("user");
}
diff --git a/target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch b/target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch
index eabfd04ed3..5be29df356 100644
--- a/target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch
+++ b/target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch
@@ -1,7 +1,6 @@
-diff -ru linux-2.6.24.7.orig/arch/x86/boot/boot.h linux-2.6.24.7/arch/x86/boot/boot.h
---- linux-2.6.24.7.orig/arch/x86/boot/boot.h 2008-10-26 20:18:14.000000000 -0700
-+++ linux-2.6.24.7/arch/x86/boot/boot.h 2008-10-26 20:18:36.000000000 -0700
-@@ -60,7 +60,7 @@
+--- a/arch/x86/boot/boot.h
++++ b/arch/x86/boot/boot.h
+@@ -60,7 +60,7 @@ static inline void outl(u32 v, u16 port)
{
asm volatile("outl %0,%1" : : "a" (v), "dN" (port));
}
@@ -10,9 +9,8 @@ diff -ru linux-2.6.24.7.orig/arch/x86/boot/boot.h linux-2.6.24.7/arch/x86/boot/b
{
u32 v;
asm volatile("inl %1,%0" : "=a" (v) : "dN" (port));
-diff -ru linux-2.6.24.7.orig/arch/x86/boot/pm.c linux-2.6.24.7/arch/x86/boot/pm.c
---- linux-2.6.24.7.orig/arch/x86/boot/pm.c 2008-10-26 19:55:50.000000000 -0700
-+++ linux-2.6.24.7/arch/x86/boot/pm.c 2008-10-26 21:38:12.000000000 -0700
+--- a/arch/x86/boot/pm.c
++++ b/arch/x86/boot/pm.c
@@ -16,6 +16,9 @@
#include "boot.h"
@@ -23,7 +21,7 @@ diff -ru linux-2.6.24.7.orig/arch/x86/boot/pm.c linux-2.6.24.7/arch/x86/boot/pm.
/*
* Invoke the realmode switch hook if present; otherwise
-@@ -160,6 +163,16 @@
+@@ -160,6 +163,16 @@ void go_to_protected_mode(void)
die();
}
diff --git a/target/linux/rdc/patches-2.6.24/006-pci_ids.patch b/target/linux/rdc/patches-2.6.24/006-pci_ids.patch
index cd4c01d920..96ab2b14e2 100644
--- a/target/linux/rdc/patches-2.6.24/006-pci_ids.patch
+++ b/target/linux/rdc/patches-2.6.24/006-pci_ids.patch
@@ -1,8 +1,6 @@
-diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
-index 55f307f..4a1aa34 100644
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
-@@ -2076,6 +2076,13 @@
+@@ -2106,6 +2106,13 @@
#define PCI_DEVICE_ID_HERC_WIN 0x5732
#define PCI_DEVICE_ID_HERC_UNI 0x5832
diff --git a/target/linux/rdc/patches-2.6.24/600-x86_lzma.patch b/target/linux/rdc/patches-2.6.24/600-x86_lzma.patch
index 266c042971..9d94950b5c 100644
--- a/target/linux/rdc/patches-2.6.24/600-x86_lzma.patch
+++ b/target/linux/rdc/patches-2.6.24/600-x86_lzma.patch
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefile.lib
---- linux-2.6.19.2/scripts/Makefile.lib 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/scripts/Makefile.lib 2007-04-15 23:51:54.000000000 +0200
-@@ -162,4 +162,9 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -166,4 +166,9 @@ cmd_objcopy = $(OBJCOPY) $(OBJCOPYFLAGS)
quiet_cmd_gzip = GZIP $@
cmd_gzip = gzip -f -9 < $< > $@
@@ -12,17 +11,15 @@ diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefil
+cmd_lzma = bash -e scripts/lzma_kern $< $@ -lc7 -lp0 -pb0
+# to use lzmacomp,
+# cmd_lzma = lzmacomp $< 700 > $@
-diff -u linux/scripts/lzma_kern linux/scripts/lzma_kern
---- linux/scripts/lzma_kern 2007-07-27 20:18:17.013014750 -0700
-+++ linux/scripts/lzma_kern 2007-07-27 20:18:17.013014750 -0700
+--- /dev/null
++++ b/scripts/lzma_kern
@@ -0,0 +1,4 @@
+get-size() { echo "$5" ;}
+printf -v len '%.8x' "$(get-size $(ls -l "$1"))"
+lzma e "$@"
+echo -ne "\x$(echo $len | cut -c 7,8)\x$(echo $len | cut -c 5,6)\x$(echo $len | cut -c 3,4)\x$(echo $len | cut -c 1,2)" >> "$2"
-diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32
---- linux-2.6.24/arch/x86/boot/compressed/Makefile_32 2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32 2008-02-13 15:21:03.000000000 +0100
+--- a/arch/x86/boot/compressed/Makefile_32
++++ b/arch/x86/boot/compressed/Makefile_32
@@ -4,8 +4,8 @@
# create a compressed vmlinux image from the original vmlinux
#
@@ -34,7 +31,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
EXTRA_AFLAGS := -traditional
LDFLAGS_vmlinux := -T
-@@ -17,7 +17,7 @@
+@@ -17,7 +17,7 @@ KBUILD_CFLAGS := -m32 -D__KERNEL__ $(LI
$(call cc-option,-fno-stack-protector)
LDFLAGS := -m elf_i386
@@ -43,7 +40,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
$(call if_changed,ld)
@:
-@@ -37,14 +37,14 @@
+@@ -37,14 +37,14 @@ $(obj)/vmlinux.bin.all: $(vmlinux.bin.al
$(call if_changed,relocbin)
ifdef CONFIG_RELOCATABLE