summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-08 15:01:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-08 15:01:33 +0000
commit25811736600f714c2f9dffbcb0f3f247f5c84cd3 (patch)
tree7aad12d8a43c8ef39a18f25db9795f04536e3e5e /target/linux
parent47f9b2a110b214432185f45fea0e143eb740fd13 (diff)
downloadmaster-31e0f0ae-25811736600f714c2f9dffbcb0f3f247f5c84cd3.tar.gz
master-31e0f0ae-25811736600f714c2f9dffbcb0f3f247f5c84cd3.tar.bz2
master-31e0f0ae-25811736600f714c2f9dffbcb0f3f247f5c84cd3.zip
kernel: update linux 3.6 to 3.6.9
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34578
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/generic/patches-3.6/065-8139cp-fixes.patch20
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/ramips/Makefile2
-rw-r--r--target/linux/sparc/Makefile2
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/x86/geos/target.mk2
9 files changed, 17 insertions, 19 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 63aa915f8f..ebaf6bb970 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.6.8
+LINUX_VERSION:=3.6.9
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index bb4c1ec47f..fcc6e86fdd 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.6.8
+LINUX_VERSION:=3.6.9
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic/patches-3.6/065-8139cp-fixes.patch b/target/linux/generic/patches-3.6/065-8139cp-fixes.patch
index f0087bfee3..149fb65c73 100644
--- a/target/linux/generic/patches-3.6/065-8139cp-fixes.patch
+++ b/target/linux/generic/patches-3.6/065-8139cp-fixes.patch
@@ -53,11 +53,9 @@ Date: Wed Nov 21 10:27:19 2012 +0000
Cc: stable@kernel.org [3.5+]
Signed-off-by: David S. Miller <davem@davemloft.net>
-diff --git a/drivers/net/ethernet/realtek/8139cp.c b/drivers/net/ethernet/realtek/8139cp.c
-index 1c81825..6cb96b4 100644
--- a/drivers/net/ethernet/realtek/8139cp.c
+++ b/drivers/net/ethernet/realtek/8139cp.c
-@@ -648,6 +648,7 @@ static void cp_tx (struct cp_private *cp)
+@@ -648,6 +648,7 @@ static void cp_tx (struct cp_private *cp
{
unsigned tx_head = cp->tx_head;
unsigned tx_tail = cp->tx_tail;
@@ -65,7 +63,7 @@ index 1c81825..6cb96b4 100644
while (tx_tail != tx_head) {
struct cp_desc *txd = cp->tx_ring + tx_tail;
-@@ -666,6 +667,9 @@ static void cp_tx (struct cp_private *cp)
+@@ -666,6 +667,9 @@ static void cp_tx (struct cp_private *cp
le32_to_cpu(txd->opts1) & 0xffff,
PCI_DMA_TODEVICE);
@@ -75,7 +73,7 @@ index 1c81825..6cb96b4 100644
if (status & LastFrag) {
if (status & (TxError | TxFIFOUnder)) {
netif_dbg(cp, tx_err, cp->dev,
-@@ -697,6 +701,7 @@ static void cp_tx (struct cp_private *cp)
+@@ -697,6 +701,7 @@ static void cp_tx (struct cp_private *cp
cp->tx_tail = tx_tail;
@@ -83,7 +81,7 @@ index 1c81825..6cb96b4 100644
if (TX_BUFFS_AVAIL(cp) > (MAX_SKB_FRAGS + 1))
netif_wake_queue(cp->dev);
}
-@@ -843,6 +848,8 @@ static netdev_tx_t cp_start_xmit (struct sk_buff *skb,
+@@ -843,6 +848,8 @@ static netdev_tx_t cp_start_xmit (struct
wmb();
}
cp->tx_head = entry;
@@ -92,7 +90,7 @@ index 1c81825..6cb96b4 100644
netif_dbg(cp, tx_queued, cp->dev, "tx queued, slot %d, skblen %d\n",
entry, skb->len);
if (TX_BUFFS_AVAIL(cp) <= (MAX_SKB_FRAGS + 1))
-@@ -937,6 +944,8 @@ static void cp_stop_hw (struct cp_private *cp)
+@@ -937,6 +944,8 @@ static void cp_stop_hw (struct cp_privat
cp->rx_tail = 0;
cp->tx_head = cp->tx_tail = 0;
@@ -101,7 +99,7 @@ index 1c81825..6cb96b4 100644
}
static void cp_reset_hw (struct cp_private *cp)
-@@ -957,8 +966,38 @@ static void cp_reset_hw (struct cp_private *cp)
+@@ -957,8 +966,38 @@ static void cp_reset_hw (struct cp_priva
static inline void cp_start_hw (struct cp_private *cp)
{
@@ -140,7 +138,7 @@ index 1c81825..6cb96b4 100644
}
static void cp_enable_irq(struct cp_private *cp)
-@@ -969,7 +1008,6 @@ static void cp_enable_irq(struct cp_private *cp)
+@@ -969,7 +1008,6 @@ static void cp_enable_irq(struct cp_priv
static void cp_init_hw (struct cp_private *cp)
{
struct net_device *dev = cp->dev;
@@ -148,7 +146,7 @@ index 1c81825..6cb96b4 100644
cp_reset_hw(cp);
-@@ -979,17 +1017,6 @@ static void cp_init_hw (struct cp_private *cp)
+@@ -979,17 +1017,6 @@ static void cp_init_hw (struct cp_privat
cpw32_f (MAC0 + 0, le32_to_cpu (*(__le32 *) (dev->dev_addr + 0)));
cpw32_f (MAC0 + 4, le32_to_cpu (*(__le32 *) (dev->dev_addr + 4)));
@@ -166,7 +164,7 @@ index 1c81825..6cb96b4 100644
cp_start_hw(cp);
cpw8(TxThresh, 0x06); /* XXX convert magic num to a constant */
-@@ -1192,6 +1219,7 @@ static void cp_tx_timeout(struct net_device *dev)
+@@ -1192,6 +1219,7 @@ static void cp_tx_timeout(struct net_dev
cp_clean_rings(cp);
rc = cp_init_rings(cp);
cp_start_hw(cp);
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 9858c720d3..f227048a33 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=danube ar9 vr9 falcon svip_be
LINUX_VERSION:=3.3.8
#SUBTARGETS=xway ase
-#LINUX_VERSION:=3.6.8
+#LINUX_VERSION:=3.6.9
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 83cf63f271..01880398df 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.6.8
+LINUX_VERSION:=3.6.9
DEVICE_TYPE:=developerboard
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index 0dce80cbb8..e29d844aeb 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
FEATURES:=squashfs
-LINUX_VERSION:=3.6.8
+LINUX_VERSION:=3.6.9
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
diff --git a/target/linux/sparc/Makefile b/target/linux/sparc/Makefile
index bd854cc8ed..e242367a5e 100644
--- a/target/linux/sparc/Makefile
+++ b/target/linux/sparc/Makefile
@@ -11,7 +11,7 @@ BOARD:=sparc
BOARDNAME:=Sun UltraSPARC
FEATURES+=fpu tgz jffs2 ext4 squashfs
-LINUX_VERSION:=3.6.8
+LINUX_VERSION:=3.6.9
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 4b8b3eefc2..149a589b85 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext4 audio
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.6.8
+LINUX_VERSION:=3.6.9
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
index 41e3db8502..d82901df74 100644
--- a/target/linux/x86/geos/target.mk
+++ b/target/linux/x86/geos/target.mk
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
kmod-cpu-msr \
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
hwclock wpad flashrom tc
-LINUX_VERSION:=3.6.8
+LINUX_VERSION:=3.6.9
CS5535_MASK:=0x0E000048
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \