summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:06 +0000
commit2499a57d92409e767386d0d36684952c20735656 (patch)
tree7aa0faeea81f36c472f0473955718da5bc6a241d /target/linux
parent4ab26a52ef687a42a318d52440e27d0f5a8d6769 (diff)
downloadmaster-31e0f0ae-2499a57d92409e767386d0d36684952c20735656.tar.gz
master-31e0f0ae-2499a57d92409e767386d0d36684952c20735656.tar.bz2
master-31e0f0ae-2499a57d92409e767386d0d36684952c20735656.zip
targets: add kernel image dependencies on device tree files
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48146
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/arc770/image/Makefile1
-rw-r--r--target/linux/bcm53xx/image/Makefile1
-rw-r--r--target/linux/brcm63xx/image/Makefile1
-rw-r--r--target/linux/ipq806x/image/Makefile1
-rw-r--r--target/linux/kirkwood/image/Makefile1
-rw-r--r--target/linux/ramips/image/Makefile1
6 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/arc770/image/Makefile b/target/linux/arc770/image/Makefile
index c033102d51..6b9c5e4524 100644
--- a/target/linux/arc770/image/Makefile
+++ b/target/linux/arc770/image/Makefile
@@ -15,6 +15,7 @@ endef
# Shared device definition: applies to every defined device
define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
+ KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
KERNEL_SUFFIX := .elf
KERNEL_INITRAMFS := kernel-bin | patch-dtb
KERNEL_INITRAMFS_NAME = $$(KERNEL_NAME)-initramfs.elf
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index c9987dddc7..d9d4a80fa1 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -67,6 +67,7 @@ define Device/Default
# extract the full dtb name based on the device info
DT := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
KERNEL := kernel-bin | append-dtb | lzma-d16
+ KERNEL_DEPENDS = $$(wildcard $(KDIR)/$$(DT).dts)
FILESYSTEMS := squashfs
KERNEL_NAME := zImage
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 53e4c217e8..81a9dc70cc 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -168,6 +168,7 @@ endef
# Shared device definition: applies to every defined device
define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
+ KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_IMAGE = $$(KERNEL_INITRAMFS_PREFIX).elf
DEVICE_PROFILE :=
DEVICE_DTS :=
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 14cf442f43..58c4e1e872 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -42,6 +42,7 @@ endef
define Device/Default
PROFILES := Default
+ KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
DEVICE_DTS :=
KERNEL_PREFIX := $$(IMAGE_PREFIX)
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 3fc84aa756..24cb31702d 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -15,6 +15,7 @@ KERNEL_LOADADDR:=0x8000
TARGET_DEVICES = linksys-audi linksys-viper
define Device/Default
+ KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL := kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
endef
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index e4cbdb6e4f..05d979573a 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -32,6 +32,7 @@ KERNEL_LOADADDR := $(loadaddr-y)
KERNEL_DTB = kernel-bin | patch-dtb | lzma
define Device/Default
+ KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
KERNEL := $(KERNEL_DTB) | uImage lzma
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)