summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:18:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:18:19 +0000
commit1200d62f668a1eac3123301eee1fc96613133409 (patch)
tree46023753eacf61fac40e0e4b3ee604b25e52d7f1 /target/linux
parent27dee35f99ae1e4478d12461520e9aeab22f1169 (diff)
downloadmaster-31e0f0ae-1200d62f668a1eac3123301eee1fc96613133409.tar.gz
master-31e0f0ae-1200d62f668a1eac3123301eee1fc96613133409.tar.bz2
master-31e0f0ae-1200d62f668a1eac3123301eee1fc96613133409.zip
refresh 2.6.24 patches
SVN-Revision: 14452
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/rb532/patches-2.6.24/100-rb5xx_support.patch42
-rw-r--r--target/linux/rb532/patches-2.6.24/110-korina_ethernet.patch20
-rw-r--r--target/linux/rb532/patches-2.6.24/120-cf.patch14
-rw-r--r--target/linux/rb532/patches-2.6.24/140-cmdline_hack.patch8
-rw-r--r--target/linux/rb532/patches-2.6.24/200-bridge_resource_hack.patch6
-rw-r--r--target/linux/rb532/patches-2.6.24/220-serial_fix.patch6
-rw-r--r--target/linux/rb532/patches-2.6.24/240-via_rhine_performance.patch14
-rw-r--r--target/linux/rb532/patches-2.6.24/510-rb500_led.patch14
-rw-r--r--target/linux/rb532/patches-2.6.24/520-rc32434_wdt.patch14
-rw-r--r--target/linux/rb532/patches-2.6.24/530-no_panic_pci_iomap.patch7
10 files changed, 59 insertions, 86 deletions
diff --git a/target/linux/rb532/patches-2.6.24/100-rb5xx_support.patch b/target/linux/rb532/patches-2.6.24/100-rb5xx_support.patch
index 081eced2b4..f9eae4b522 100644
--- a/target/linux/rb532/patches-2.6.24/100-rb5xx_support.patch
+++ b/target/linux/rb532/patches-2.6.24/100-rb5xx_support.patch
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.24.7/arch/mips/Kconfig linux-2.6.24.7.new/arch/mips/Kconfig
---- linux-2.6.24.7/arch/mips/Kconfig 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/arch/mips/Kconfig 2008-07-15 15:29:51.000000000 +0200
-@@ -687,6 +687,23 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -687,6 +687,23 @@ config WR_PPMC
This enables support for the Wind River MIPS32 4KC PPMC evaluation
board, which is based on GT64120 bridge chip.
@@ -25,7 +24,7 @@ diff -urN linux-2.6.24.7/arch/mips/Kconfig linux-2.6.24.7.new/arch/mips/Kconfig
endchoice
source "arch/mips/au1000/Kconfig"
-@@ -967,6 +982,7 @@
+@@ -967,6 +984,7 @@ config MIPS_L1_CACHE_SHIFT
default "4" if MACH_DECSTATION
default "7" if SGI_IP27 || SNI_RM
default "4" if PMC_MSP4200_EVAL
@@ -33,10 +32,9 @@ diff -urN linux-2.6.24.7/arch/mips/Kconfig linux-2.6.24.7.new/arch/mips/Kconfig
default "5"
config HAVE_STD_PC_SERIAL_PORT
-diff -urN linux-2.6.24.7/arch/mips/Makefile linux-2.6.24.7.new/arch/mips/Makefile
---- linux-2.6.24.7/arch/mips/Makefile 2008-07-15 15:27:55.000000000 +0200
-+++ linux-2.6.24.7.new/arch/mips/Makefile 2008-07-15 15:30:21.000000000 +0200
-@@ -297,6 +297,13 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -297,6 +297,13 @@ load-$(CONFIG_LEMOTE_FULONG) +=0xfffffff
cflags-$(CONFIG_LEMOTE_FULONG) += -Iinclude/asm-mips/mach-lemote
#
@@ -50,18 +48,16 @@ diff -urN linux-2.6.24.7/arch/mips/Makefile linux-2.6.24.7.new/arch/mips/Makefil
# For all MIPS, Inc. eval boards
#
core-$(CONFIG_MIPS_BOARDS_GEN) += arch/mips/mips-boards/generic/
-diff -urN linux-2.6.24.7/arch/mips/pci/Makefile linux-2.6.24.7.new/arch/mips/pci/Makefile
---- linux-2.6.24.7/arch/mips/pci/Makefile 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/arch/mips/pci/Makefile 2008-07-15 15:30:46.000000000 +0200
-@@ -48,3 +48,4 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_MIKROTIK_RB500) += pci-rc32434.o ops-rc32434.o fixup-rb500.o
-diff -urN linux-2.6.24.7/drivers/pci/Makefile linux-2.6.24.7.new/drivers/pci/Makefile
---- linux-2.6.24.7/drivers/pci/Makefile 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/drivers/pci/Makefile 2008-07-15 15:31:20.000000000 +0200
-@@ -35,6 +35,7 @@
+--- a/drivers/pci/Makefile
++++ b/drivers/pci/Makefile
+@@ -35,6 +35,7 @@ obj-$(CONFIG_PPC32) += setup-irq.o
obj-$(CONFIG_PPC64) += setup-bus.o
obj-$(CONFIG_MIPS) += setup-bus.o setup-irq.o
obj-$(CONFIG_X86_VISWS) += setup-irq.o
@@ -69,9 +65,8 @@ diff -urN linux-2.6.24.7/drivers/pci/Makefile linux-2.6.24.7.new/drivers/pci/Mak
#
# ACPI Related PCI FW Functions
-diff -urN linux-2.6.24.7/include/asm-mips/bootinfo.h linux-2.6.24.7.new/include/asm-mips/bootinfo.h
---- linux-2.6.24.7/include/asm-mips/bootinfo.h 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/include/asm-mips/bootinfo.h 2008-07-15 15:32:06.000000000 +0200
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
@@ -198,6 +198,14 @@
#define MACH_GROUP_BRCM 23 /* Broadcom */
#define MACH_BCM47XX 1 /* Broadcom BCM47XX */
@@ -87,10 +82,9 @@ diff -urN linux-2.6.24.7/include/asm-mips/bootinfo.h linux-2.6.24.7.new/include/
#define CL_SIZE COMMAND_LINE_SIZE
const char *get_system_type(void);
-diff -urN linux-2.6.24.7/include/asm-mips/cpu.h linux-2.6.24.7.new/include/asm-mips/cpu.h
---- linux-2.6.24.7/include/asm-mips/cpu.h 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/include/asm-mips/cpu.h 2008-07-15 15:32:22.000000000 +0200
-@@ -196,7 +196,7 @@
+--- a/include/asm-mips/cpu.h
++++ b/include/asm-mips/cpu.h
+@@ -196,7 +196,7 @@ enum cpu_type_enum {
*/
CPU_4KC, CPU_4KEC, CPU_4KSC, CPU_24K, CPU_34K, CPU_74K, CPU_AU1000,
CPU_AU1100, CPU_AU1200, CPU_AU1500, CPU_AU1550, CPU_PR4450,
diff --git a/target/linux/rb532/patches-2.6.24/110-korina_ethernet.patch b/target/linux/rb532/patches-2.6.24/110-korina_ethernet.patch
index acfba6c00a..3c46590f94 100644
--- a/target/linux/rb532/patches-2.6.24/110-korina_ethernet.patch
+++ b/target/linux/rb532/patches-2.6.24/110-korina_ethernet.patch
@@ -1,10 +1,8 @@
-Index: linux-2.6.23.17/drivers/net/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/drivers/net/Kconfig
-+++ linux-2.6.23.17/drivers/net/Kconfig
-@@ -348,6 +348,13 @@ config AX88796
- AX88796 driver, using platform bus to provide
- chip detection and resources
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -362,6 +362,13 @@ config AX88796_93CX6
+ help
+ Select this if your platform comes with an external 93CX6 eeprom.
+config KORINA
+ tristate "Korina Local Ethernet support"
@@ -16,11 +14,9 @@ Index: linux-2.6.23.17/drivers/net/Kconfig
config MACE
tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32
-Index: linux-2.6.23.17/drivers/net/Makefile
-===================================================================
---- linux-2.6.23.17.orig/drivers/net/Makefile
-+++ linux-2.6.23.17/drivers/net/Makefile
-@@ -25,6 +25,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -30,6 +30,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
#
obj-$(CONFIG_PLIP) += plip.o
diff --git a/target/linux/rb532/patches-2.6.24/120-cf.patch b/target/linux/rb532/patches-2.6.24/120-cf.patch
index 522195e451..15b84a1dbc 100644
--- a/target/linux/rb532/patches-2.6.24/120-cf.patch
+++ b/target/linux/rb532/patches-2.6.24/120-cf.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/drivers/block/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/drivers/block/Kconfig
-+++ linux-2.6.23.17/drivers/block/Kconfig
-@@ -426,6 +426,14 @@ config SUNVDC
+--- a/drivers/block/Kconfig
++++ b/drivers/block/Kconfig
+@@ -408,6 +408,14 @@ config SUNVDC
Support for virtual disk devices as a client under Sun
Logical Domains.
@@ -17,10 +15,8 @@ Index: linux-2.6.23.17/drivers/block/Kconfig
source "drivers/s390/block/Kconfig"
config XILINX_SYSACE
-Index: linux-2.6.23.17/drivers/block/Makefile
-===================================================================
---- linux-2.6.23.17.orig/drivers/block/Makefile
-+++ linux-2.6.23.17/drivers/block/Makefile
+--- a/drivers/block/Makefile
++++ b/drivers/block/Makefile
@@ -21,6 +21,7 @@ obj-$(CONFIG_BLK_DEV_DAC960) += DAC960.o
obj-$(CONFIG_XILINX_SYSACE) += xsysace.o
obj-$(CONFIG_CDROM_PKTCDVD) += pktcdvd.o
diff --git a/target/linux/rb532/patches-2.6.24/140-cmdline_hack.patch b/target/linux/rb532/patches-2.6.24/140-cmdline_hack.patch
index 1e01e953e5..29a4e19665 100644
--- a/target/linux/rb532/patches-2.6.24/140-cmdline_hack.patch
+++ b/target/linux/rb532/patches-2.6.24/140-cmdline_hack.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/arch/mips/kernel/head.S
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/kernel/head.S
-+++ linux-2.6.23.17/arch/mips/kernel/head.S
-@@ -132,6 +132,10 @@
+--- a/arch/mips/kernel/head.S
++++ b/arch/mips/kernel/head.S
+@@ -122,6 +122,10 @@
j kernel_entry
nop
diff --git a/target/linux/rb532/patches-2.6.24/200-bridge_resource_hack.patch b/target/linux/rb532/patches-2.6.24/200-bridge_resource_hack.patch
index 707935539b..552b7282ee 100644
--- a/target/linux/rb532/patches-2.6.24/200-bridge_resource_hack.patch
+++ b/target/linux/rb532/patches-2.6.24/200-bridge_resource_hack.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.17/arch/mips/pci/pci.c
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/pci/pci.c
-+++ linux-2.6.23.17/arch/mips/pci/pci.c
+--- a/arch/mips/pci/pci.c
++++ b/arch/mips/pci/pci.c
@@ -64,8 +64,10 @@ pcibios_align_resource(void *data, struc
/*
* Put everything into 0x00-0xff region modulo 0x400
diff --git a/target/linux/rb532/patches-2.6.24/220-serial_fix.patch b/target/linux/rb532/patches-2.6.24/220-serial_fix.patch
index 4af6620fb5..59194da34d 100644
--- a/target/linux/rb532/patches-2.6.24/220-serial_fix.patch
+++ b/target/linux/rb532/patches-2.6.24/220-serial_fix.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.17/drivers/serial/8250.c
-===================================================================
---- linux-2.6.23.17.orig/drivers/serial/8250.c
-+++ linux-2.6.23.17/drivers/serial/8250.c
+--- a/drivers/serial/8250.c
++++ b/drivers/serial/8250.c
@@ -433,6 +433,13 @@ serial_out(struct uart_8250_port *up, in
default:
outb(value, up->port.iobase + offset);
diff --git a/target/linux/rb532/patches-2.6.24/240-via_rhine_performance.patch b/target/linux/rb532/patches-2.6.24/240-via_rhine_performance.patch
index d82b6f7055..ba66d40bd3 100644
--- a/target/linux/rb532/patches-2.6.24/240-via_rhine_performance.patch
+++ b/target/linux/rb532/patches-2.6.24/240-via_rhine_performance.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.17/drivers/net/via-rhine.c
-===================================================================
---- linux-2.6.23.17.orig/drivers/net/via-rhine.c
-+++ linux-2.6.23.17/drivers/net/via-rhine.c
+--- a/drivers/net/via-rhine.c
++++ b/drivers/net/via-rhine.c
@@ -33,6 +33,8 @@
#define DRV_VERSION "1.4.3"
#define DRV_RELDATE "2007-03-06"
@@ -52,7 +50,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
/*
Theory of Operation
-@@ -927,7 +934,7 @@ static void alloc_rbufs(struct net_devic
+@@ -922,7 +929,7 @@ static void alloc_rbufs(struct net_devic
/* Fill in the Rx buffers. Handle allocation failure gracefully. */
for (i = 0; i < RX_RING_SIZE; i++) {
@@ -61,7 +59,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
rp->rx_skbuff[i] = skb;
if (skb == NULL)
break;
-@@ -1484,7 +1491,9 @@ static int rhine_rx(struct net_device *d
+@@ -1485,7 +1492,9 @@ static int rhine_rx(struct net_device *d
struct sk_buff *skb;
/* Length should omit the CRC */
int pkt_len = data_size - 4;
@@ -72,7 +70,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
/* Check if the packet is long enough to accept without
copying to a minimally-sized skbuff. */
if (pkt_len < rx_copybreak &&
-@@ -1503,7 +1512,9 @@ static int rhine_rx(struct net_device *d
+@@ -1504,7 +1513,9 @@ static int rhine_rx(struct net_device *d
rp->rx_skbuff_dma[entry],
rp->rx_buf_sz,
PCI_DMA_FROMDEVICE);
@@ -83,7 +81,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
skb = rp->rx_skbuff[entry];
if (skb == NULL) {
printk(KERN_ERR "%s: Inconsistent Rx "
-@@ -1517,6 +1528,14 @@ static int rhine_rx(struct net_device *d
+@@ -1518,6 +1529,14 @@ static int rhine_rx(struct net_device *d
rp->rx_skbuff_dma[entry],
rp->rx_buf_sz,
PCI_DMA_FROMDEVICE);
diff --git a/target/linux/rb532/patches-2.6.24/510-rb500_led.patch b/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
index 6cd7b1a1c5..d38b427fd0 100644
--- a/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
+++ b/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.24.7/drivers/leds/Kconfig linux-2.6.24.7.new/drivers/leds/Kconfig
---- linux-2.6.24.7/drivers/leds/Kconfig 2008-07-15 15:27:55.000000000 +0200
-+++ linux-2.6.24.7.new/drivers/leds/Kconfig 2008-07-15 15:35:24.000000000 +0200
-@@ -120,6 +120,12 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -120,6 +120,12 @@ config LEDS_CM_X270
help
This option enables support for the CM-X270 LEDs.
@@ -14,10 +13,9 @@ diff -urN linux-2.6.24.7/drivers/leds/Kconfig linux-2.6.24.7.new/drivers/leds/Kc
comment "LED Triggers"
config LEDS_TRIGGERS
-diff -urN linux-2.6.24.7/drivers/leds/Makefile linux-2.6.24.7.new/drivers/leds/Makefile
---- linux-2.6.24.7/drivers/leds/Makefile 2008-07-15 15:27:55.000000000 +0200
-+++ linux-2.6.24.7.new/drivers/leds/Makefile 2008-07-15 15:35:38.000000000 +0200
-@@ -20,6 +20,7 @@
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_LEDS_COBALT_QUBE) += leds-
obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
obj-$(CONFIG_LEDS_CM_X270) += leds-cm-x270.o
diff --git a/target/linux/rb532/patches-2.6.24/520-rc32434_wdt.patch b/target/linux/rb532/patches-2.6.24/520-rc32434_wdt.patch
index 6e26237042..cfcf69777b 100644
--- a/target/linux/rb532/patches-2.6.24/520-rc32434_wdt.patch
+++ b/target/linux/rb532/patches-2.6.24/520-rc32434_wdt.patch
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.24.7/arch/mips/kernel/time.c linux-2.6.24.7.new/arch/mips/kernel/time.c
---- linux-2.6.24.7/arch/mips/kernel/time.c 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/arch/mips/kernel/time.c 2008-07-15 15:38:33.000000000 +0200
-@@ -75,6 +75,7 @@
+--- a/arch/mips/kernel/time.c
++++ b/arch/mips/kernel/time.c
+@@ -75,6 +75,7 @@ EXPORT_SYMBOL(perf_irq);
*/
unsigned int mips_hpt_frequency;
@@ -9,10 +8,9 @@ diff -urN linux-2.6.24.7/arch/mips/kernel/time.c linux-2.6.24.7.new/arch/mips/ke
void __init clocksource_set_clock(struct clocksource *cs, unsigned int clock)
{
-diff -urN linux-2.6.24.7/drivers/watchdog/Kconfig linux-2.6.24.7.new/drivers/watchdog/Kconfig
---- linux-2.6.24.7/drivers/watchdog/Kconfig 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/drivers/watchdog/Kconfig 2008-07-15 15:39:24.000000000 +0200
-@@ -639,6 +639,18 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -639,6 +639,18 @@ config AR7_WDT
help
Hardware driver for the TI AR7 Watchdog Timer.
diff --git a/target/linux/rb532/patches-2.6.24/530-no_panic_pci_iomap.patch b/target/linux/rb532/patches-2.6.24/530-no_panic_pci_iomap.patch
index a37b190dfe..1e79bfcd0e 100644
--- a/target/linux/rb532/patches-2.6.24/530-no_panic_pci_iomap.patch
+++ b/target/linux/rb532/patches-2.6.24/530-no_panic_pci_iomap.patch
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.24.7/arch/mips/lib/iomap-pci.c linux-2.6.24.7.new/arch/mips/lib/iomap-pci.c
---- linux-2.6.24.7/arch/mips/lib/iomap-pci.c 2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/arch/mips/lib/iomap-pci.c 2008-07-15 16:24:22.000000000 +0200
-@@ -32,7 +32,7 @@
+--- a/arch/mips/lib/iomap-pci.c
++++ b/arch/mips/lib/iomap-pci.c
+@@ -32,7 +32,7 @@ static void __iomem *ioport_map_pci(stru
"report it to linux-mips@linux-mips.org or your "
"vendor.\n", name);
#ifdef CONFIG_PCI_DOMAINS