summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2010-11-19 13:41:54 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2010-11-19 13:41:54 +0000
commit049e59a27be91dc9731f53b4868795adde682fd4 (patch)
tree6b8999e55c7218cc21db47bb355fd1b35d716ab8 /target/linux
parentde509c49d7430d0f220cceed80d1b8f19715d159 (diff)
downloadmaster-31e0f0ae-049e59a27be91dc9731f53b4868795adde682fd4.tar.gz
master-31e0f0ae-049e59a27be91dc9731f53b4868795adde682fd4.tar.bz2
master-31e0f0ae-049e59a27be91dc9731f53b4868795adde682fd4.zip
Initial support for Telsey CPVA642 boards (no vlans, no DSL, GPIO led/buttons not known).
SVN-Revision: 24040
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm63xx/image/Makefile3
-rw-r--r--target/linux/brcm63xx/patches-2.6.35/310-CPVA642_board.patch37
2 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 56d048bbbd..4f41889a52 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -172,6 +172,9 @@ define Image/Build
# RG100A,DB120 etc.
$(call Image/Build/RG100A,$(1),96358VW2,6358,0x20000,RG100A_DB120)
+ # Telsey CPVA642-type (e.g. CPA-ZNTE60T)
+ $(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
+
endef
$(eval $(call BuildImage))
diff --git a/target/linux/brcm63xx/patches-2.6.35/310-CPVA642_board.patch b/target/linux/brcm63xx/patches-2.6.35/310-CPVA642_board.patch
new file mode 100644
index 0000000000..bc71425d94
--- /dev/null
+++ b/target/linux/brcm63xx/patches-2.6.35/310-CPVA642_board.patch
@@ -0,0 +1,37 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -677,6 +677,26 @@ static struct board_info __initdata boar
+ },
+ };
+
++static struct board_info __initdata board_CPVA642 = {
++ .name = "CPVA642",
++ .expected_cpu_id = 0x6358,
++
++ .has_uart0 = 1,
++ .has_enet1 = 1,
++ .has_pci = 1,
++
++ .enet1 = {
++ .force_speed_100 = 1,
++ .force_duplex_full = 1,
++ },
++
++ .has_ohci0 = 1,
++ .has_ehci0 = 1,
++
++ /* GPIOs not yet known for this device */
++};
++
++
+ static struct board_info __initdata board_AGPFS0 = {
+ .name = "AGPF-S0",
+ .expected_cpu_id = 0x6358,
+@@ -1339,6 +1359,7 @@ static const struct board_info __initdat
+ &board_96358vw,
+ &board_96358vw2,
+ &board_AGPFS0,
++ &board_CPVA642,
+ &board_DWVS0,
+ &board_nb4_ser_r0,
+ &board_nb4_ser_r1,