summaryrefslogtreecommitdiffstats
path: root/target/linux/zynq/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-02-12 08:29:24 +0000
committerJohn Crispin <john@openwrt.org>2016-02-12 08:29:24 +0000
commit2d45ad07fc64b04a2e723a77491d450a1664cdec (patch)
treedcb49bd7f86d031de8783ad5f915996d37eb38df /target/linux/zynq/profiles
parent69517e88bea6ac19626dbff16cdc5e4a9f55cc25 (diff)
downloadmaster-31e0f0ae-2d45ad07fc64b04a2e723a77491d450a1664cdec.tar.gz
master-31e0f0ae-2d45ad07fc64b04a2e723a77491d450a1664cdec.tar.bz2
master-31e0f0ae-2d45ad07fc64b04a2e723a77491d450a1664cdec.zip
zynq: add new target
Add support for Xilinx ZC702 Dev board Zynq target is using 4.4 kernel and mainline 2016.1 u-boot. Patch is tested with Xilinx ZC702 Dev board with SD boot mode. known issues: - no QSPI driver in 4.4 kernel: no QSPI flash support - USB is not working in 4.4 kernel Signed-off-by: Jason Wu <jason.wu.misc@gmail.com> create mode 100644 package/boot/uboot-zynq/Makefile create mode 100644 target/linux/zynq/Makefile create mode 100644 target/linux/zynq/base-files.mk create mode 100755 target/linux/zynq/base-files/etc/board.d/02_network create mode 100644 target/linux/zynq/base-files/etc/config/network create mode 100644 target/linux/zynq/base-files/etc/inittab create mode 100644 target/linux/zynq/config-4.4 create mode 100644 target/linux/zynq/image/Makefile create mode 100755 target/linux/zynq/image/mkits.sh create mode 100644 target/linux/zynq/patches-4.4/0001-arm-dts-zynq-zc702.dts-Set-default-rdinit-to-sbin-in.patch create mode 100644 target/linux/zynq/profiles/zc702.mk SVN-Revision: 48697
Diffstat (limited to 'target/linux/zynq/profiles')
-rw-r--r--target/linux/zynq/profiles/zc702.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/zynq/profiles/zc702.mk b/target/linux/zynq/profiles/zc702.mk
new file mode 100644
index 0000000000..9d3c972fa6
--- /dev/null
+++ b/target/linux/zynq/profiles/zc702.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZC702
+ NAME:=ZC702 development baord
+endef
+
+define Profile/ZC702/Description
+ Build firmware image for Xilinx Zynq ZC702 development board.
+endef
+
+$(eval $(call Profile,ZC702))