summaryrefslogtreecommitdiffstats
path: root/target/linux/xburst
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 12:25:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 12:25:45 +0000
commitd7f6b8e3bead839ccf3b253c5b846f673348a12e (patch)
tree9f39bc9c5e674cb87c65303a7736430fdbef88bd /target/linux/xburst
parent282894a407220231b9350f240aea66bef6f38fe7 (diff)
downloadmaster-31e0f0ae-d7f6b8e3bead839ccf3b253c5b846f673348a12e.tar.gz
master-31e0f0ae-d7f6b8e3bead839ccf3b253c5b846f673348a12e.tar.bz2
master-31e0f0ae-d7f6b8e3bead839ccf3b253c5b846f673348a12e.zip
xburst: fix imagebuilder
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45805
Diffstat (limited to 'target/linux/xburst')
-rw-r--r--target/linux/xburst/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 49bb254164..58436d5359 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -31,8 +31,12 @@ define MkImageGzip
-d $(1).gz $(2)
endef
+define Image/Prepare
+ $(call MkImageGzip,$(KDIR)/vmlinux,$(KDIR)/uimage)
+endef
+
define Image/BuildKernel
- $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
+ cp $(KDIR)/uimage $(UIMAGE)
endef
define Image/Build/squashfs