summaryrefslogtreecommitdiffstats
path: root/target/linux/xburst
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-12 21:44:48 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-12 21:44:48 +0000
commitc808a4a7efd0342cb565958dcd43bdd75d432ded (patch)
treea486fbe7714ac03abca702166ff283bcddfca92d /target/linux/xburst
parent05625233edb53fb9bcf053b35bcb3e6d4e2233b5 (diff)
downloadmaster-31e0f0ae-c808a4a7efd0342cb565958dcd43bdd75d432ded.tar.gz
master-31e0f0ae-c808a4a7efd0342cb565958dcd43bdd75d432ded.tar.bz2
master-31e0f0ae-c808a4a7efd0342cb565958dcd43bdd75d432ded.zip
ubifs: enable building modular images
Now it is possible to build ubi/ubifs images for only selected boards inside single target. Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38375
Diffstat (limited to 'target/linux/xburst')
-rw-r--r--target/linux/xburst/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 9c03b38092..0de5560c96 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -10,11 +10,11 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=256k 512k
ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBI_OPTS = -m 4096 -p 512KiB
UBIFS_OPTS = -m 4096 -e 516096 -c 4095
-UBINIZE_OPTS = -m 4096 -p 512KiB
else
+UBI_OPTS = -m 2048 -p 128KiB -s 512
UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
-UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
endif
UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin