summaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/xburst/image
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadmaster-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/xburst/image')
-rw-r--r--target/linux/xburst/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 199ba2b7d4..c445494c74 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -18,7 +18,7 @@ UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
endif
define Image/BuildKernel
- cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
+ cp $(LINUX_DIR)/arch/mips/boot/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
endef
define Image/Build/squashfs
@@ -26,7 +26,7 @@ define Image/Build/squashfs
endef
define Image/Build
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(SUBTARGET)-root.$(1) bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
$(eval $(call BuildImage))