summaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/image
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-05-12 23:12:41 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-05-12 23:12:41 +0000
commit946c8fa59adb937542c1b193d4226388f2cd9659 (patch)
treedce4b02656aa9541595451e805cdcda4ae2ca403 /target/linux/xburst/image
parent37a8f3522fcfb961c94f102b4a5d9ad936d04de7 (diff)
downloadmaster-31e0f0ae-946c8fa59adb937542c1b193d4226388f2cd9659.tar.gz
master-31e0f0ae-946c8fa59adb937542c1b193d4226388f2cd9659.tar.bz2
master-31e0f0ae-946c8fa59adb937542c1b193d4226388f2cd9659.zip
Add 2.6.34 patches
SVN-Revision: 21438
Diffstat (limited to 'target/linux/xburst/image')
-rw-r--r--target/linux/xburst/image/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index c445494c74..9c03b38092 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -17,8 +17,22 @@ UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
endif
+UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
+
+define kernel_entry
+0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
+endef
+
+
+define MkImageGzip
+ gzip -9 -c $(1) > $(1).gz
+ mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
+ -e $(call kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(1).gz $(2)
+endef
+
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/mips/boot/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
+ $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
endef
define Image/Build/squashfs